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1 Introduction 
1.1 About the User Manual 

This user manual contains a description for the netLINK NL 50-MPI with an 
integrated netX 50 communication controller. This device is a successor of 
the netLINK NL-MPI. 

This user manual contains information for commissioning and use of the 
device.  

 

1.1.1 List of Revisions 
Index Date Chapter Revisions 
4 2009-06-07 1.1.2 

1.1.3 
1.1.4 
3.3, 4.2 
8.3 
10.1 

Hardware revision 4 added 
Firmware V2.004 added 
Reference on SyCon Software added  
PROFIBUS interface is isolated from hardware revision 4  
Name of Pin 2 and 5 for the hardware revision  
PROFIBUS interface is isolated from hardware revision 4  

5 2011-09-13 1.1.3 
3.3 
 
5.1 
7.2 
13.1 

Section Reference on Firmware updated 
Section Preconditions for NL 50-MPI Operation: Windows® Vista and 
Windows® 7 added, DVD 
Section Installing Software from DVD updated 
Section Failure in 10 MBit/s Half Duplex Mode and Workaround added 
Section Disposal of Waste Electronic Equipment added 

Table 1: List of Revisions 
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1.1.2 Reference on Hardware 
Hardware Revision 
NL 50-MPI  Rev 2, Rev 3, Rev 4 

Table 2: Reference on Hardware 

 

1.1.3 Reference on Firmware 
Firmware Version 
nl50mpi.e50  2.000 

2.004  
2.145 

Table 3: Reference on Firmware 

 

1.1.4 Reference on SyCon Software  
Software Version 
SyCon 2.950 (Installation)  

Table 4: Reference on SyCon Software  

 

1.1.5 Conventions in this Manual 
Operating Instructions, a result of an operation step or notes are marked as 
follows: 

Operating Instructions: 
 <instruction> 

 

or 
 

1. <instruction> 

2. <instruction> 

Results: 
 <result> 

 

Notes: 
 

 
Note:  <note> 
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1.2 Contents of the Product DVD 
The Product DVD for the netLINK contains: 

• Documentation  

• STEP 7® Driver IBHNet  

• System Configurator SyCon  

• Hilscher IP driver  

 

1.2.1 Directory Structure of the DVD 
All manuals on this DVD are delivered in the Adobe Acrobat® Reader 
format (PDF).  
 

Directory Name Description 
API Files for the configuration and communication interface (API) of 

the netLINK  
Documentation Documentation in the Acrobat® Reader Format (PDF) 
EDS Files needed from SyCon during installation.  
Firmware Loadable Firmware 
fscommand Installation support routines used during the installation process 
IBHnet IBH driver setup program. 
Sycon System Configurator SyCon (configuration program). Setup 

program. 
TcpUdpIpDriver Setup program for the Hilscher IP Driver  

Table 5: Directory Structure of the DVD 
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1.2.2 Overview of relevant Documentation 
The following documentation overview gives information, for which items 
you can find further information in which manual. 

Documentation for Users  
Manual Contents Document name 
netLINK NL 50-MPI Installation, Operation and Hardware 

Description 
netLINK NL 50-MPI UM xx EN.pdf  
(this document) 

SyCon Description of the configuration software 
SyCon 

SyCon_netLINK_en.pdf  

IBHNet Describes the installation and configuration of 
the IBH driver for the use of the NL 50-MPI 
device as PG Interface with Simatic® STEP® 7. 
The netLINK NL 50-MPI device is designated 
as IBH Link S7++.  

IBHNet_Manual.pdf  
This description was created by 
IBHsoftec Gesellschaft für 
Automatisierungstechnik mbH .  

Table 6: Documentations for netLINK 50-MPI for users  

For the configuration of the NL 50-MPI device the configuration software 
SyCon or the IBH driver can be used.  

 

Documentation for Developers  
Manual Contents Document name 
IP Driver Description of the Hilscher IP driver  Drv_Ip.pdf  
netIdent Description of the Hilscher netIdent protocol netIdent_Protocol_API_en.pdf  
MPI Protocol Interface 
Manual for netLink 

Description of the netLINK MPI protocol 
interface 

netLINK_MPI_Protocol_API_en.pdf  

FDL Protocol Interface 
Manual for netLink 

Description of the netLINK FDL protocol 
interface 

netLINK_FDL_Protocol_API_en.pdf  

Table 7: Documentations for netLINK 50-MPI for developers  
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1.3 Legal Notes 

1.3.1 Copyright  
© Hilscher, 2008-2011, Hilscher Gesellschaft für Systemautomation mbH   

All rights reserved. 

The images, photographs and texts in the accompanying material (user 
manual, accompanying texts, documentation, etc.) are protected by 
German and international copyright law as well as international trade and 
protection provisions. You are not authorized to duplicate these in whole or 
in part using technical or mechanical methods (printing, photocopying or 
other methods), to manipulate or transfer using electronic systems without 
prior written consent. You are not permitted to make changes to copyright 
notices, markings, trademarks or ownership declarations. The included 
diagrams do not take the patent situation into account. The company 
names and product descriptions included in this document may be 
trademarks or brands of the respective owners and may be trademarked or 
patented. Any form of further use requires the explicit consent of the 
respective rights owner. 
 

 

1.3.2 Important notes 
The user manual, accompanying texts and the documentation were created 
for the use of the products by qualified experts, however, errors cannot be 
ruled out. For this reason, no guarantee can be made and neither juristic 
responsibility for erroneous information nor any liability can be assumed. 
Descriptions, accompanying texts and documentation included in the user 
manual do not present a guarantee nor any information about proper use 
as stipulated in the contract or a warranted feature. It cannot be ruled out 
that the user manual, the accompanying texts and the documentation do 
not correspond exactly to the described features, standards or other data of 
the delivered product. No warranty or guarantee regarding the correctness 
or accuracy of the information is assumed.  

We reserve the right to change our products and their specification as well 
as related user manuals, accompanying texts and documentation at all 
times and without advance notice, without obligation to report the change. 
Changes will be included in future manuals and do not constitute any 
obligations. There is no entitlement to revisions of delivered documents. 
The manual delivered with the product applies.  

Hilscher Gesellschaft für Systemautomation mbH is not liable under any 
circumstances for direct, indirect, incidental or follow-on damage or loss of 
earnings resulting from the use of the information contained in this 
publication. 

 

 



Introduction 10/65 

netLINK NL 50-MPI Ethernet | Installation, Operation and Hardware Description  
DOC080604UM05EN | Revision 5 | English | 2011-09 | Released | Public  © Hilscher, 2008-2011 

1.3.3 Exclusion of liability 
The delivered product (including the technical data) is subject to export or 
import laws as well as the associated regulations of different counters, in 
particular those of Germany and the USA. The software may not be 
exported to countries where this is prohibited by the United States Export 
Administration Act and its additional provisions. You are obligated to 
comply with the regulations at your personal responsibility. We wish to 
inform you that you may require permission from state authorities to export, 
re-export or import the product. 

 

 

1.3.4 Warranty 
Although the hardware and software was developed with utmost care and 
tested intensively, Hilscher Gesellschaft für Systemautomation mbH does 
not guarantee its suitability for any purpose not confirmed in writing. It 
cannot be guaranteed that the hardware and software will meet your 
requirements, that the use of the software operates without interruption and 
that the software is free of errors. No guarantee is made regarding 
infringements, violations of patents, rights of ownership or the freedom from 
interference by third parties. No additional guarantees or assurances are 
made regarding marketability, freedom of defect of title, integration or 
usability for certain purposes unless they are required in accordance with 
the law and cannot be limited. Warranty claims are limited to the right to 
claim rectification. 
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1.3.5 Export Regulations 
The delivered product (including the technical data) is subject to export or 
import laws as well as the associated regulations of different counters, in 
particular those of Germany and the USA. The software may not be 
exported to countries where this is prohibited by the United States Export 
Administration Act and its additional provisions. You are obligated to 
comply with the regulations at your personal responsibility. We wish to 
inform you that you may require permission from state authorities to export, 
re-export or import the product. 

 

1.3.6 Registered Trademarks 
Windows® 2000/Windows® XP/Windows® Vista/ Windows® 7 are registered 
trademarks of Microsoft Corporation. 

Acrobat®  is a registered trademark of Adobe Systems, Inc in the USA and 
further countries. 

Pentium® is a registered trademark of Intel Corporation in the USA and 
further countries. 

S7, S7-300, S7-400 and MPI are registered trademarks of Siemens AG, 
Berlin and Munich. 

1.4 Licenses 
The NL 50-MPI device contains a license for the use with the IBH driver.  
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2 Safety 
2.1 Safety notes 

The user manual, accompanying texts and the documentation were created 
for the use of the products by qualified experts. When using the products, 
all safety notes and applicable regulations must be observed. Technical 
knowledge is required. The user must comply with legal provisions. 

2.2 Intended Use 
The netLINK NL 50-MPI may only be used as a part of a communication 
system as described in this manual. It has been designed exclusively for 
use in connection with the S7-300 und S7-400 PLCs manufactured by 
Siemens AG.  

The device may not be opened or be used when the housing has been 
removed.  

2.3 Personnel Qualification 
The NL 50-MPI is used as a part of a system which must fulfill safety and 
accident precaution regulations depending on the respective conditions of 
use. The user of the system is exclusively responsible for the fulfillment of 
those regulations. 

Therefore the system to which the NL 50 MPI belongs may only be used by 
personnel who has been informed and educated about all relevant 
regulations. 
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2.4 Labeling of Safety Instructions 
The safety instructions are pinpointed particularly. The instructions are 
highlighted with a specific safety symbol, a warning triangle and a signal 
word according to the degree of endangerment. Inside the note the danger 
is exactly named. Instructions to a property damage message do not 
contain a warning triangle. 
Symbol Sort of Warning or Principle 

 

Safety symbol for the warning to personal injury 

 

Warning of danger by electrical current 
 

 

Warning of damages by electrostatic discharge 

Table 8: Safety Symbols and Sort of Warning or Principle 

2.4.1.1 Signal Words 
Signal 
Word 

Meaning 

DANGER indicates a direct hazard with high risk, which will have as consequence 
death or grievous bodily harm if it isn't avoided. 
The use of this signal word shall be restricted to extremely hazard. 
Remark: The signal word may not be used in case of danger of pure 
property damages. 

WARNING indicates a possible hazard with medium risk, which will have as 
consequence death or (grievous) bodily harm if it isn't avoided. 
Remark: The signal word may not be used in case of danger of pure 
property damages. 

CAUTION indicates a minor hazard with medium risk, which could have as 
consequence simple battery if it isn't avoided. 

Note Indicates an important note in the manual. 

Table 9: Signal Words 

2.4.1.2 Signal Words USA 
Signal 
Word 

Meaning 

DANGER Indicates a Hazardous Situation Which, if not Avoided, will Result in 
Death or Serious Injury. 

WARNING Indicates a Hazardous Situation Which, if not Avoided, could Result in 
Death or Serious Injury. 

CAUTION Indicates a Hazardous Situation Which, if not Avoided, may Result in 
Minor or Moderate Injury. 

NOTICE Indicates a Property Damage Message. 
Note Indicates an Important Note in the Manual.  

Table 10: Signal Words according to ANSI  
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2.5 Safety Instructions 
This manual contains instructions which must be observed to ensure your 
own personal safety and to avoid damage to devices of your system.  

2.5.1 Electrical Current 
 

 
CAUTION! 

Device Destruction! 
 Use only 18..30 V for power supply to operate the device.  
Operation with more than 30 V power supply voltage will lead to 
destruction of the device. 

 

2.5.2 Electrostatic Discharge 
Adhere to the necessary safety precautions for components that are 
vulnerable with electrostatic discharge (EN 61340-5-1 und EN 61340-5-2 
as well as IEC 61340-5-1 und IEC 61340-5-2). 
 

 
CAUTION! 

Electrostatic Discharge 
This equipment is sensitive to electrostatic discharge, which cause 
internal damage and affect normal operation. Follow guidelines when you 
handle this equipment: 

 Touch a grounded object to discharge potential static. 

 Do not touch connectors or pins. 

 Do not touch circuit components inside the equipment. 

 When not in use, store the equipment in appropriate static-safe 
packaging. 
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2.6 Safety Instructions USA 
This manual contains instructions which must be observed to ensure your 
own personal safety and to avoid damage to devices.  

2.6.1 Electrical Current 
 

 
 

 
Device Destruction! 
 Use only 18..30 V for power supply to operate the device.  
Operation with more than 30 V power supply voltage will lead to 
destruction of the device. 

 

 

2.6.2 Electrostatic Discharge 
Adhere to the necessary safety precautions for components that are 
vulnerable with electrostatic discharge (EN 61340-5-1 und EN 61340-5-2 
as well as IEC 61340-5-1 und IEC 61340-5-2). 
 

 
 

 
Electrostatic Discharge 
This equipment is sensitive to electrostatic discharge, which cause 
internal damage and affect normal operation. Follow guidelines when you 
handle this equipment: 

 Touch a grounded object to discharge potential static. 

 Do not touch connectors or pins. 

 Do not touch circuit components inside the equipment. 

 When not in use, store the equipment in appropriate static-safe 
packaging. 

 

 

 

 



Description and Requirements 16/65 

netLINK NL 50-MPI Ethernet | Installation, Operation and Hardware Description  
DOC080604UM05EN | Revision 5 | English | 2011-09 | Released | Public  © Hilscher, 2008-2011 

3 Description and Requirements 
3.1 Description 

The netLINK NL 50-MPI device described in this user manual is an 
Ethernet Gateway based on netX technology. This device is a successor of 
the netLINK-MPI (NL-MPI) which was based on an EC1 controller circuit. 

The device is designed to provide compatibility to the netLINK-MPI with 
respect to the communication and configuration interfaces. It is built into a 
DSub housing. It consists of a PROFIBUS Master together with a 10/100 
MBit/s Ethernet interface and thus represents a complete gateway, which 
can detect via Auto Detection whether it is connected to a network with a 
transmission rate of 10 or 100 MBit/s. 

Because of its structure in the DSub housing, it can be plugged directly on 
to the Fieldbus connection of an MPI capable device and connects this, 
using an external Ethernet cable to the next Ethernet switch, hub or device. 

The power supply is provided directly by the netLINK MPI-Interface or 
externally.  

The Configuration (set IP-Address, PROFIBUS parameter etc.) is carried 
out via the Ethernet. For this purpose either  

• the configuration software SyCon or alternatively  

• the IBH driver  

can be used.  

A diagnostic channel to the NL 50-MPI is established via TCP/IP, which 
operates through a predefined port parallel to the user data transmission. 
The configuration is saved in the NL 50-MPI in a FLASH memory and is 
therefore also available after a power reset. 

 

The NL 50-MPI device can be used as PG Interface with Simatic® STEP® 
7 when the IBH driver is used. The configuration of the NL 50-MPI device 
with SyCon is not necessary in this use case, because the configuration 
can be done with the IBH driver. The description of the installation and 
configuration of the IBH driver is described in the document 
IBHNet_Manual.pdf on the DVD.  

 



Description and Requirements 17/65 

netLINK NL 50-MPI Ethernet | Installation, Operation and Hardware Description  
DOC080604UM05EN | Revision 5 | English | 2011-09 | Released | Public  © Hilscher, 2008-2011 

3.2 System Requirements 
For a reasonable application of the NL 50-MPI, a suitable power supply is 
required. Power supply is possible either internally via the MPI respectively 
the PROFIBUS interface of the S7 PLC or externally via the Mini-Combicon 
socket right beside the Ethernet socket. 

The voltage to be applied must be in the range between 18 V und 30 V. 

 

3.3 Preconditions for NL 50-MPI Operation 
The following preconditions must be met in order to operate the NL 50-MPI 
device successfully: 

1. A suitable power supply as described above is required. 
 

 
CAUTION! 

Device Destruction! 
 The reference potential of the power supply is galvanically connected 
with the reference potential of the PROFIBUS for hardware revision 2 
and 3 of the device. From this it follows that the power supply must be 
potential free! 

 

 
 

 
Device Destruction! 
 The reference potential of the power supply is galvanically connected 
with the reference potential of the PROFIBUS for hardware revision 2 
and 3 of the device. From this it follows that the power supply must be 
potential free! 

 

With hardware revision 4 of the NL 50-MPI device the power supply of the 
device and the PROFIBUS interface is connected via optocoupler and 
hence galvanically separated.  

 

2. The device must have been configured correctly using the system 
configurator SyConND. 

 

The necessary system requirements for the application of the system 
configurator SyConND are: 

1. PC with 586-, Pentium® processor or higher  

2. Windows® 2000, Windows® XP, Windows® Vista (32-Bit), Windows® 7 
(32-Bit) or Windows® 7 (64-Bit) 

3. Free space on hard disk: 30-80 MByte  

4. DVD ROM drive  

5. RAM: min. 16 MByte  

6. Graphics resolution: min 800 x 600 pixels  

7. Keyboard and mouse for input and operation 
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3.4 Compatibility of the netLINK NL 50-MPI to the NL-MPI 
The netLINK NL 50-MPI is compatible to the netLINK NL-MPI with respect 
to the following details: 

• The communication functionality for user data exchange is compatible. 

• The configurations of both device are compatible. 

With respect to the diagnostic functions there is only a partial compatibility. 
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4 Getting Started 
4.1 Mount 

The NL 50-MPI is slipped and screwed on a S7 MPI / PROFIBUS interface 
or another compatible device with the MPI / PROFIBUS interface of the NL 
50-MPI. 

4.2 Power Supply 
The power supply of the NL 50-MPI can be performed by directly plugging 
the device onto a PLC. Alternatively to the direct power supply method by 
the PLC there is the possibility for external power supply with a voltage of 
24 V using the Mini-Combicon connector. 
 

 
CAUTION! 

Device Destruction! 
 The reference potential of the power supply is galvanically connected 
with the reference potential of the PROFIBUS for hardware revision 2 
and 3 of the device. From this it follows that the power supply must be 
potential free! 

 

 
 

 
Device Destruction! 
 The reference potential of the power supply is galvanically connected 
with the reference potential of the PROFIBUS for hardware revision 2 
and 3 of the device. From this it follows that the power supply must be 
potential free! 

 

With hardware revision 4 of the NL 50-MPI device the power supply of the 
device and the PROFIBUS interface is connected via optocoupler and 
hence galvanically separated.  

 

4.3 Ethernet Connection 
The Ethernet connector of the NL 50-MPI is connected to a switch, hub or 
Ethernet end device by an Ethernet cable.  

The NL 50-MPI operates its Ethernet interface in the Auto-crossover mode. 
Thus for the connection with Ethernet devices both crossover cables and 
patch cables are applicable. 
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5 Installing Software 
5.1 Installing Software from DVD 

To install the software: 

 Close all application programs on the system! 

 Insert the DVD in the local DVD ROM drive.  

 The installation routine will start automatically (Auto start feature 
enabled). Otherwise change to the root directory of the DVD and start 
the EXE file (Auto start feature disabled). 

 

 
Note: Administrator privileges are required on Windows® 2000/ 
Windows® XP/Windows® Vista/Windows® 7 systems for installation! 

 

 
Figure 1: Menu of the DVD autostart  

The menu offers for installation the following: 

• Install STEP 7® Driver IBHNet 

• Install SyCon Configuration Tool (the Hilscher IP Driver can be installed 
during the installation of SyCon).  

• Open Ducumentations Directory 

To configure the netLINK NL 50-MPI device you can use either the IBHnet 
driver or SyCon.  

For the system configurator SyCon no license is required as the basic 
version already contains all functions necessary for the operation of the 
netLINK NL 50-MPI.  
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5.2 Install IP Driver 
Some application programs use the Hilscher IP Driver to communicate with 
the netLINK NL 50-MPI device.  

The installation program for the Hilscher IP driver is on the DVD in the 
TcpUdpIpDriver folder.  

 Start on the DVD in the folder TcpUdpIpDriver the setup.exe. 

 At the first screen, you simply have to click at the Next button in order 
to proceed. 

 
Figure 2: Install IP Driver (1) 

 Then some information about the IP driver is displayed on the screen. 
You should read this text carefully! 

 At the next screen, you are asked to specify the storage location for the 
Hilscher IP Driver. You may choose the proposed standard location or 
choose another one after clicking the Browse button. Then click the 
Next button again in order to proceed. 

 
Figure 3: Install IP Driver (2) 
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 After that, you will reach the final screen indicating that the installation 
process has been completed. 

 
Figure 4: Install IP Driver (3) 

 After the installation the driver has to be configured correctly, i.e. the IP 
address and the port number of the NL 50-MPI need to be specified as 
described in the next section of this document. 
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6 Configuration  
6.1 Configuration of the IP Driver  

 Start the configuration program of the Hilscher IP Driver with Start > 
Programs > Hilscher IP Driver > IP Driver Setup. The GUI of the 
Hilscher IP Driver Setup program will appear then: 

 
Figure 5: GUI of the Hilscher IP Driver Setup 

 Enter the configured IP address of the NL 50-MPI in the field IP 
Address and the Port number in the field Port.  

 The following settings are necessary: 
Field Required action 
Port Set the port to 1099. 
Protocol Set the protocol to TCP. 
Mode Set the mode to Client. 

Table 11: Configuring IP Driver 

 Connect Timeout (ms): 
In client mode this field holds the time period the driver tries to establish 
a connection with the selected device. 
 

 
Note: A too small time out value can prevent correct connection 
establishment to the device. 

 

 
Note: If this configuration shall be changed later again, the program  
IpDrvSetup.exe and also the programs which use the driver need to be 
restarted. 

 

 
Note: If the PC is behind a Firewall, then port 1099 has to be unblocked. 
For this, contact your network administrator. 
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6.2 Creating and downloading the Configuration 

6.2.1 Overview 
 

 
Note: The configuration of the NL 50-MPI is done via TCP/IP. 

 

To create and to download the configuration of the NL 50-MPI device, 
proceed as follows: 

1. Start the System configurator SyCon: 

 Therefore select Start > Programs > SyCon System Configurator > 
SyCon. 

 

2. Open a new project: 

 Therefore select File > New or File > New > netLINK. 

 

3. Enter the NL50-MPI device to the project: 

 Select the menu Insert > Device. 

 In the window Insert Device under Available devices select the device 
NL50-MPI. 

 Select the button Add. 

 Select the button OK. 

 

4. Setting the IP address and the PROFIBUS parameters: 

 Select the menu Settings > netLINK Parameter or double click to the 
NL50-MPI device symbol. 

 The parameter window is displayed. 

 Set the IP address (if necessary also the Net Mask and the gateway 
address). 

A description of these parameters is included in the section IP Address on 
page 38.  

 

 Set the PROFIBUS parameters (especially the station address and the 
bus parameters). 

A description of the PROFIBUS parameters are in the section PROFIBUS 
Parameter on page 40. 
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5. Connecting the System configurator SyCon with the NL 50-MPI device: 

 Select the menu Settings > Device Assignment.  
 Select in the window Driver Select the driver CIF TCP/IP Driver. 
 Click to the OK button. 

 The window Device Assignment ODM TCP/IP Drive is displayed.   

 Click to the netIdent Rescan button. 

 The local Ethernet network is scanned for devices. The detected 
devices are displayed under Board Selection.  

 In the list Board Selection mark the check box for NL 50-MPI device.  

 A connection from the System configurator SyCon to the NL 50-MPI 
device has been established 

 Select the button OK. 

 The window Device Assignment ODM TCP/IP Drive is closed, 

 

6. Downloading the configuration to the device: 

 Select the menu Online > Download. 

 The safety question is displayed, if the download should be executed.  

 Select the button Yes.  

 The configuration is downloaded to the device.  

 

7. Take over the configuration - therefore make a reset to the device: 

 Select the menu Online > Firmware/Reset. 
 The window Firmware/Reset is displayed.  

 Select the button Reset. 
 The safety question is displayed, if the reset shall be executed.  

 Select the button Yes.  

 The reset is executed. By this the configuration is taken over. 

 

8. Saving the SyCon project: 

 Select the menu File > Save under. 
 The window Save under is displayed. 

 Enter the file name for the project. 

 Select the button OK. 

 The project is saved. 
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6.2.2 Description of the single Steps 
Step 1:  
The System configurator SyCon: 

 Therefore select Start > Programs > SyCon System Configurator > 
SyCon. 

 

Step 2:  
Open a new project: 

 Therefore select File > New or File > New > netLINK. 

 An empty project file (configuration file) is created and is displayed. 

 
Figure 6: System configurator SyCon - Open a new project 
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Step 3:  
Enter the NL50-MPI device to the project:: 

 Select the menu Insert > Device. 

 The window Insert Device is displayed. 

 
Figure 7: Insert Device 

 Under Available devices select the device NL50-MPI. 
 Select the button Add. 

 Select the button OK. 

 The NL50-MPI device is displayed in the SyCon project or the 
configuration file. 

 
Figure 8: System configurator SyCon – The NL50-MPI device is displayed in the project 
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Step 4:  
Set IP address and PROFIBUS parameters: 

 Select the menu Settings > netLINK Parameter or double click to the 
NL50-MPI device symbol. 

 The parameter window is displayed. 

 

Step 4A:  
 Set the IP address (if necessary also the Net Mask and the gateway 

address). 

A description of these parameters is included in the section IP Address on 
page 38.  

 
Figure 9: Set the IP address 

 

Step 4B:  
 The Ethernet parameters are detected automatically by the device.  

A description of the Ethernet parameters are in the section Ethernet 
Parameter on page 39. 

 
Figure 10: The Ethernet parameters are detected automatically by the device 
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Step 4C:  
 Set the PROFIBUS parameters (especially the station address and the 

bus parameters). 

A description of the PROFIBUS parameters are in the section PROFIBUS 
Parameter on page 40. 

 

 
Figure 11: Set the PROFIBUS parameters 

 

 Select the button OK. 

 The parameter window is closed. 

 



Configuration 30/65 

netLINK NL 50-MPI Ethernet | Installation, Operation and Hardware Description  
DOC080604UM05EN | Revision 5 | English | 2011-09 | Released | Public  © Hilscher, 2008-2011 

Step 5:  
Connecting the System configurator SyCon with the NL 50-MPI device: 

Therefore: 

A.) Select the driver CIF TCP/IP Driver. 
B.) Scan for the NL 50-MPI device. 

C.) If necessary, change and assign the IP address manually. 

D.) Connect the System configurator SyCon with the NL 50-MPI device. 

 

Proceed as follows: 

Step 5A:  Select the driver CIF TCP/IP Driver: 
 Select the menu Settings > Device Assignment.  
 The Driver Select window is displayed. 

 
Figure 12: Window Driver Select 

 Select in the window Driver Select the driver CIF TCP/IP Driver. 
 Click to the OK button. 

 The window Device Assignment ODM TCP/IP Drive is displayed.   
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Figure 13: Window Device Assignment ODM TCP/IP Drive 
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Step 5B:  Scan for the NL 50-MPI device: 

 In the window Device Assignment ODM TCP/IP Drive click to the 
netIdent Rescan button. 

 The local Ethernet network is scanned for devices. The detected 
devices are displayed under Board Selection.  

 
Figure 14: Window Device Assignment ODM TCP/IP Drive – The detected device is 
displayed  

 If one or more devices were found, they are displayed in the list Board 
Selection with their MAC-ID. If the device already has an IP address 
this is shown in the field IP Address. 
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Step 5C: If necessary, change and assign the IP address manually. 

If the shown IP address is 0.0.0.0 or the IP address shall be changed, an IP 
address has to be assigned to the device. 

 In the window Device Assignment ODM TCP/IP Drive in the list 
Board Selection mark the check box for NL 50-MPI device.  

 Select the button Set IP Address. 
 The window Configure IP Address is displayed. 

 
Figure 15: Window Configure IP Address 

 Enter a valid IP address.  

 
Figure 16: Window Configure IP Address – Set the IP address  

 

 
Note: With Set IP only a temporarily IP address is set in the device. To set 
a permanent IP address a configuration download has to be done.  

 

 
Note: When the IP address set in this step 5C and the IP address entered 
in step 4A are different, then the IP address of step 4A is used from the 
device after a download of the configuration and a reset.  

 

 Select the button Set IP. 

 The IP address is assigned to the device. 

 The hint window Setting IP address successful! is displayed. 

  
Figure 17: Hint – Setting IP address successful! 

 In the hint window click to the button OK. 

 Select in the window Configure IP Address the button Exit. 
 The window Configure IP Address is closed. 
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Step 5D:  Connect the System configurator SyCon with the NL 50-MPI 
device: 

 In the window Device Assignment ODM TCP/IP Drive in the list 
Board Selection mark the check box for NL 50-MPI device.  

 A connection from the System configurator SyCon to the NL 50-MPI 
device has been established. 

 
Figure 18: Window Device Assignment ODM TCP/IP Drive – A connection has been 
established. 

 

 Select the button OK. 

 The window Device Assignment ODM TCP/IP Drive is closed. 
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Step 6:  
Download the configuration to the device: 

 Select in the System configurator SyCon the menu Online > 
Download. 

 The safety question is displayed, if the download should be executed.  

 
Figure 19: Question – Do you really want to download? 

If the download must not be executed: 

 Select the button No.  

 The download is not executed.  

If the download must be executed: 

 Select the button Yes.  

 The download is executed. During the download the progress bar Data 
Base Download is displayed. 

 
Figure 20: Progress Bar Data Base Download 

 The configuration is downloaded to the device.   
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Step 7:  
Take over the configuration - therefore make a reset to the device: 

 Select in the System configurator SyCon the menu Online > 
Firmware/Reset. 

 The window Firmware/Reset is displayed.  

 
Figure 21: Window Firmware/Reset 

 Select the button Reset. 
 The safety question is displayed, if the reset shall be executed.  

 
Figure 22: Question – Do you really want to reset the firmware? 

If the reset must not be executed: 

 Select the button No.  

 The reset is not executed.  

If the reset must be executed: 

 Select the button Yes.  

 The reset is executed. Thereby the configuration is taken over. 
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Step 8:  
Saving the project: 

 Select the menu File > Save under. 
 The window Save under is displayed. 

 Enter the file name for the project. 

 Select the button OK. 

 The project is saved. 
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6.3 Description of the Parameter  

6.3.1 IP Address 

 
Figure 23: Settings > NetLink Parameter > IP Address 

Description: 
The description of the device is shown in SyCon as the name of the device. 
The description is changeable in this field. 

The handing over of the IP parameters (IP address, Net mask, Gateway) 
can result in three ways. 

1. DHCP: 
The device gets the IP parameters from a DHCP server. 

2. BOOTP: 
The device gets the IP parameters from a BOOTP server. 

3. IP address, Net mask and Gateway: 
The IP parameters can be entered in this fields. If more than one 
configuration way is activated (for example DHCP and manually entered IP 
parameters), the device tries to process the different configuration way one 
after the other. As soon as it got an IP configuration in one of this ways, the 
device starts with this parameters. 
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6.3.2 Ethernet Parameter 

 
Figure 24: Settings > NetLink Parameter > Ethernet 

Description: 
The description of the device is shown in SyCon as the name of the device. 
The description is changeable in this field. 

Auto detect: 
This option is set. An automatic detection of the Ethernet interface is done 
by the device.  

Interface: 
Is detected automatically.  

Auto negotation: 
Auto negotation means, that in case of two connected devices the devices 
detect the hardware and the features (for example Half- or Full Duplex, 10 
or 100 Mbits and so on) of the other device. This option is preselected. 
Duplex mode: 
Duplex mode of the Ethernet interface. Is detected automatically.  

Speed: 
Transmission speed of the data in MBits/s: 10 MBits/s and 100 MBits/s. Is 
detected automatically.  
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6.3.3 PROFIBUS Parameter 

 
Figure 25: Settings > NetLink Parameter > PROFIBUS 

 

 
Note: Wrong configured PROFIBUS Parameters can lead to 
communication failures.  

 

The busparameters and their meaning: 

• Station Address 

The Station Address of the NetLink 

• Baudrate 

Transmission speed: Number of bits per second. 
Baudrate Bit Time (tBit) 
9,6 kBaud 104,2 us  
19,2 kBaud  52,1 us  
93,75 kBaud 10,7 us 
187,5 kBaud 5,3 us  
500 kBaud 2 us 
1,5 Mbaud  666,7 ns  
3 Mbaud  333,3 ns  
6 Mbaud  166,7 ns 
12 Mbaud  83,3 ns  

Table 12: Baud rates and Bit times 
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• Minimum Station Delay of Responders (min TSDR)  

This is the shortest time period that must elapse before a remote 
recipient (Responder) may send an acknowledgement of a received 
query telegram. The shortest time period between receipt of the last 
Bit of a telegram to the sending of the first Bit of a following telegram.  

Value range: 1.. 65535 

• Maximum Station Delay of Responders (max TSDR)  

This is the longest time period that must elapse before a Sender 
(Requestor) may send a further query telegram. Greatest time period 
between receipt of the last Bit of a telegram to the sending of the first 
Bit of a following telegram.  

The Sender (Requestor, Master) must wait at least for this time period 
after the sending of an unacknowledged telegram (e.g. Broadcast 
only) before a new telegram is sent.  

Value range: 1.. 65535 

• Slot Time (TSL) 

'Wait for receipt' – monitoring time of the Senders (Requestor) of 
telegram for the acknowledgement of the recipient (Responder). After 
expiration, a retry occurs in accordance with the value of 'Max. 
telegram retries'.  

Value range: 52.. 65535 

• Quiet Time (TQUI) 

This is the time delay that occurs for modulators (Modulator-trip time) 
and Repeaters (Repeater-switch time) for the change over from 
sending to receiving.  

Value range: 0.. 255 

• Setup Time (TSET) 

Minimum period “reaction time” between the receipt of an 
acknowledgement to the sending of a new query telegram (Reaction) 
by the Sender (Requestor). 

Value range: 1.. 255 

• Target Rotation Time (TTR) 

Pre-set nominal Token cycling time within the Sender authorization 
(Token) will cycle around the ring. How much time the Master still has 
available for sending data telegrams to the Slaves is dependent on 
the difference between the nominal and the actual token cycling time.  

Value range: 1.. 16.777.215  
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• GAP Update Factor (G) 

Factor for determining after how many Token cycles an added 
participant is accepted into the Token ring. After expiry of the time 
period G*TTR, the Station searches to see whether a further 
participant wishes to be accepted into the logical ring.  

Value range: 1.. 100  

• Max number of telegram retries (Max_Retry_Limit)  

Maximum number of repeats in order to reach a Station.  

Value range: 1.. 8  

• Highest Station Address (HSA)  

Station address of the highest active (Master) Station.  

Value range: 2.. 126 
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The device NL50-MPI supports the automatic baudrate detection.  
 

 
Note:  The automatic detection of the PROFIBUS baudrate can only be 
used, when additionally to the netLINK NL 50-MPI another PROFIBUS 
Master is available on the PROFIBUS network.  

 

 
Note:  The automatic detection of the PROFIBUS baudrate can only be 
used, when the control unit sends the PROFIBUS parameters via a 
broadcast telegram on the PROFIBUS network. 

 

 
Note:  A download of the configuration has to be done to activate these 
setting in the device. 

 

 
Note:  The device uses the new configuration/the new parameters after a 
reset.  

 

To set the automatic baudrate detection, select in the list of Bus profile the 
setting PROFIBUS and then select in the list Baud rate the setting 
AutoBaud.  

 

 
Figure 26: Settings > NetLink Parameter > PROFIBUS > Autobaud 
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6.4 Firmware Update – Firmware Download  
The section describes how to do a Firmware Update.  

 

Step A:  
 Start the System Configurator SyCon with Start > Programs > SyCon 

System Configurator > SyCon  
 

Step B:  
 Open an existing project/configuration file with the menu File > Open. 

The extension is *.nd.  

or  

 Create a configuration as it is described in steps 2, 3 and 4 in section 
Creating and downloading the Configuration from page 24.  

 

Step C:  
 With the menu Settings > Device Assignment create a connection to 

the device. This is describes in detail in Step 5 in section Creating and 
downloading the Configuration from page 24.  

 

Step D:  
 Select the menu  Online > Firmware Download.  

 A safety question is displayed.  

 
Figure 27: Question – Do you really want to download? 

If the download must not be executed: 

 Select the button No.  

 The download is not executed.  

If the download must be executed: 

 Select the button Yes.  

 The window Firmware Copy/Download is displayed.  
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Figure 28: Window Firmware Copy/Download 

 Select in Available Firmware Files section the directory that contains 
the firmware file, e. g. on the DVD. The firmware filename is 
nl50mpi.e50.  

 Press the button Download in Available Firmware Files section.  

 A safety question is displayed.  

 
Figure 29: Question – Do you really want to download the firmware? 

If the download must not be executed: 

 Select the button No.  

 The download is not executed.  
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If the download must be executed: 

 Select the button Yes.  

 The download is executed. During the download the progress bar Data 
Base Download is displayed. 

 
Figure 30: Progress Bar Data Base Download 

 

 After the firmware download was finished, press in the window 
Firmware Copy/Download the button Close.  

 

Step E:  
 Load with the menu Online > Download the configuration into the 

NL50-MPI device. This is describes in Step 6 in section Creating and 
downloading the Configuration from page 24.  

 

Step F:  
 The device uses the new firmware or the new configuration/new 

parameters after a reset. This is describes in Step 7 in section Creating 
and downloading the Configuration from page 24.   
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7 Troubleshooting 
7.1 Hints on how to solve Problems 

General 
 Check, if the following preconditions for NL 50-MPI operation are 

fulfilled: 

1. A suitable power supply must be available (internally from the S7 PLC 
or externally via the Combicon connector). 

2. The configuration must have been performed correctly using the system 
configurator SyConND. 

3. The IP driver must have been installed correctly. 

Further information to this is in section Preconditions for NL 50-MPI 
Operation on page 17. 

LNK-LED 
 With the Ethernet link status LED (LNK) of the NL 50-MPI it can be 

examined whether a connection to the Ethernet exists. If the LED is off, 
no connection exists. If the LED is on, the device has a connection to 
the Ethernet.  

ACT-LED 
 With the Status-LED ACT of the NL 50-MPI it can be examined whether 

communication takes place. 

Cable 
 Make sure that the cable is connected to the hub/ switch on the 

Ethernet side and that the serial inter-face is connected to the S7. 

Configuration  
 Check, whether the NL 50-MPI is configured according to the 

description given in section Creating and downloading the Configuration 
on page 24 of this document. 

Diagnostic using the System Configurator SyCon 
 Read out the data with the menu Online > Message Monitor. 

You can find more information about the Message Monitor and its functions 
you find in the operating manual SyConND/ System Configurator 
netDEVICE. 
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Ethernet-TCP/IP Interface 

 Check the network settings of your PC. 

With the ping command in MS-DOS Prompt you can easily check if a 
connection via TCP/IP to the NL 50-MPI is possible. Open the MS-DOS 
Prompt and enter ping 192.168.10.190 (the IP address has to be the same 
as set in the NL 50-MPI) and press the Return key. Could a connection be 
established then the answer is displayed by the following text Reply from 
192.168.10.190...  
Otherwise a connection timeout is displayed.  
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7.2 Failure in 10 MBit/s Half Duplex Mode and Workaround 
 

Affected Hardware 
Hardware with the communication controller netX 50, netX 100 or  
netX 500; netX/Internal PHYs. 

 
When can this  Failure occur? 
When using standard Ethernet communication with 10 MBit/s half duplex 
mode, the PHY gets stuck in case of network collisions. Then no further 
network communication is possible. Only device power cycling allows 
Ethernet communication again.  

This problem can only occur with Ethernet TCP/UDP IP, EtherNet/IP or 
Modbus TCP protocols when using hubs at 10 MBit/s. The issue described 
above is not applicable for protocols which use 100 MBit/s or full duplex 
mode. 

 

Solution / Workaround: 
Do not use 10 MBit/s-only hubs. Use either switches or 10/100 MBit/s Dual 
Speed hubs, to make sure the netX Ethernet ports are connected with 100 
MBit/s or in full duplex mode. 

This erratum is fixed with all components of the ‘Y’ charge (9 digit charge 
number shows ‘Y’ at position 5 (nnnnYnnnn). 

 

Reference 
“Summary of 10BT problemon EthernetPHY”,   
RenesasElectronics Europe, April 27, 2010 
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8 Device Drawings and Connections 
8.1 Device Drawing NL 50-MPI 

 
Figure 31: Device Drawing NL 50-MPI 

The pins of the PROFIBUS/MPI interface are connected through 1:1 to the 
programming device interface.  
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8.2 Ethernet Interface 
For the Ethernet interface use RJ45 plugs and twisted pair cable of 
category 5 (CAT5) or higher, which consists of 4 twisted cores and has a 
maximum transmission rate of 100 MBit/s (CAT5).  

8.2.1 Ethernet pinning at the RJ45 Socket 
 

 
Note: The device supports the Auto Crossover function. Due to this fact 
RX and TX can be switched. The following figure shows the RJ45 
standard pinning. 

 

 

PIN 1: TX+
PIN 2: TX-
PIN 3: RX+
PIN 4: TERM
PIN 5: TERM
PIN 6: RX-
PIN 7: TERM
PIN 8: TERM

 
Figure 32: Ethernet pinning at the RJ45 Socket 

Pin Signal Meaning 
1 TX+ Transmit Data + 
2 TX– Transmit Data – 
3 RX+ Receive Data + 
4 Term 1 
5 Term 1 

Connected to each other and 
terminated to PE through RC circuit* 

6 RX– Receive Data – 
7 Term 2 
8 Term 2 

Connected to each other and 
terminated to PE through RC circuit* 

  * Bob Smith Termination 

Table 13: Ethernet pinning at the RJ45 Socket 

 

8.2.2 Ethernet Connection Data 
Medium 2 x 2 Twisted-Pair copper cable, CAT5 (100 MBit/s) 
Length of cable max. 100 m 
Transmission rate 10 MBit/s / 100 MBit/s 

Table 14: Ethernet Connection Data 
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8.3 PROFIBUS Interface 

8.3.1 DSub Connector (9-Pin, Male and Female) 
The DSub plug (male connector) for putting onto the S7 PLC (or another 
MPI-capable device) and the DSub socket (female connector) for 
connecting a programming device internally have a 1 to 1-connection as 
can be seen in the table below:  

 

1
2
3
4
5

6
7
8
9

 
Figure 33: PROFIBUS Interface (DSub female connector, 9 pin)  

 

5
4
3
2
1

9
8
7
6

 
Figure 34: PROFIBUS Interface (DSub male connector, 9 pin)  

Connection 
with DSub 
female 
connector 

Connection 
with DSub 
male 
connector 

Signal Meaning 

1 1 - unused, is only connected through 
2 2 DGND 

 
GND 

Reference potential 
(for hardware revision 2 and 3) 
Ground (for VS) 
(for hardware revision 4) 

3 3 RxD/TxD-
P 

Receive / Send Data-P respectively 
connection B plug 

4 4 - unused, is only connected through 
5 5 DGND  

 
ISOGND 

Reference potential 
(for hardware revision 2 and 3) 
Reference potential (PROFIBUS) 
(for hardware revision 4)  

6 6 - unused, is only connected through 
7 7 VS Positive power supply (24 V) 
8 8 RxD/TxD-

N 
Receive / Send Data-N respectively 
connection A plug 

9 9 - unused, is only connected through 
Housing shield shield 

Table 15: PROFIBUS-MPI- Interfaces (DSub female and male connector, 9 pin) 
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8.4 External Power Supply 

8.4.1 Mini-Combicon Male Connector 
The netLINK NL 50-MPI device can be operated by a DC external power 
supply from 24V (18V – 30V). 
 

 
CAUTION! 

Device Destruction! 
 When using an external power supply, the potential of this power supply 
is DC coupled to that of the PROFIBUS. Consequently, the power 
supply must be potential free! 

 

 
 

 
Device Destruction! 
 When using an external power supply, the potential of this power supply 
is DC coupled to that of the PROFIBUS. Consequently, the power 
supply must be potential free! 

 

 Plug the DC power supply into the power jack located at the top side of 
the device. 

 
Pin Description 
1 Ground 
2 24V (18 - 30 V DC) 

Table 16: External Power Supply, (Mini-Combicon male Connector, 2 pin), 

 

0 +24

2
1

 
Figure 35: External Power Supply (Mini-Combicon male Connector, 2 pin), 
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9 LED 
LED Name Meaning 
System Status SYS System status 
Communication Status COM Communication status 

LNK Link (Ethernet link status) RJ45 
ACT Activity (Ethernet activity status) 

Table 17: Names and Meaning of LED 

LED Display 
color 

Display state Meaning 

Duo LED yellow/green 

 
(green) 

On Firmware started. 

  
(yellow) 

On This state is allowed for a short time only.  
Stays this LED with permanent yellow on, the a hardware 
defect is possible.   

  
(yellow/ 
green) 

Blinking 
yellow/green 

Bootloader active. This state is allowed for a short time only.  

SYS 

 
(off) 

Off Missing power supply or a hardware error occurred. 

Duo LED red/green 

  
(green) 

On Status 
The device currently holds the PROFIBUS token and is able 
to transfer telegrams of data. 

  
(green) 

Blinking 
(regularly)  
5 Hz 

Status 
The device is configured to be a part of the PROFIBUS ring, 
but it must share the PROFIBUS token with other 
PROFIBUS-Master devices present on the PROFIBUS ring. 

  
(green) 

Blinking 
(regularly)  
0.5 Hz 

Status 
Automatic baudrate detection is running 

  
(red) 

On Error 
Communication error at the PROFIBUS. 

COM 

 
(off) 

Off Status/Error 
The device has not been integrated into the PROFIBUS ring, 
i.e. it has not been configured correctly or has a wrong 
configuration or has not received the PROFIBUS token. 

LED green beside Ethernet socket 

 
(green) 

On The device is currently connected to the Ethernet. 
LNK 

 
(off) 

Off The device is currently not connected to the Ethernet. 

LED yellow beside Ethernet socket 

  
(yellow) 

On The device currently sends or receives Ethernet-Frames. 
ACT 

 
(off) 

Off The device does currently not send and receive any 
Ethernet-Frames. 

Table 18: Meaning of LED-Signals 
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LED-Display Status netLINK NL 50-MPI: 
 

Display Status Description 
On The display is lighted permanently. 
Off The display is not lighted at all. 
Blinking The display is switched on and off in phases,  

At regular blinking with a frequency of 5 Hz: On for a duration of 
100 ms followed by Off  for a duration of  100 ms.  
 

Table 19: Display Status 
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10 Technical Data 
10.1 Technical Data of the netLINK NL 50-MPI  

NL 50-MPI Parameter Value 
Communication 
controller 

Type netX 50  

RAM 8 MB SDRAM Memory 
FLASH  4 MB serial Flash, contains boot 

loader, firmware and 
configuration 

Type Client 
Data transport PROFIBUS FDL telegrams 
Number of connections max. 32 MPI connections at a 

time 

PROFIBUS-MPI 
communication 

Access to Data block,  
Bit memory,  
Peripheral data,  
Counter, 
Timer,  
State of OP-Mode 

Data transport  TCP/IP 
Number of connections max. 16 TCP connections at a 

time 

Ethernet communication 

RFC 1006 Supported 
Transmission rate 9,6 kBit/s to 12 MBit/s 
Interface type RS-485,  

non-isolated  
(for revision 2 und 3 of the 
device)  
isolated  
(for revision 4 of the device)  

Connector D-Sub plug (9-pin male 
connector)  

PROFIBUS interface 

Automatic Baud rate 
detection  

supported 

Transmission rate 10/100 MBit/s 
Interface type 10 BASE-T/100 BASE-TX, 

isolated 
Connector RJ45 socket 
Auto-Negotiation supported 

Ethernet interface 

Auto-Crossover supported 
Interface for 
programming tool 

Connector DSub-socket (9-pin female 
connector) 
Note: There is a 1:1-connection 
to the corresponding pins of 
PROFIBUS-interface 

Display LED Display SYS System Status 
COM Communication status 
ACT Ethernet activity status 
LNK Ethernet link status 

Table 20: Technical Data NL 50-MPI (Part 1) 
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NL 50-MPI Parameter Value 

Voltage 18 – 30 V DC  
Typical current at 18 V 72 mA 
Typical current at 24 V 57 mA 
Typical current at 30 V 48 mA 
Connector for power 
supply from PLC 

via DSub-plug (9-pin male 
connector) 

Power supply 

Connector for external 
power supply 

Mini-Combicon socket 3,81 mm 
2-pin 

Electrostatic discharge  
(ESD) according to 
IEC/EN 61000-4-2:1995 

10 kV Air discharge method, 
Criterion A 
4 kV Contact discharge method, 
Criterion B 

Fast transient 
interferences (Burst), 
zone B, according to 
IEC/EN 61000-4-4:1995 

2 kV Power supply connectors 
DC, Criterion B 
1 kV Communication and data 
lines, Criterion A 

Electrical immunity to 
interference 

Surge voltage, zone B, 
according to IEC/EN 
61000-4-5:1995 

1 kV CM, 0,5 kV DM Power 
supply connectors DC, Criterion 
B 
1 kV CM Communication and 
data lines, Criterion B 

Temperature range 0 … + 55 °C  Environmental conditions 
Humidity range 0 … 85 % relative humidity (not 

condensing)  
Dimensions (L x W x H) 74,3 x 40,6 x 16,7 mm 
Weight appr. 40 g 
Mounting / Installation directly at MPI interface 
Protection Class IP 20 
RoHS Yes 

Device 

UL in preparation 
CE Sign Yes 
Emission CISPR 11 Class A 

CE Sign 

Immunity EN 61131-2:2003 
Configuration Software SYCON.net or IBH driver 

Table 21: Technical Data NL 50-MPI (Part 2) 
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11 RFC 1006 
RFC 1006 is a standard for communication over TCP/IP that is supported 
by the netLINK NL 50-MPI. Via RFC 1006 the S7 communication protocol 
is transferred. The S7 communication protocols transparently for the 
netLINK. 

 

Application:  

PC-based visualization systems can be coupled by the netLINK to an S7 in 
order to read and write data. 

 

RFC 1006 provides a point-to-point connection from the PC to the 
automation device. 

 

The RFC 1006 uses a rack and a slot number for addressing. These are 
directly converted to the MPI address. 

 

In order to access MPI address 2 you need to use the value 0 for the rack 
number and 2 for the slot number on the side of RFC 1006, for precise 
assignment see the table below. Some visualization software needs the 
TSAP. The assignment is listed in the following table.  

 
MPI Rack Slot TSAP 
0 0 0 0200 

1 0 1 0201 

2 0 2 0202 
… … … … 
31 0 31 021F 

32 1 0 0220 

33 1 1 0221 

… … … … 
63 1 31 023F 

64 2 0 0240 

65 2 1 0241 

… … … … 
95 2 31 025F 

96 3 0 0260 

97 3 1 0261 

… … … … 
126 3 30 027E 

Table 22: Relation of MPI Address to Rack and Slot Number and TSAP  
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12 Error Numbers  
12.1 TCP/IP Error Numbers  

Error Number Description  
10013 Permission denied 
10024 Too many open sockets. 
10048 Address already in use 
10049 Cannot assign requested address. 
10050 Network is down 
10051 Network is unreachable 
10052 Network dropped connection on reset 
10053 Software caused connection abort. An established connection was 

aborted by the software in your host machine, possibly due to a data 
transmission time-out or protocol error. 

10054 Connection reset by peer 
10055 No buffer space available 
10056 Socket is already connected 
10057 Socket is not connected. 
10058 Cannot send after socket shutdown 
10060 Connection timed out 
10061 Connection refused 
10065 No route to host 
10092 Winsock.dll version out of range 

Table 23: TCP/IP Error Numbers – Standard Win32 Socket API Error Numbers  

 

12.2 netIdent Error Numbers  
Error Number Description  
0x8004c701 Unknown Device Error 
0x8004c702 Request Pending 
0x8004c703 Set IP time exceeded 
0x8004c704 IP address invalid 
0x8004c705 Returned IP address invalid 
0x8004c706 Answer from wrong device 
0x8004c707 Wrong OP code received 
0x8004c708 NetIdent Timeout 

Table 24: netIdent Error Numbers  
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12.3 PROFIBUS-FDL Error Numbers  
Error Number Description  
0 (00H) CON_OK 

Positive acknowledgement: Transmission of data from the sending 
(local) station completed. 

1 (01H) CON_UE  
Negative acknowledgement: Remote-User/FDL interface error.  

2 (02H) CON_RR  
Negative acknowledgement: No remote resources available.  

3 (03H) CON_RS 
Negative acknowledgement: No Service or no remote address at 
remote SAP activated.  

4 (04H) CON_RA 
Negative acknowledgement: Access-point blocked.  

8 (08H) CON_DL 
Positive acknowledgement for sent data (L_SDU), reply data with low 
priority available.  

9 (09H) CON_NR 
Positive acknowledgement for sent data, negative acknowledgement 
for reply data, as not available to the remote FDL controller.  

10 (0AH) CON_DH 
Positive acknowledgement for sent data (L_SDU), reply data with high 
priority available. 

12 (0CH) CON_RDL 
Negative acknowledgement for sent data (L_SDU), resource of the 
remote FDL controller not available or not sufficient, reply data with 
low priority available. 

13 (0DH) CON_RDH 
Negative acknowledgement for sent data (L_SDU), resource of the 
remote FDL controller not available or not sufficient, reply data with 
high priority available. 

16 (10H) CON_LS 
Service at local SAP or local SAP not activated.  

17 (11H) CON_NA 
No reaction (acknowledgement/response) from remote station. 

18 (12H) CON_DS 
Local FDL/PHY not in token ring. 

19 (13H) CON_NO 
Negative acknowledgement: Not ok (different meanings dependent on 
service). 
No reply data transmitted. 

20 (14H) CON_LR 
Resource of the local FDL controller not available or not sufficient. 

21 (15H) CON_IV 
Invalid parameter in request 
- illegal parameters in the request header or  
- local station is passive or  
- destination station is own station address  

23 (17H) CON_NM 
Notice.  

24 (18H) CON_NC 
Reaction from only one station. 

25 (19H) CON_NP 
No plausible reaction from remote station. 

26 (1AH) CON_NL 
Local configurator variable is set. 

27 (1BH) CON_RD 
Reply data available. 
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Error Number Description  
32 (20H) CON_LO 

Low prior response data are sent at this SRD. 
33 (21H) CON_HI 

High prior response data are sent at this SRD. 
34 (22H) CON_NO_DATA 

No data are sent at this SRD. 

Table 25: PROFIBUS-FDL Error Numbers  

12.4 PROFIBUS-MPI Error Numbers  
Error Number Description  
48 (30H) CON_TO 

Timeout, the request message was accepted but no indication is sent 
back by the remote station. MPI protocol error, or station not present.  

57 (39H) CON_SE 
Sequence fault, internal state machine error. Remote station does not 
react like awaited or a reconnection was retried while connection is 
already open or device has no SAPs left to open connection channel 

133 (85H) REJ_IV 
Specified offset address out of limits or not known in the remote 
station. Check msg.data_adr if present or offset parameter in request 
message 

134 (86H)  REJ_PDU 
Wrong PDU coding in the MPI response of the remote station. 

135 (87H) REJ_OP  
Specified length to write or to read results in an access outside the 
limits. Check msg.data_cnt length in request message.  

136 (88H) REJ_HW 
Specified address not defined in the remote station. Check 
msg.data_request message 

137 (89H) REJ_MODE 
MPI remote station not in the right operational mode. Bring S7 into 
RUN-P Mode.  

Table 26: PROFIBUS-MPI Error Numbers  
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13 Appendix 
13.1 Disposal of Waste Electronic Equipment 

Important note from the European Directive 2002/96/EG Waste Electrical 
and Electronic Equipment (WEEE):  
 

 

Waste Electronic Equipment 
 This product must not be treated as household waste. 
 You must dispose the device at a designated waste electronic 
equipment collecting point. 

 

Waste electronic equipment may not be disposed of with household waste. 
As a consumer you are legally obliged to dispose all Waste electronic 
equipment professionally, as to the public collection. 
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Headquarters 
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Hilscher Gesellschaft für  
Systemautomation mbH 
Rheinstrasse 15 
65795 Hattersheim 
Phone: +49 (0) 6190 9907-0 
Fax:     +49 (0) 6190 9907-50 
E-Mail: info@hilscher.com 
Support 
Phone: +49 (0) 6190 9907-99 
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E-Mail: cn.support@hilscher.com 
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Hilscher France S.a.r.l. 
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Phone: +33 (0) 4 72 37 98 40 
E-Mail: info@hilscher.fr 
Support 
Phone: +33 (0) 4 72 37 98 40  
E-Mail: fr.support@hilscher.com 
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Hilscher India Pvt. Ltd. 
New Delhi - 110 025 
Phone:  +91 11 40515640 
E-Mail: info@hilscher.in 
 
Italy 
Hilscher Italia srl 
20090 Vimodrone (MI) 
Phone: +39 02 25007068 
E-Mail: info@hilscher.it 
Support 
Phone: +39 02 25007068 
E-Mail: it.support@hilscher.com 

Japan 
Hilscher Japan KK 
Tokyo, 160-0022 
Phone: +81 (0) 3-5362-0521 
E-Mail: info@hilscher.jp 
Support 
Phone: +81 (0) 3-5362-0521 
E-Mail: jp.support@hilscher.com 
 
Korea 
Hilscher Korea Inc. 
Suwon, 443-734 
Phone: +82 (0) 31-695-5515 
E-Mail: info@hilscher.kr 
 
Switzerland 
Hilscher Swiss GmbH  
4500 Solothurn 
Phone: +41 (0) 32 623 6633 
E-Mail: info@hilscher.ch 
Support 
Phone: +49 (0) 6190 9907-99 
E-Mail: ch.support@hilscher.com 
 
USA 
Hilscher North America, Inc.  
Lisle, IL 60532 
Phone: +1 630-505-5301 
E-Mail: info@hilscher.us 
Support 
Phone: +1 630-505-5301 
E-Mail: us.support@hilscher.com 
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