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Although this program has been developed with great care and intensively 
tested, Hilscher Gesellschaft für Systemautomation mbH cannot guarantee 
the suitability of this program for any purpose not confirmed by us in writing. 

Guarantee claims shall be limited to the right to require rectification. Liability 
for any damages which may have arisen from the use of this program or its 
documentation shall be limited to cases of intent. 

We reserve the right to modify our products and their specifications at any 
time in as far as this contributes to technical progress. The version of the 
manual supplied with the program applies. 
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1 Overview SyCon  
1.1 Main Functions 

The main functions of the System Configurator are: 
Function Section Short Description 

Configuration Overview  Overview about possible protocol 
conversions and description of 
configuration steps  

Diagnostic Diagnostic Functions Extended Device Diagnostic, 
Message Monitor 

Project Information Set the project information Documentation 

Print Print out the configuration 

Table 1: SyCon Main Functions  

1.2 SyCon / SyConND 
SyCon is a System Configurator for netLINK.  

The software described in his manual supports the follwoing devices:  

• NL-MPI 

• NT40-MPI 

• NL50-MPI 

For these devices the name  

For these devices the name netLINK and with historical reasons the name 
netDEVICE is used in this document.  
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2 Installation and Licensing 
2.1 System Requirements  

• PC with 586-, Pentium processor or higher 

• Windows 98/ME, Windows NT/2000/XP/Vista 

• Free disk space: 30 - 80 MByte 

• CD ROM drive  

• RAM: min. 16 MByte  

• Graphic resolution: min. 800 x 600 pixel 

• Windows NT: Service Pack 6 or higher 

• Keyboard and Mouse  
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2.2 Software Installation  
Close all application programs on the system!  

Insert the Hilscher netLINK CD in the local CD ROM drive. The installation 
program starts by itself (Autostart enabled). Otherwise change into the root 
directory on the CD and start exe file in the root (Autostart disabled).  

Note: Administrator privileges are required on Windows NT/2000/XP 
systems for installation!  

The installation program asks for the components you want to install. 
Answer these questions with Yes or No.  

 
Figure 1: Selection for the Installation of the System Configurator  

 

It can be installed:  

• System Configurator SyCon (Configuration and diagnostic tool) 

Note: For SyCon (for netLINK) no license is needed, because the basic 
version includes all functions for operating the netLINK. 
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2.3 Installation of the SyCon 
In the basic version of the System Configurator all functions of SyCon for 
operating the netLINK are available.  

Follow the instructions of the installation program and answer the questions 
with OK or NEXT. 

The installation program offers the following selections:  

 
Figure 2: Selection of components during installation 

The installation program copies the program files and Bitmaps to the PC. 
Finally the system DLLs and the application are entered into the Registry.  
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2.4 Scope of Functions  

2.4.1 Scope of Functions of the Basic Versions 
The basic version of the System Configurator SyCon has the following 
functionality: 

• Full functionality for operating the netDEVICES/netLINK  

• All diagnostic functions 
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3 Configuration Steps - Getting Started 
3.1 Overview Protocol Conversions 

Select from the following table the device you want to use. The 
configuration steps are described in the given section.  

Note: At this point it is presupposed that the hardware installation was 
already done.  

 

 
Device Ethernet Protocol Described in section Page 

netLINK Hilscher TCP/IP PROFIBUS MPI Configuration netLINK MPI 12 

Table 2: Overview NetLink Communication 
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3.2 Configuration netLINK 

3.2.1 Configuration netLINK MPI 
The following table describes the steps to configure a Hilscher netLINK 
MPI/netTAP MPI device. 

# Action Menu in the System Configurator  Detail information in section Page 
1 Create a new project File > New > netLINK Setting up the netLINK 

Configuration 
13 

2 Choose Hilscher netLINK 
device 

Insert > Device > netLINK Insert Device 14 

3 Set Device Assignment Settings > Device Assignment > CIF 
TCP/UDP IP Driver 

CIF TCP/IP Driver 19 

4 Set Protocol Parameter Settings > NetLink Parameter Device Parameter 23 
   IP Address 24 
   PROFIBUS Parameter 26 

5 Save project File > Save Save and Save As 40 

6 Download Online > Download Downloading the 
Configuration 

35 

Table 3: Configuration netLINK MPI 
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4 Configuration of netLINK with SyCon 
4.1 Setting up the netLINK Configuration  

To create a new configuration, choose the File > New menu. This will offer 
a selection list of fieldbus systems. Choose the netLINK. If only the 
netDEVICES (netLINK) was installed, then the configuration window will 
open directly.  

The name of the configuration file can be allocated when the configuration 
is finished or with File > Save As. 
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4.2 Insert Device 
In order to insert a device into the configuration, choose the Insert > 
Device menu, in order to open the selection window, or click on the 
symbol:  
Insert > Device  

 

Figure 3: Symbol Insert > Device 

A dialog box opens, from which exactly one device can be selected.  

 
Figure 4: Insert > Device 

In this window you select the device you want by clicking on it in the list 
Available Devices and then click the Add button or make a double click on 
the device to put the device to the list Selected Devices. With OK you 
confirm the selection. 

This example shows a NL50-MPI device that is inserted with the 
Description netLINK. The shown description depends on the insert device 
and can be changed the user. 
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4.2.1 Replace Device 
If a device already exists in the configuration and should be replaced 
against another device, you have to choose the menu Insert > Device or 
select the "Insert Device" Symbol. 

The question appears if the device should be replaced. 

If you click the Yes button a new window opens, where you can replace the 
device against another one. 

 
Figure 5: Edit > Replace Device 

In this window you select the device you want by clicking on it in the list 
Available devices. By clicking the Add button you put the device in the list 
Selected devices. With OK you confirm the selection and the device will 
be replaced. 
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5 Settings  
5.1 Device Assignment 

The Device Assignment setting determines how the System Configurator 
communicates with the device. This is set in the device assignment via the 
menu Settings > Device Assignment. The following possibilities are 
available:  
CIF Serial Driver  CIF TCP/IP Driver 

 

CIF Serial Driver: 

• CIF Serial Driver: The System Configurator communicates with the 
NetNode over a serial connection. In this case, a COM port of the PC 
must be connected via a diagnostic cable with the diagnostic interface 
of the NetNode.  

• This communication is utilized when the System Configurator has 
access the device over the diagnostic interface of the Hilscher device. 

 

CIF TCP/IP Driver: 

• CIF TCP/IP Driver: The System Configurator communicates with the 
Hilscher device via a TCP/IP connection.  
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5.1.1 CIF Serial Driver 
The serial driver supports COM1 to COM 4, in order to communicate via the 
diagnostic interface with the device.  

Note: A serial interface as available at the NT40-MPI device. A special 
cable is necessary. The devices NL-MPI and NL50-MPI have no serial 
interface. 

The Serial Driver is selected via Settings > Device Assignment.  

 
Figure 6: Driver Selection - CIF Serial Driver 

Choose the CIF Serial Driver and then OK, in order to select the CIF Serial 
Driver.  

The connection must first be established using the button Connect COM1 
or Connect COM2 or Connect COM3 or Connect COM4. They can be 
used depending on which COM ports are installed and free on the PC.  

The System Configurator sends a request to the corresponding COM port 
and polls the Firmware name of the device. A display of the Firmware will 
indicate when a device is connected. In the other case, a Timeout error  
(-51) appears, which will state that no device is connected.  
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Figure 7: CIF Serial Driver - Device Assignment 

The error number –20 indicates that this COM interface is not available or 
free.  
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5.1.2 CIF TCP/IP Driver 
The TCP/IP driver connects up to four devices that can be accessed over a 
TCP/IP connection.  

The TCP/IP driver is chosen via Settings > Device Assignment.  

 
Figure 8: Driver Selection - CIF TCP/IP Driver 

In order to select the CIF TCP/IP driver, choose CIF TCP/IP Driver and 
then OK. 
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The follwowing window appears: 

 
Figure 9: CIF TCP/IP Driver > Device Assignment 

 

With the button netIdent Rescan the local Ethernet network is scanned for 
netLINK devices.  
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Figure 10: CIF TCP/IP Driver > Device Assignment – After Scan 

 

If one or more devices were found, they are shown with their MAC 
Address. Further more the device Type, the Serial Number and the IP 
Address are displayed. 

Caution: To find devices with NetIdent and to set their IP Address, the 
devices have to be in the same network as the used PC. 

 

If a device with IP address 0.0.0.0 is shown, then a valid IP address needs 
to be set for this devices.  

To set or to change an IP address select in Board Selection the device 
and then press the button Set IP address.  
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Figure 11: CIF TCP/IP Driver > Set IP address 

Enter a valid IP address and press the button Set IP to send it to the 
device. Then a message appears if the IP address was set with or without 
success.  

Caution: With Set IP only a temporarily IP address is set in the device. To 
set a permanent IP address a configuration download has to be done.  
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5.2 Device Parameter 
The Device Parameter are the basis for the working data exchange. This 
section contains information for setting the Device Parameter and a 
description for the individual protocol- and busparameter. 
NetLink 

The NetLink device parameters can be 
called up with the menu Settings > NetLink 
Parameter, if a NetLink configuration is 
loaded. 

Table 4: Settings > Parameter 

The settings of the individual parameter is described in the section given 
below. 
Parameter NetLink Described in section Page 

IP-Address Yes IP Address 24 

Ethernet Yes Ethernet Parameter 25 

PROFIBUS Yes PROFIBUS Parameter 26 

Table 5: Settings of Device Parameter 
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5.2.1 IP Address 

 
Figure 12: Settings > NetLink Parameter > IP Address 

Description: 
The description of the device is shown in SyCon as the name of the device. 
The description is changeable in this field. 

The handing over of the IP parameters (IP address, Net mask, Gateway) 
can result in three ways. 

1. DHCP: 
The device gets the IP parameters from a DHCP server. 

2. BOOTP: 
The device gets the IP parameters from a BOOTP server. 

3. IP address, Net mask and Gateway: 
The IP parameters can be entered in this fields. If more than one 
configuration way is activated (for example DHCP and manually entered IP 
parameters), the device trys to process the different configuration way one 
after the other. As soon as it got an IP configuration in one of this ways, the 
device starts with this parameters. 
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5.2.2 Ethernet Parameter 

 
Figure 13: Settings > NetLink Parameter > Ethernet 

Description: 
The description of the device is shown in SyCon as the name of the device. 
The description is changeable in this field. 

Auto detect: 
This option is set. An automatic detection of the Ethernet interface is done 
by the device.  

Interface: 
Is detected automatically.  

Auto negotation: 
Auto negotation means, that in case of two connected devices the devices 
detect the hardware and the features (for example Half- or Full Duplex, 10 
or 100 Mbits and so on) of the other device. This option is preselected. 
Duplex mode: 
Duplex mode of the Ethernet interface. Is detected automatically.  

Speed: 
Transmission speed of the data in MBits/s: 10 MBits/s and 100 MBits/s. Is 
detected automatically.  
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5.2.3 PROFIBUS Parameter 

 
Figure 14: Settings > NetLink Parameter > PROFIBUS 

The busparameters and their meaning: 

• Station Address 

The Station Address of the NetLink 

• Baudrate 

Transmission speed: Number of bits per second. 
Baudrate Bit Time (tBit) 

9,6 kBaud 104,2 us  

19,2 kBaud  52,1 us  

93,75 kBaud 10,7 us 

187,5 kBaud 5,3 us  

500 kBaud 2 us 

1,5 Mbaud  666,7 ns  

3 Mbaud  333,3 ns  

6 Mbaud  166,7 ns 

12 Mbaud  83,3 ns  

Table 6: Baud rates and Bit times 
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• Minimum Station Delay of Responders (min TSDR)  

This is the shortest time period that must elapse before a remote 
recipient (Responder) may send an acknowledgement of a received 
query telegram. The shortest time period between receipt of the last 
Bit of a telegram to the sending of the first Bit of a following telegram.  

Value range: 1 .. 65535 

• Maximum Station Delay of Responders (max TSDR)  

This is the longest time period that must elapse before a Sender 
(Requestor) may send a further query telegram. Greatest time period 
between receipt of the last Bit of a telegram to the sending of the first 
Bit of a following telegram.  

The Sender (Requestor, Master) must wait at least for this time period 
after the sending of an unacknowledged telegram (e.g. Broadcast 
only) before a new telegram is sent.  

Value range: 1 .. 65535 

• Slot Time (TSL) 

'Wait for receipt' – monitoring time of the Senders (Requestor) of 
telegram for the acknowledgement of the recipient (Responder). After 
expiration, a retry occurs in accordance with the value of 'Max. 
telegram retries'.  

Value range: 52 .. 65535 

• Quiet Time (TQUI) 

This is the time delay that occurs for modulators (Modulator-trip time) 
and Repeaters (Repeater-switch time) for the change over from 
sending to receiving.  

Value range: 0 .. 255 

• Setup Time (TSET) 

Minimum period “reaction time” between the receipt of an 
acknowledgement to the sending of a new query telegram (Reaction) 
by the Sender (Requestor). 

Value range: 1 .. 255 

• Target Rotation Time (TTR) 

Pre-set nominal Token cycling time within the Sender authorization 
(Token) will cycle around the ring. How much time the Master still has 
available for sending data telegrams to the Slaves is dependent on 
the difference between the nominal and the actual token cycling time.  

Value range: 1 .. 16.777.215  
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• GAP Update Factor (G) 

Factor for determining after how many Token cycles an added 
participant is accepted into the Token ring. After expiry of the time 
period G*TTR, the Station searches to see whether a further 
participant wishes to be accepted into the logical ring.  

Value range: 1 .. 100  

• Max number of telegram retries (Max_Retry_Limit)  

Maximum number of repeats in order to reach a Station.  

Value range: 1 .. 8  

• Highest Station Address (HSA)  

Station address of the highest active (Master) Station.  

Value range: 2 .. 126 
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The device NL50-MPI supports the automatic baudrate detection.  

The devices NL-MPI and NT40-MPI do not support the automatic baudrate 
detection.  

To set the automatic baudrate detection, select in the list of Bus profile the 
setting PROFIBUS and then select in the list Baud rate the setting 
AutoBaud.  

 

 
Figure 15: Settings > NetLink Parameter > PROFIBUS > Autobaud 

Caution: The automatic detection of the PROFIBUS baudrate can only be 
used, when the control unit sends the PROFIBUS parameters on the 
PROFIBUS network.  

 

Note: A download of the configuration has to be done to activate these 
setting in the device.  
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5.3 Project Information 
If the you create an own project, the project information can be typed in into 
the Settings > Project Information menu. Everybody can then read this 
entry when this menu is opened.  

 
Figure 16: Settings > Project Information  

5.4 Language 
Choose the Settings > Language menu and the following window opens: 

 
Figure 17: Settings > Language 

Here can be set the language of the System Configurator. Select the 
required language and confirm the entry with the OK button.  

A message appears that the System Configurator must be started again in 
order to activate the selected language. Please carry this out.  

After restarting the System Configurator, the language will have changed to 
the selected one.  

Note: Up to now not all languages are available for all fieldbusses! 
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5.5 Start Options  
Starting from the window Network View (menu Window > Network View) 
the menu Settings > Startoptions opens the window Start Options. The 
different start options or modes can be set. Some of these settings are only 
of importance for the OPC server.  

Note: The menu option Start Options is only displayed in the selection 
Settings, if a project is loaded. 

 
Figure 18: Settings > Start Options 

• Simulation mode ON/OFF 
Only valid for the OPC Server.  

• Start SyCon hidden if started via OPC  
Only valid for the OPC Server.  

• Start SyCon next time with last Configuration 
When this is marked the last saved configuration in the SyCon is 
automatically loaded when the SyCon is started again.  
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• Logic Network View visible 
When this is marked, there is the possibility of diverting to the network 
mode without having to install the SyCon with OPC. It is also possible 
to use the Watch List from the network mode.  

• Fast start ON/OFF 
Only valid for the OPC Server.  

• TAG tracing ON/OFF 
Only valid for the OPC Server.  

• OPC tracing ON/OFF 
Only valid for the OPC Server.  

• Auto connect ON/OFF 
If this is marked, when opening a configuration automatically a 
connection to that Hilscher devices is manufactured without the 
device assignment additionally have to be executed. 

• Start with multiple configurations 
If this option is selected you have the possibility to start SyCon with 
up to four configurations simultaneously. The paths are shown in the 
window and they are changable there. 
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6 Online Functions 
6.1 Introduction 

In this section, all the functions that directly influence Hilscher netLINK / 
netDEVICES. 

Note: Please note that this also permits an interruption of the running 
communication or that input and output can be switched on or off.  
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6.2 Online to the NetDevice 

6.2.1 Firmware Download  
If you want to carry out a Firmware download, act as follow: Select the 
menu Online > Firmware Download. A warning appears, that the 
communication on the bus will be interrupted. This warning has to be 
confirmed.  

 
Figure 19: Securitiy question before Firmware Download 

 

 
Figure 20: Online > Firmware Download 

The Firmware is transferred into the selected device and stored there in a 
power failure protected FLASH memory.  
After the download of the firmware a download of the configuration has to 
be done.  
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6.2.2 Downloading the Configuration  
In order to transfer the configuration, a transfer download to the device 
must be carried out with the menu Online > Download. A warning appears 
that the communication on the bus will be interrupted. This warning must be 
confirmed.  

 
Figure 21: Security question before Download 

Attention: The download overwrites the configuration in the device. 

 
Figure 22: Online > Download  

The configuration is transferred into the selected device and is stored there 
in FLASH memory in a zero voltage manner so that the configuration is 
available when the power supply is switched off and on again.  
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6.2.3 Firmware / Reset  
First the device must be chosen with a left mouse click on the symbol of the 
device. Then the Online > Firmware / Reset menu has to be called up and 
the name and the version of the Firmware are displayed.  

 
Figure 23: Online > Firmware / Reset 

The device is resetted with the Reset button. 

6.2.4 Device Info  
Select the menu Online > Device Info in order to obtain information for the 
device.  

The manufacturer date, the device number and the serial number of the 
device is read out and shown.  

 
Figure 24: Online > Device Info  

The section Drivers display show if and which licenses are available in the 
device.  
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6.3 Diagnostic Functions  

6.3.1 Extended Device Diagnostic netLINK 
The Extended Device Diagnostic helps to find bus and configuration errors 
when the SyCon menu functions are of no further help.  

Note: The extended device diagnostic is supported by the devices NL-MPI 
and NT40-MPI. The extended device diagnostic is not supported by the 
device NL50-MPI.  

First select the Hilscher device with a left mouse click on the symbol of the 
device. Then select the Online > Extended Device Diagnostic menu.  

This menu opens a list of diagnostic structures. These contain online 
counters, states and parameter information:  

 
Figure 25: Online > Extended Device Diagnostic NetLink 

Task / Task State Page 

FDL_TASK Requests 60 

FDL_TASK FMA Request 61 

TCP_UDP_TASK Information 55 

TCP_UDP_TASK Code Diag 56 

IP_TASK Task Information 57 

IP_TASK Ethernet Status 57 

IP_TASK Ethernet Count 58 

IP_TASK Packet Count 59 

IP_TASK Code Diag 59 

Table 7: Online > Extended Device Diagnostic NetLink 
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6.4 Message Monitor  
The Message Monitor permits access to the Mailbox of the device.  

Note: The usage of the Message Monitor assumes advanced knowledge 
from the user.  

Select the menu Online > Message Monitor.  

 
Figure 26: Online > Message Monitor  

A Message can be saved and loaded and has the file extension *.MSG.  

File > New: clears the window 

File > Open: opens a Message (Message can be loaded)  

File > Save or File > Save As: saves a Message  

File > Exit: ends the Message Monitor and returns to the SyCon.  
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Edit > Create answer: creates an answer Message  

Edit > Reset counter: resets the Message counter 

 

View > Review the received data: all received data is shown 

View > Review the  send data: all the send data is shown 

View > Number of receipt errors: the number of the received errors is 
shown  

View > Decimal/Hexadecimal: Switch the display format  

 

It is recommend to create a sub-directory MSG and to save the messages 
in it.  
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7 File, Print, Export, Edit and View 
7.1 File  

7.1.1 Open  
An existing project can be opened with File > Open.  

7.1.2 Save and Save As  
When the file name is known, then the configuration can be saved under 
the File > Save menu, otherwise the File > Save As menu must be 
selected.  

7.1.3 Close  
The current project can be closed with File > Close.  
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7.2 Print  
After the current printer has been selected in the File > Printer Setup 
menu, the configuration can be printed out under the File > Print menu. For 
a page view, select the File > Page View menu.  

7.3 Export Functions  

7.3.1 DBM Export  
Select the File > Export > DBM menu in order to save the previously 
saved project file (*.IB Microsoft Access Format) in a DBM file (Hilscher 
binary format). This DBM file can be loaded in the DOS Compro program. 
The configuration is stored in the Project directory in the path of the SyCon 
installation with the extension *.DBM. 

Attention: The file name can have max. 8 characters. 

7.4 Edit 

7.4.1 Delete 
To delete a device you have to have to select the menu Edit > Delete. 
Before SyCon deletes the device a security question appears. If you really 
want to delete this device you have to confirm this question with Yes, and 
the device will be deleted. 

 
Figure 27: Security question delete device 

Note: When you delete a device the settings and the configuration of this 
device get lost. 
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7.5 View 

7.5.1 Logical Network View 
In the menu View > Logical Network View the user can activate or 
deaktivate the network view by selecting ist (with hook) or by not selcting it 
(without hook). 

The network view is used for example for the Start Options. 

7.5.2 Toolbars 
In the menu View > Toolbars the user has the possibility to activate or 
deactivate the Toolbars Standard and Fieldbus. If this function is 
deactivated the toolbars are not shown. 

7.5.3 Status Bar 
In the menu View > Status Bar this bar can be activated (with hook) or 
deactivated (without hook). 
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8 Error Numbers 
8.1 CIF Serial Driver Error Numbers (-20 .. -71) 

These is the list of error numbers using the serial driver.  
Error Number Description  
-20 Driver: No COM port found or COM port already in use.  

-21 Driver: COM port already opened 

-22 Driver: Function call into driver has failed 

-23 Driver: Internal driver error 

-24 Driver: Could not create read thread 

-25 Driver: Could not create read event 

-26 Driver: Could not create write event 

-27 Driver: Could not create timer event 

-28 Driver: Error by writing data 

-29 Driver: Wrong COM state 

-30 Driver: COM state error is set  

-31 Driver: COM buffer setup failed 

-32 Driver: COM set timeout failed 

-33 Driver: Receive buffer overrun 

-34 Driver: Receive buffer full 

-35 Driver: Send busy 

-36 Driver: Error during close driver 

-40 User: COM port not opened  

-41 User: Invalid handle value 

-42 User: Invalid COM number 

-43 User: Size parameter invalid 

-44 User: Size parameter zero 

-45 User: Buffer pointer is NULL 

-46 User: Buffer too short 

-47 User: Setup error 

Table 8: CIF Serial Driver Error Numbers (-20..-47) 
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Error Number Description  
-50 User: Send message, timeout error 

-51 User: Could not send a message 
Cable not connected.  
Wrong cable. 
Device does not respond.  

-52 User: Send message, no device connected 

-53 User: Error by send message, message receiving 

-54 User: Telegram collision 

-55 User: Telegram, no acknowledgement received 

-56 User: Telegram, noise 

-57 User: Telegram, data overrun 

-58 User: Telegram, parity error 

-59 User: Telegram, framing error 

-60 User: Telegram, unknown error 

-70 User: Timeout by receive a message 

-71 User: No message received 

Table 9: CIF Serial Driver Error Numbers (-20..-47) 
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8.2 RCS Error Numbers (4 .. 93) 
This is the list of error numbers returned by the RCS (Realtime 
Communication System), that is the operating system of Hilscher devices. 
The error number is returned in an answer message. Command messages 
and answer messages are used to communicate between the application 
(e.g. the System Configurator) and the Hilscher device. An example of this 
communication is the download of a configuration.  
Error Number Description  
4 Task does not exist  

5 Task is not initialised  

6 The MCL is locked 

7 The MCL rejects a send command because of an error  

20 The user will download a database into the device that is not valid for 
this device type. 

21 Data base segment not configured or not existent  

22 Number for message wrong during download  

23 Received number of data during download does not match to that in the 
command message  

24 Sequence identifier wrong during download  

25 Checksum after download and checksum in command message do not 
match  

26 Write/Read access of data base segment  

27 Download/Upload or erase of configured data base type is not allowed 

28 The state of the data base segment indicated an error. Upload not 
possible  

29 The access to the data base segment needs the bootstraploader. The 
bootstraploader is not present 

30 Trace buffer overflow  

31 Entry into trace buffer too long 

37 No or wrong licence. The OEM licence of the System Configurator 
allows only communication to devices that have the same licence inside 

38 The data base created by the System Configurator and the data base 
expected by the firmware is not compatible  

39 DBM module missing  

Table 10: RCS error numbers (answer message) (4..39)  
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Error Number Description  
40 No command free 

41 Command unknown 

42 Command mode unknown  

43 Wrong parameter in the command  

44 Message length does not match to the parameters of the command  

45 Only a MCL does use this command to the RCS  

50 FLASH occupied at the moment  

51 Error deleting the FLASH  

52 Error writing the FLASH 

53 FLASH not configured 

54 FLASH timeout error 

55 Access protection error while deleting the FLASH  

56 FLASH size does not match or not enough FLASH memory 

60 Wrong structure type  

61 Wrong length of structure  

62 Structure does not exist 

70 No clock on the device  

80 Wrong handle for the table (table does not exist) 

81 Data length does not match the structure of this table  

82 The data set of this number does not exist 

83 This table name does not exist 

84 Table full. No more entries allowed  

85 Other error from DBM 

90 The device info (serial number, device number and date) does already 
exist 

91 Licence code invalid  

92 Licence code does already exist  

93 All memory locations for licence codes already in use  

Table 11: RCS error numbers (answer message) (40..93)  
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8.3 Database Access Error Numbers (100 .. 130)  
The following table lists the error numbers of the database access errors  
Error Number Description  
100 Database already opened  

101 Dataset could not be opened 

103 Error while opening database occurred  

104 No valid path name  

105 No connection to data base. Call function DbOpen().  

106 Error in parameter  

107 Error during opening a table  

108 Nullpointer occurred  

109 Table not opened. Call function OpenTable() first. 

110 The first record is reached 

111 The last record is reached 

112 Unknown type in the record found  

113 Data has to be truncated 

114 No access driver installed on the system 

115 Exception received  

116 This table is set to read only 

117 There is no data set in the table 

118 The requested table could not be edit 

119 An operation could not be completed 

120 User gives an unexpected length in WritsDs().  

121 An assertion failed 

122 DLL not found  

123 DLL couldn't be freed 

124 Specified function not found in the DLL  

125 ODBC Function returns an error 

126 Count of data bytes in the record exceeds 1938 

127 DBM32 DLL is not loaded 

128 Field with the given index was not found 

129 This table contains no records 

130 Invalid character (' ') found in a Table or Column 

Table 12: Database Access Error Numbers (100..130)  
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8.4 Online Data Manager Error Numbers  

8.4.1 Online Data Manager Error Numbers (1000 .. 1018)  
The following table lists the error numbers of the Online Data Manager.  
Error Number Description  
1000 Driver OnlineDataManager not opened 

1001 Initialization of the OnlineDataManager has failed  

1002 No DriverObject found. OnlineDataManager Sub DLL not found.  

1003 No DeviceObject found. Device not found.  

1004 Application not found 

1010 Application has requested an unknown event  

1011 Application has requested an unknown function mode, operating mode. 
Known function modes, operating modes are Reset, Download, Register 
Server, Unregister Server. 

1012 Application has requested an unknown command 

1013 Message Server already exists  

1014 Message Server not registered 

1015 Device already in use 

1016 Device not assigned  

1017 Device has changed  

1018 Command active 

Table 13: Online Data Manager Error numbers (1000..1018)  

8.4.2 Message Handler Error Numbers (2010 .. 2027)  
The following table lists the error numbers of the Message handler of the 
Online Data Manager.  
Error Number Description  
2010 Message handler: Messagebuffer empty 

2011 Message handler: Messagebuffer full 

2021 Message handler: Invalid Message ID (msg.nr)  

2022 Message handler: No entry  

2023 Message handler: Message already active 

2024 Message handler: Wrong Application  

2025 Message handler: Message Timeout  

2026 Message handler: Wait for Delete 

2027 Message handler: No cyclic Message 

Table 14: Error Numbers of the Message Handler of the Online Data Manager (2010..2027)  
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8.4.3 Driver Functions Error Numbers (2501 .. 2512)  
The following table lists the error numbers of the Driver Functions of the 
Online Data Manager.  
Error Number Description  
2501 OnlineDataManager Sub DLL not found 

2502 Function missing 

2503 'Read Thread' not created 

2504 'Write Thread' not created 

2505 'IO Thread' not created  

2510 Function failed 

2512 Assign reports error. Return neither OK or cancel 

Table 15: Error Numbers of the Driver Functions of the Online Data Manager (2501..2512) 

8.4.4 Online Data Manager Subfunctions Error Numbers (8001 .. 
8035) 

The following table lists the error numbers of the Subfunctions of the Online 
Data Manager.  
Error Number Description  
8001 Driver not opened. E.g. CIF Device Driver  

8002 Application has requested an unknown event  

8003 Application has requested an unknown command 

8004 Command has failed  

8005 Command active 

8006 Device invalid 

8010 No device was assigned 

8011 Device was already assigned  

8020 Driver not connected 

8021 Driver already connected 

8030 Faulty 'GetState'  

8031 Send error (PutMessage returns error)  

8032 Send active (PutMessage active) 

8033 Receive error (GetMessage returns error)  

8034 Receive active (GetMessage active) 

8035 IO Error (ExchangeIO returns error) 

Table 16: Subfunction Error Numbers of the Driver Functions of the Online Data Manager 
(8001..8035)  
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8.5 Data Base Functions Error Numbers (4000 .. 4199)  
The following table lists the error numbers of the converting functions.  
Error Number Description  
4000  File does not exist  

4001  Success in comprimizing  

4002  Dataset does not exist  

4003  Last respectively first entry reached  

4004  Not enough memory  

4005  File directory full  

4006  Max number of entries reached  

4007  No writing to this table possible, because the table is located in the 
FLASH  

4008  Table name does already exist  

4009  File name does not exist  

4010  Free RAM length from RCS_CNF.P86 is smaller than E_F_INDEX * 2  

4011  Parameter ‘next’ wrong  

4012  Not enough free space to copy data set  

4013  Set is deleted  

4014  Value for Index is wrong  

4015  Access not allowed  

4016  open_file used before init_file  

4017 Drive is not ready 

4018 Not enough drive memory  

4019 File name or path does not exist 

4020 Cannot create path 

4021 Wrong path 

4022 Wrong flag 

4023 The delete path is the root path 

4024 Path file exists 

4025 Write error during write a file 

4026 Error during create a file 

4027 Error during close a file 

4028 No DBM file 

4029 Length of the read data is unequal of the file length 

Table 17: Error numbers of converting functions (4000..4029)  
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Error Number Description  
4030 Path too long 

4031 Directory changed 

4032 Directory created 

4034  Length of converting stream is 0  

4035  Non equal data set found 

4036  Non equal data set found 

4037  Non equal data set found 

4038  Data set has length 0 

4039  The function DbmInit has assigned a Zero pointer during RCS 
initialisation 

4040  Printer not ready  

4041  The data base is used from an other function  

4042  New length of data base is smaller than used  

4043  Unknown access mode  

4044  Old data base has to be converted  

4045  Error while converting. Function not known  

4046  Unknown type in set 0 found  

4047  No float function available  

4048  Function not in RCS module  

4049  Check failed  

4050  Checksum check failed  

4051  More segments are existing in file, than in the structure FILE_INFO_T in 
wMaxEintraege  

4052  SegLen in structure FILE_INFO_T is smaller then the length in the file. 
Return of function dbm_restore_data  

4053  The header file holds an other information for a length than in the 
segment itself  

4054  Not enough memory for allocation on the PC  

4055  No index for file handle in structure FLASH_DIR of RCS found  

4057  File type 2 can not be printed because of too many definitions  

4058  The definitions need too many lines to display them, than in the program 
available  

4059  An unknown format for the parameter. Valid is U, H, or S 

4060  Unknown parameter type  

Table 18: Error numbers of converting functions (4030..4060)  
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Error Number Description  
4061  The data base was transmitted into the FLASH  

4062  Set 0 contains no structure definition  

4063  Set 0 can not be deleted  

4064  Error during execution of a ODBC data base access  

4065  Initialising of DBM through RCS had no success  

4066  Passed data length incorrect  

4067  Sorting function not linked  

4068  Error in function parameter  

4069  Error from ODBC table  

4070  No free handle available. Too many data base links are already opened  

4071  Unknown data type found in the table  

4072  Structure of table GLOBAL not correct or no such table existing  

4073  No name of an ACCESS data base  

4074  Download window can’t be created  

4075  Download not fully performable  

Table 19: Error numbers of converting functions (4061..4075)  
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Error Number Description  
4082  More than 32 tables should be created  

4083  No entry in element szSourceFile  

4084  ODBC connection initialisation not possible. This could happen when in 
file ODBCINST.INI in section [Microsoft Access Driver (*.mdb)] is no 
valid path to ODBCJT16/32.DLL. 

4085  Error in structure in the ACCESS data base that is in DBM format  

4086  Error in structure in the ACCESS data base that is in DBM format  

4087  No data in a ODBC table  

4088  No entry  

4089  ODBC set length not valid  

4090  Not enough data sets in ODBC table  

4091  Table CreateTab not found  

4092  Error in structure of table CreateTab  

4093  No entry in element szSourceTable  

4094  No entry in element szDestTable  

4095  Entry in iSourceType of table CreateTab is wrong  

4096  Entry in iTranslate of table CreateTab is wrong  

4097  Function SQLAllocStmt reports an error  

4098  ODBC source table not found  

4099 ODBC data truncated  

4100 Download timeout  

4101 Library load error  

4102 Library function error 

4103 Error in description 'toggle'  

4104 Error in description 'KB'  

4105 Column does not exist 

4106 ODBC structure different  

4107 ODBC address error  

4108 No CRC sum exists (table GLOBAL exists or old)  

4109 Table GLOBAL is old 

4110 Calculated CRC different to CRC in table GLOBAL 

4199 Programming error  

Table 20: Error numbers of converting functions (4082..4199)  

Hilscher Gesellschaft für Systemautomation mbH – Rheinstr. 15 – D 65795 Hattersheim  
Edition 3 – Oi:SyCon netLINK#EN 2008/06  



SyCon System Configurator netLINK   Error Numbers  •  54 

8.6 Converting Functions Error Numbers (5001 .. 5008) 
The following table lists the error numbers of converting functions.  
Error Number Description  
5000 Function PackLongToByteShort: Not enough space in pvD (Number of 

elements greater than reserved memory)  

5001 Function PackLongToByteShort: Not enough space in pvD. Detected 
during converting of pvS  

5002 Function PackLongToByteShort: Not enough space in pvD 

5003 Function StringToByte: Not enough space in pvD  

5004 Function IntToByte: Not enough space in pvD  

5005 Function LongToShort: Not enough space in pvD  

5006 Function PackStringDumpToByteArray: Not enough space in pvD  

5007 Function PackStringBumpToByteArray: A character was found, which is 
not convertible into a HEX value 

5008 Function PackStringDumpToByteArray: Number of character odd 

5009 Function PackStringDumpToByteArray: Not enough space in pvD 

5010 Function PackStringDumpToByteArray: The current data set needs to be 
appended the previous one 

5011 Function PackStringDumpToByteArray: No corresponding function to the 
given number exist 

5012 Converting error 

Table 21: Error Numbers of data base functions (5000 .. 5012) 
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9 Appendix  
9.1 Extended Device Diagnostic 

Note: The extended device diagnostic is supported by the devices NL-MPI 
and NT40-MPI. The extended device diagnostic is not supported by the 
device NL50-MPI.  

9.1.1 Extended Device Diagnostic TCP UDP TASK  

9.1.1.1 TCP_UDP_TASK Information 

 
Figure 28: TCP_UDP_TASK Task Information 

Variable Meaning 

Task state State of the task 

Error count Number of appeared errors 

Last error Last appeared error 

Table 22: TCP_UDP_TASK Task Information 
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9.1.1.2 TCP_UDP_TASK Code Diag 

 
Figure 29: TCP_UDP_TASK Code Diag 

Variable Meaning 

Info count Counter for information reports 

Warning count Counter for warning reports 

Error count Counter for errors 

Severity level Level of the last appeared error 

Code Code of the last appeared error 

Parameter Additional information to the error 

Module Software-module 

Line number Line number inside the software-module 

Table 23:  TCP_UDP_TASK Code Diag 
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9.1.2 Extended Device Diagnostic IP TASK 

9.1.2.1 IP_TASK Task Information 

 
Figure 30: IP_TASK Task Information 

Variable Meaning 

Task state State of the Task: 
1 = Task is running 
2 = initialization is running 
3 = initialization has failed 

Error count Counter for appeared errors 

Last error Last appeared error 

IP address IP-Address of the device 

Net mask Net mask of the device 

Gateway Gateway of the device 

Table 24: IP_TASK Task Information 

9.1.2.2 IP_TASK Ethernet Status 

 
Figure 31: IP_TASK Ethernet Status 

Variable Meaning 

MAC address (hex) MAC address of the device 

Interface Actual known Ethernet interface 

Speed Transmission rate 

Duplex mode Shows the actual Duplex mode: Half-/Fullduplex 

Twisted Pair link State of the Twisted Pair connection 

Table 25: IP_TASK Ethernet Status 
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9.1.2.3 IP_TASK Ethernet Count 

 
Figure 32: IP_TASK Ethernet Count 

Variable Meaning 

IRQ count Counter for interrupts of the Ethernet controller 

Last event (hex) Last appeared interrupt type 

Events OK Counter for known interrupt types 

Events unknown Counter for unknown interrupt types 

Frame recv OK Counter for received Ethernet frames 

Frame recv missed Counter for missed Ethernet frames 

Frame recv bad CRC Counter for Ethernet frames with CRC errors 

Frame sent OK Counter for sent Ethernet frames 

Frame sent errors Counter for send errors 

Frame sent collisions Counter for sending collisions 

Frame sent late collision 
errors 

Counter for late sending collisions 

Table 26: IP_TASK Ethernet Count 
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9.1.2.4 IP_TASK Packet Count 

 
Figure 33: IP_TASK Packet Count 

Variable Meaning 

Packet recv TCP Counter for received TCP packets 

Packet recv UDP Counter for received UDP packets 

Packet recv ICMP Counter for received ICMP packets 

Packet recv IP header err Counter for received IP packets with errors 

Packet recv ARP Counter for received ARP packets 

Packet recv unknown Counter for received packets of an unknown type 

Table 27: IP_TASK Packet Count 

9.1.2.5 IP_TASK Code Diag 

 
Figure 34: IP_TASK Code Diag 

Variable Meaning 

Info count Counter for information reports 

Warning count Counter for warning reports 

Error count Counter for errors 

Severity level Level of the last appeared error 

Code  Code of the last appeared error 

Parameter Additional information to the error 

Module Software-module 

Line number Line number inside the software-module 

Table 28: IP_TASK Code Diag 
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9.1.3 Extended Device Diagnostic PROFIBUS 

9.1.3.1 FDL_TASK Requests 

 
Figure 35: FDL_TASK Requests 

Variable Bedeutung 

SDA request Number of 'SDA' Request  

SDA confirmation pos. Number of 'SDA' Confirmation, positive 

SDA confirmation neg. Number of 'SDA' Confirmation, negative 

SDA indication Number of 'SDA' Indication 

SDN request Number of 'SDN' Request 

SDN confirmation pos. Number of 'SDN' Confirmation, positive 

SDN confirmation neg. Number of 'SDN' Confirmation, negative 

SDN indication Number of 'SDN' Indication 

SRD request Number of 'SRD' Request 

SRD confirmation pos. Number of 'SRD' Confirmation, positive 

SRD confirmation neg. Number of 'SRD' Confirmation, negative 

SRD indication Number of 'SRD' Indication 

SRD update request Number of 'SRD' Update Request 

SRD update con. pos. Number of 'SRD' Update Confirmation, positive 

SRD update con. neg. Number of 'SRD' Update Confirmation, negative 

Table 29: FDL_TASK Requests 
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9.1.3.2 FDL_TASK FMA Request 

 
Figure 36: FDL_TASK FMA Request 

Variable Bedeutung 

SAP act. Request Number of 'SAP Activate' Request 

SAP act. Confirmation pos Number of 'SAP Activate' Confirmation, positive 

SAP act. Confirmation neg Number of 'SAP Activate' Confirmation, negative 

RSAP act. Request Number of 'RSAP Activate' Request 

RSAP act. Confirmation 
pos 

Number of 'RSAP Activate' Confirmation, positive 

RSAP act. Confirmation 
neg 

Number of 'RSAP Activate' Confirmation, negative 

SAP deact. Request Number of 'SAP Deactivate' Request 

SAP deact. Confirmation 
pos 

Number of 'SAP Deactivate' Confirmation, positive 

SAP deact. Confirmation 
neg 

Number of 'SAP Deactivate' Confirmation, negative 

LiveList request Number of 'LiveList' Request 

LiveList confirmation pos Number of 'LiveList' Confirmation, positive 

LiveList confirmation neg Number of 'LiveList' Confirmation, negative 

Table 30: FDL_TASK FMA Request 
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12 Glossar 
SyCon 

System Configurator.  

Configuration and Diagnostic tool.  
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