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Kurzbeschreibung

Description

Diese CD beinhaltet

« die ladbare Firmware*

« den Systemkonfigurator SyCon**

» den OPC-Server**

« den CIF Device Driver

« die Treiber fir SoftSPS**

« die EDS-Dateien

« die Dokumentation

fiir alle unsere Communication InterFaces CIF.

Das Communication Interface flihrt den gesamten
Datenaustausch zwischen den angeschlossenen
Feldbus-Teilnehmern und dem PC durch. Dabei werden
die Daten als Prozessabbild im Dual-Port Memory des
CIFs zur Verfiigung gestellt.

Bei nachrichtenorientiertem Datenaustausch erfolgt

dieser uber eine Mailbox im Dual-Port Memory.

Die PC-Applikation greift Gber den CIF Device Driver

oder einen speziellen SoftSPS-Treiber auf das Prozess-

abbild oder auf die Mailbox zu.

Die Konfiguration und Inbetriebnahme erfolgt durch den

Systemkonfigurator SyCon. Dieser kommuniziert mit dem

CIF Uber den CIF Device Driver oder tiber TCP/IP zu einem

Remote-PC oder Uber eine serielle Verbindung zwischen

dem COM-Port des PCs und der Diagnoseschnittstelle

des CIFs. Die Konfiguration wird auf dem CIF gespeichert,
sodass das CIF beim Starten sofort betriebsbereit ist.

* Falls es eine neue Firmwareversion gibt, kénnen Sie
diese von unserer Homepage herunterladen.

** Zum Betrieb des Systemkonfigurators, des
OPC-Servers oder des SoftSPS-Treibers bendtigen
Sie einen Lizenzcode. Wenn dieser im Lieferumfang
mit enthalten ist, finden Sie ihn fiir den Systemkonfi-
gurator als Label auf dieser CD oder in einem Brief-
umschlag ein Lizenzcodeanforderungsformular bzw.
fiir den OPC-Server oder den SoftSPS-Treiber auf
der Karte. Andernfalls wenden Sie sich bitte an Ihren
Distributor oder direkt an uns.

This CD contains

* loadable Firmware*

« System Configurator SyCon**

» OPC Server**

« CIF Device Driver

« Driver for SoftPLCs**

« EDS files

» Documentation

for all our Communication InterFaces CIF.

The Communication Interface handles the complete
data exchange between the connected fieldbus devices
and the PC. The data are available as process image in
the dual-port memory of the CIF. The message oriented
data exchange is handled via a mailbox in the dual-port
memory.

The PC application has access on the process image or

the mailbox over the CIF Device Driver or a special

SoftPLC Driver.

The configuration and set up takes place through the

System Configurator SyCon. It communicates via the

CIF Device Driver or via TCP/IP to a remote PC or via a

serial connection between the COM port of the PC and

the diagnostic interface of the CIF. The configuration is

stored on the CIF, therefore the CIF is immediately

ready after the start.

* If there is a new firmware version available you can
download it from our homepage.

** Alicense code is required to use the System
Configurator, the OPC Server or the SoftPLC Driver.
If this is included in the scope of delivery you will find
it for the System Configurator on a label on this CD or
in an envelope a license code request form respectively
for the OPC Server or the SoftPLC Driver on the card.
Otherwise please contact your distributor or us
directly.



Verzeichnisstruktur der CD Directory Structure of the CD

Sie erhalten auf dieser CD alle Dokumentationen im All manuals on this CD are delivered in the Adobe
Adobe-Acrobat-Reader-Format (PDF). Im Verzeichnis Acrobat Reader format (PDF). A runtime version of this
ACROREAD ist eine Runtime-Version enthalten. reader can be found in the ACROREAD directory.

EIEI Syaternzaftw [E:)
EI{:I Acroread
w27 Deutsch

Installation des Acrobat Readers, in Deutsch
und Englisch fiir verschiedene Windows-
Versionen
Installation of Acrobat Reader, in German or
English language for different Windows
| versions

{1 Driver ]
-{7] DrvPrg
= Eds

-3 Fag]
-2 Firrmware
B3 Manuals
{17 Deutsch

_Installation des CIF Device Driver
Installation of the CIF Device Driver
_Manuals, Headers, Sample
zur Treiberprogrammierung

for the driver programming

_Héufig gestellte Fragen
| Frequently asked questions

[Dokumentation zum SyCon und
den Protokollen im Acrobat-Reader-Format

Documentation of SyCon and the protocols in
fcrobat Reader format

~{_] Syeon}
-2 Uil

[Installation SyCon

| Installation of SyCon



Systemvoraussetzungen

System Requirements

« PC mit 486-, Pentium-Prozessor oder hoher

» Windows 95/98/ME, Windows NT 4.0/2000/XP
« Freier Festplattenspeicher: 30-80 MByte

* CD-ROM-Laufwerk

* RAM: mind. 16 MByte

« Grafikauflésung: mind. 800 x 600 Bildpunkte

* Windows 95: Service Pack 1

« Windows NT: Service Pack 6 oder hoher

« COM/DCOM fiir den OPC-Server

+ PC with 486-, Pentium processor or higher

» Windows 95/98/ME, Windows NT 4.0/2000/XP
« Free disk space: 30-80 MByte

+ CD ROM Drive

* RAM: min. 16 MByte

« Graphic resolution: min. 800 x 600 pixel

+» Windows 95: Service Pack 1

» Windows NT: Service Pack 6 or higher

+ COM/DCOM only for OPC Server

« Tastatur und Maus

Installation des CIFs

Um eine Beschéadigung des PCs und des CIFs zu ver-
meiden, entladen Sie sich am metallischen Gehduse
des PCs.

» Keyboard and Mouse

Installation of the CIF

To prevent damage to the PC or the CIF discharge
yourself at the metal cabinet of the PC.

Make sure that the configured memory areas and inter-
rupts are not used by another PC component.

Stellen Sie sicher, dass die konfigurierten Speicherbereiche
und Interrupte nicht von anderen Geréaten belegt sind.

Um solche Fehler zu erkennen und zu verhindern,
wahlen Sie unter In order to identify and prevent such errors, select in

Windows Pfad / Path

2000/XP Start > Systemsteuerung > Verwaltung > Computerverwaltung > System > Systeminformationen >
Hardwareressourcen
Start > Control Panel > Administrative Tools > Computer Management > System Information >
Hardware Resources

NT Start > Programme > Verwaltung > Windows-NT-Diagnose > Ressourcen
Start > Programs > Administrative Tools > Windows NT Diagnostics > Resources

95/98/ME Start > Einstellungen > Systemsteuerung > System > Geratemanager
Start > Settings > Control Panel > System > Device Manager

ISA- und PC/104-Karten ISA and PC/104 cards

1. Konfigurieren Sie die Startadresse des CIFs gemaf
den nachstehenden Abbildungen. Beachten Sie, dass
das CIF einen freien Speicherbereich von 2 bzw.

8 KByte zwischen 0xA0000 und OxFFFFF bendtigt.

1. Configure the start address of the CIF according the
following description. Please note that a free memory
area of 2 KByte respectively 8 KByte between 0xA0000
and OxFFFFF is necessary.



2. Falls Sie im Interruptbetrieb arbeiten, stellen Sie
einen freien Interrupt auf dem CIF ein.

3. Schalten Sie zuerst die Betriebsspannung Ihres PCs
und aller angeschlossenen Geréte aus.

4. Offnen Sie das Geh&use des PCs und stecken Sie
das CIF auf einen freien ISA-Steckplatz. Der CIF
Device Driver unterstiitzt bis zu vier CIFs pro PC. Befe-
stigen Sie das CIF an der vorgesehenen Bohrung.

5. SchlieRen Sie wieder das PC-Geh&use und schalten
Sie die Betriebsspannung des PCs ein.

PCl-Karten

1. Schalten Sie zuerst die Betriebsspannung lhres PCs
und aller angeschlossenen Geréte aus.

2. Offnen Sie das Geh3use des PCs und stecken Sie
das CIF auf einen freien PCI-Steckplatz. Der CIF
Device Driver unterstiitzt bis zu vier CIFs pro PC. Befe-
stigen Sie das CIF an der vorgesehenen Bohrung.

3. SchlieRen Sie wieder das PC-Gehause und schalten
Sie die Betriebsspannung des PCs ein.

4a. Windows 2000/XP erkennen das CIF automatisch
und 6ffnen das Fenster Neue Hardware gefunden.
Das CIF wird als Anderes PCI-Briickengerat erkannt.
Der Installationsassistent erwartet eine Diskette/CD des
Hardware-Herstellers. Wechseln Sie hierzu in das Ver-
zeichnis Driver\Win2000_XP\PCI auf der CD oder bei
bereits installiertem CIF Device Driver in das Verzeich-
nis der Treiberhilfsprogramme

(...\Programme\CIF Device Driver\Win2000_XP\PClI).

4b. Unter Windows NT werden PCl-Karten nicht auto-
matisch erkannt, sondern missen manuell Gber den
CIF Device Driver aktiviert werden. Die Aktivierung
erfolgt mithilfe des Programms CIF Device Driver
Setup im Meni PCI > Setup > Activate PCI support.
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2. If you are using the interrupt mode you have to set up
a free interrupt on the CIF.

3. First switch off the power of the PC and all connected
devices.

4. Open the cabinet of the PC and plug in the CIF on a
free ISA slot. Up to four CIFs per PC are supported by
the CIF Device Driver. Fix the CIF using the hole
intended.

5. Close the PC and switch on the power of the PC.

PCl cards

1. First switch off the power of the PC and all connected
devices.

2. Open the cabinet of the PC and plug in the CIF on a
free PCI slot. Up to four CIFs per PC are supported by
the CIF Device Driver. Fix the CIF using the hole
intended.

3. Close the PC and switch on the power of the PC.

4a. Windows 2000/XP detect the CIF automatically and
will open the window New Hardware Found. The CIF
is detected as an Other Bridge Device. The installation
devices assistant asks for a disk/CD from the hardware
manufacturer. For this purpose, change to the directory
Driver\Win2000_XP\PCI on the CD or if the CIF Device
Driver is already installed into the directory of the driver
utilities (...Program Files\CIF Device Driver
\Win2000_XP\PClI).

4b. Under Windows NT the PCI cards are not detected
automatically, they have to be activated manually via
the CIF Device Driver. The activation is done with help
of the CIF Device Driver Setup Program in the menu
PCI > Setup > Activate PCI support.



4c. Windows 95/98/ME erkennen das CIF automatisch
und 6ffnen das Fenster Neue Hardwarekomponente
gefunden. Der Installationsassistent erwartet eine Dis-
kette/CD des Hardware-Herstellers. Wechseln Sie hier-
zu in das Verzeichnis Driver\Win9x\PClI auf der CD
oder bei bereits installiertem CIF Device Driver in das
Verzeichnis der Treiberhilfsprogramme
(...\Programme\CIF Device Driver\Win9x\PCl).

5. Nach erfolgreicher Installation ist der PC neu zu
starten.

PCMCIA-Karten

1. PCMCIA-Karten kénnen bei einigen Betriebssyste-
men im laufenden PC hinzugefligt oder entfernt wer-
den. Halten Sie die Karte so, dass das Hilscher-Logo
nach oben und der 68-polige Stecker zum Steckplatz
zeigt. Stecken Sie die Karte bis zum Einrasten in den
PCMCIA-Karten-Steckplatz.

2a. Windows 2000/XP erkennt das CIF automatisch
und 6ffnet das Fenster Neue Hardware gefunden. Das
CIF wird als Hilscher_GmbH CIF60_... erkannt. Der
Installationsassistent erwartet eine Diskette/CD des
Hardware-Herstellers. Wechseln Sie hierzu in das Ver-
zeichnis Driver\Win2000_XP\PCMCIA auf der CD oder
bei bereits installiertem CIF Device Driver in das Ver-
zeichnis der Treiberhilfsprogramme (...\Programme\CIF
Device Driver\Win2000_XP\PCMICIA).

2b. Windows NT ist kein Plug-and-Play-Betriebs-
system. Die PCMCIA-Karte nur bei ausgeschaltetem
PC hinzufiigen oder entfernen.

2c. Windows 95/98/ME erkennen das CIF automatisch
und 6ffnen das Fenster Neue Hardwarekomponente
gefunden. Der Installationsassistent erwartet eine
Diskette/CD des Hardware-Herstellers. Wechseln Sie

4c. Windows 95/98/ME will detect the CIF automatical-
ly and will open the window New Hardware Found.
The installation assistent asks for a disk/CD from the
hardware manufacturer. For this purpose, change to the
directory Driver\Win9x\PCI on the CD or if the CIF
Device Driver is already installed into the directory of
the driver utilities

(...\Programs\CIF Device Driver\Win9x\PClI).

5. After a successful installation the PC has to be
rebooted.

PCMCIA cards

1. Some operating systems support that PCMCIA cards
can be plugged in and removed while the system is
powered on. Hold the card with the Hilscher logo facing
upward and the 68-pin card connector to the card slot.
Insert the card into the PCMCIA card slot and push it in
until it is firmly seated.

2a. Windows 2000/XP detects the CIF automatically
and opens the windows New Hardware found. It will
detected the CIF as Hilscher_GmbH CIF60_... The
installation assistant asks for a disk/CD from the hard-
ware manufacturer. For this purpose, change to the
directory Driver\Win2000_XP\PCMCIA on the CD or if
the CIF Device Driver is already installed into the direc-
tory of the driver utilities (...\Program Files\CIF Device
Driver\Win2000_XP\PCMCIA).

2b. Windows NT is no Plug & Play operating system.
The PCMCIA card can only be added or removed if the
PC is switched off.

2c. Windows 95/98/ME will detect the CIF automatical-
ly and will open the window New Hardware Found.
The installation assistent ask for a disk from the hard-
ware manufacturer. For this purpose, change to the



hierzu in das Verzeichnis Driver\Win9x\PCMCIA auf
der CD oder bei bereits installiertem CIF Device Driver
in das Verzeichnis der Treiberhilfsprogramme
(...\Programme\CIF Device Driver\Win2000_XP\
PCMICIA).

3. Nach erfolgreicher Installation ist der PC neu zu
starten.

directory Driver\Win9x\PCMCIA on the CD or if the CIF
Device Driver is already installed into the directory of
the driver utilities (...\Program Files\CIF Device Dri-
ver\Win2000_XP\PCMCIA).

3. After a successful installation the PC has to be
rebooted.



Geratezeichnungen Device Drawings
Typ / Type Karte / Card Dual-Port Memory Funktion / Function
CIF 30-DNS ISA 8 KByte DeviceNet-Slave
CIF 30-DNM ISA 8 KByte DeviceNet-Master
- R E 0 DeviceNet-Schnittstelle
il q (COMBICON-Stecker)
] AR B o
= DeviceNet Interface
m %@ (COMBICON male connector)
% m S [OeoH
5 0mD .
m % Diagnoseschnittstelle
® m (DSub-Stecker)
0 e=
[} o
D m oo 1 ] I(:)Diasgr:)osticl Imerfacet )
[m] o @ ub male connector,
o % = @ —
m O -
5= ] "=k
o s 588
— =
Scom & - 0o g EE RDY RUN
ﬂ ﬂ 5[z NET MOD

Interrupt 115 114 112 11

Kein / no CA000 X X
15 X CC000 X X | X
14 X CE000 X | X
12 X D0000 X | X | X X
11 X D2000 X | X X
D4000 X X X
9 X D6000 X X

X = Steckbriicke gesteckt / Jumper closed

[ Grundeinstellung / Default configuration |

Weitere Beispiele fir Jumpereinstellungen finden Sie auf der CD im Verzeichnis CD:/Fag/jumper.pdf.
Further examples for jumper settings are on the CD in the directory CD:/Faq/jumper.pdf.
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Typ / Type Karte / Card Dual-Port Memory Funktion / Function
CIF 50-DNS PCI 8 KByte DeviceNet-Slave
CIF 50-DNM PCI 8 KByte DeviceNet-Master

Hilscher GrmH
OCIF50-DNM

€€ OCIF50-INS

m

DeviceNet-Schnittstelle

(COMBICON-Stecker)

DeviceNet Interface =0
(COMBICON male connector) — @

Diagnoseschnittstelle
(DSub-Stecker)

Diagnostic Interface
(DSub male connector)

o
rov RUN C{[®]
NET MOD [ =x

Die Adresseinstellung erfolgt automatisch durch den
CIF Device Driver und kann mit dem Programm CIF
Device Driver Setup Uberprift werden.

Fir die Betriebssysteme Windows 95/98/ME und NT ist
der CIF Device Driver ab Version 3.010 oder héher zu
verwenden.

Fir die Betriebssysteme Windows 2000 und XP ist der
CIF Device Driver Version 3.110 oder héher zu verwen-
den.

based on ECl
L0405002

0= .,
o] 0F H *

[ A A

=a

\
]
]

(=)

The address setting takes place automatically by the
CIF Device Driver and can be checked with the pro-
gram CIF Device Driver Setup.

For the operating systems Windows 95/98/ME and NT
you have to use the CIF Device Driver version 3.010 or
higher.

For the operating systems Windows 2000 and XP you
have to use the CIF Device Driver version 3.110 or
higher.



Typ | Type Karte / Card Dual-Port Memory Funktion / Function
CIF 60-DNS PCMCIA 8 KByte DeviceNet-Slave
CIF 60-DNM PCMCIA 8 KByte DeviceNet-Master

Communication Interface

. CIF 60

RDY @
RUN @
MNS @
not used @

2

L
J

DeviceNet-Schnittstelle
(COMBICON-Stecker)

DeviceNet Interface
(COMBICON male connector)

12 3\4 5

Die Adresseinstellung erfolgt automatisch durch den The address setting takes place automatically by the
CIF Device Driver und kann mit dem Programm CIF CIF Device Driver and can be checked with the pro-
Device Driver Setup (berprift werden. gram CIF Device Driver Setup.
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Typ | Type Karte / Card Dual-Port Memory Funktion / Function
CIF 80-DNS Compact PCI 8 KByte DeviceNet-Slave
CIF 80-DNM Compact PCI 8 KByte DeviceNet-Master
° III
ws O = % q 3 0 e’
DeviceNet-Schnittstelle M E. « — T mm\ || I By
(COMBICON-Stecker) A @ D
" 0e,0° o ] [ | 0 G4
DeviceNet Interface Ny = ) E g ]
(COMBICON male connector) Rii ] e g o o B g
L [Tooeees
Diagnoseschnittstelle T RN = m - i
(DSub-Stecker) oo D Dmom
Diagnostic Interface E oo § B ez
(DSub male connector) El @ alz) 8 - b
O - =
HS RDY RUN B i mﬂ] -z
OO0O00 e nerseny OO0 0 T s

Die Adresseinstellung erfolgt automatisch durch den
CIF Device Driver und kann mit dem Programm CIF
Device Driver Setup liberprift werden.

Fur die Betriebssysteme Windows 95/98/ME und NT ist
der CIF Device Driver ab Version 3.010 oder hoher zu
verwenden.

Fir die Betriebssysteme Windows 2000 und XP ist der
CIF Device Driver Version 3.110 oder héher zu verwen-
den.

The address setting takes place automatically by the
CIF Device Driver and can be checked with the pro-
gram CIF Device Driver Setup.

For the operating systems Windows 95/98/ME and NT
you have to use the CIF Device Driver version 3.010 or
higher.

For the operating systems Windows 2000 and XP you
have to use the CIF Device Driver version 3.110 or
higher.
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Typ | Type Karte / Card Dual-Port Memory
CIF 104-DNS PC/104 8 KByte
CIF 104-DNS-R PC/104 8 KByte
CIF 104-DNM PC/104 8 KByte
CIF 104-DNM-R PC/104 8 KByte

DeviceNet-Schnittstelle
(COMBICON-Stecker)

DeviceNet Interface
(COMBICON male connector)

Diagnoseschnittstelle
(DSub-Stecker)

Diagnostic Interface
(DSub male connector)

Adresse /Address A13

Funktion / Function
DeviceNet-Slave
DeviceNet-Slave *
DeviceNet-Master
DeviceNet-Master *

* Karte mit Stecker an der rechten Seite nicht abgebildet / boards with connector on the right side are not shown

s,
Bk

B guns

om

MOD
NET
RUN
RDY

CA000 X X | X
CCO000 X X | X
CE000 X | X
D0000 X | X | X X
D2000 X | X X
D4000 X X X

X = Steckbriicke gesteckt / Jumper closed

Interrupt

Option
Pfostenverbinder
anstelle von
DSub-Stecker
Option

Square post
connector instead

of a DSub connector

\P  10-polig gewinkelt
10 pin angled

\S 10-polig gerade
10 pin straight

\H 16-polig gewinkelt
16 pin angled

\V  16-polig gerade
16 pin straight

115 114 112

15
14
12

3

X

[ Grundeinstellung / Default configuration |

Weitere Beispiele fir Jumpereinstellungen finden Sie auf der CD im Verzeichnis CD:/Fag/jumper.pdf.
Further examples for jumper settings are on the CD in the directory CD:/Faq/jumper.pdf.
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Typ / Type Karte / Card
CIF 104P-DNS PC/104+ 8 KByte
CIF 104P-DNM PC/104+ 8 KByte
DeviceNet-Schnittstelle
(Combicon-Stecker)
Option . DeviceNet Interface
Pfostenverbinder (Combicon male connector)
anstelle von

DSub-Stecker

Diagnoseschnittstelle

Option (DSub-Stecker)
Square post
connector instead

of a DSub connector

Diagnostic Interface
(DSub male connector)

\P  10-polig gewinkelt
10 pin angled
\S 10-polig gerade
10 pin straight
16-polig gewinkelt
16 pin angled
16-polig gerade
16 pin straight
Der Schalter dient zur Einstellung der physikalischen
Steckplatznummer. Es kénnen max. 4 Module aufeinan-
der gesteckt werden und jede Schaltereinstellung darf
nur einmal verwendet werden. Das Modul, das direkt
am Host-Controller aufgesteckt ist, erhalt die CLK 0, die
folgenden Module erhalten die nachsthohere CLK-Num-
mer.

\H

\V

Die Adresseinstellung erfolgt automatisch durch den
CIF Device Driver und kann mit dem Programm CIF
Device Driver Setup Uberprift werden. Fir die
Betriebssysteme Windows 95/98/ME und NT ist der CIF
Device Driver ab Version 3.010 oder héher zu verwen-
den. Fir die Betriebssysteme Windows 2000 und XP ist
der CIF Device Driver Version 3.110 oder héher zu ver-
wenden.

Dual-Port Memory

Funktion / Function

15

DeviceNet-Slave
DeviceNet-Master
0 5 O Hgic]
N 0="0
][] ooo
D[Hj (] ¥ | MNS
E‘QE' F %m RUN
3 \roY
Switch Module No. CLK  ID Select INT
Position  Slot
0,4,8 1 CLKO IDSELO INTA
1,59 2 CLK1 IDSEL1 INTB
2,6 8 CLK2 IDSEL2 INTC
3,7 4 CLK3 IDSEL3 INTD

The switch is used for setting the physical slot number.
Max. 4 modules can be plugged on each other. Each
slot setting can be used only one time. The module next
to the host controller gets the CLK 0, the following
modules get the next higher CLK number.

The address setting takes place automatically by the
CIF Device Driver and can be checked with the pro-
gram CIF Device Driver Setup. For the operating
systems Windows 95/98/ME and NT you have to use
the CIF Device Driver version 3.010 or higher. For the
operating systems Windows 2000 and XP you have to
use the CIF Device Driver version 3.110 or higher.



Typ / Type Karte / Card
PMC-DNS PMC 8 KByte
PMC-DNM PMC 8 KByte

DeviceNet-Schnittstelle
(COMBICON-Stecker)

DeviceNet Interface
(COMBICON male connector)

MNS
RUN RDY

Dual-Port Memory

Funktion / Function
DeviceNet-Slave
DeviceNet-Master

1

mm

Die Adresseinstellung erfolgt automatisch durch den
CIF Device Driver und kann mit dem Programm CIF
Device Driver Setup Uberprift werden.

Fir die Betriebssysteme Windows 95/98/ME und NT ist
der CIF Device Driver ab Version 3.010 oder héher zu

verwenden.

Fir die Betriebssysteme Windows 2000 und XP ist der
CIF Device Driver Version 3.110 oder héher zu verwen-

den.

= B Bf
E:t i
] pic-en 0 g oe B
[] Puc-con
% s OB B
Ly (] pwc-Das D 2] ] [] 2] o
@ L0115002 O
Befestigungsbolzen
Fixing Bolt

PCI-Bus

PCI Bus

The address setting takes place automatically by the
CIF Device Driver and can be checked with the pro-
gram CIF Device Driver Setup.

For the operating systems Windows 95/98/ME and NT
you have to use the CIF Device Driver version 3.010 or
higher.

For the operating systems Windows 2000 and XP you
have to use the CIF Device Driver version 3.110 or
higher.
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DeviceNet-Schnittstelle

DeviceNet Interface

Potentialfreie ISO-11898-Schnittstelle geman
DeviceNet Spezifikation.

Anschluss mit
Combicon-Stecker Pfostenverbinder

Verbindung mit

Signal
Signal

Isolated ISO 11898 interface according the DeviceNet
specification.

Farbe
Color

Bedeutung
Meaning

Connection with Combi- Connection with

con male connector square post connector

1 5 V- Schwarz Bezugspotential DeviceNet-Spannungs-

Black versogung / Reference potential
DeviceNet power supply

2 & CAN_L Blau CAN Low-Signal
Blue

3 10 Drain Schirm / Shield

4 4 CAN_H | Weil CAN High-Signal
White

5 8 V+ Rot +24 V-DeviceNet-Spannungsversogung /
Red +24 V DeviceNet power supply

Bitte beachten Sie, dass an beiden Enden des Kabels
Abschlusswiderstande von 120 Ohm vorhanden sind.

An dem Buskabel kénnen tber Stichleitungen weitere
Gerate angeschlossen werden. Diese dirfen max. 6 m
lang sein. Die Gesamtlange des Buskabels und aller
Stichleitungen darf die max. Lange in der nachfolgen-
den Tabelle nicht Uberschreiten. Es gibt zwei verschie-
dene Kabeltypen. Werden diese gemischt verwendet,

berechnet sich die max. Lange wie folgt:
Ldick * 5 % Lginn <= 500 m bei 125 kBaud
Ldick * 2,5 X Lgijnn <= 250 m bei 250 kBaud

Ldick * Ldiinn <= 100 m bei 500 kBaud
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Please ensure that termination resistors with 120 Ohm
are available at both ends of the cable.

Further devices can be conneted via T stubs to the bus
cable. The maximum length of all T stubs is 6 m. The
whole length of the bus cable and all T stubs does not
exceed the maximum length listed in the following table.
There are two different types of cables. If both cables
types are used within the same network, the maximum

length is:
Lthick + 5 X Lthin <= 500 m at 125 kBaud
Lthick * 2,5 X Lthjn <= 250 m at 250 kBaud

Lthick * Lthin <= 100 m at 500 kBaud



DeviceNet-Netzteil
power supply for DeviceNet

COMEnco

A
DeviceNet-Schnittstelle

DeviceNet-Schnittstelle

DeviceNet Interface DeviceNet Interface
Versorgungsleitung
24V 5 rot / red power lines 5 24V
GND 1 schwarz / black 1 1. eND
CAN_High >4 ~ weift / white verdrilte Leitung ~ 4. CAN_High

twisted pair cable

2, CAN_Low

CAN_Low Blau / blue
L) )
B Y benkeee I s,
COMBICON-Buchse / COMBICON-Buchse /
COMBICON female connector COMBICON female connector

Sie kénnen bis zu 64 DeviceNet-Geréate liber den Bus Up to 64 DeviceNet devices can be linked together over
miteinander verbinden. Die maximale Lénge des Bus- the bus. The maximum length of the bus cable depends
kabels ist abhangig von der verwendeten Baudrate und on the used baud rate and the used cable type.
dem Kabeltyp. Bitte verwenden Sie nur speziell fir Only special proved DeviceNet cable should be used.
DeviceNet zugelassenes Kabel.

Stromversorgungskabel* dick dunn Datenleitung* dick  diinn

Power supply cable* thick  thin Data line cable thick  thin

Schleifenwiderstand <11,8 <57,4 Ohm/km Wellenwiderstand 120 120 Ohm

Loop resistance Impendance

Aderndurchmesser 2x1,42x0,7 mm Kapazitatsbelag <39,4 <394 pfim

Wire gauge Capacity

Schleifenwiderstand <22,6 <91,8 Ohm/km
Loop resistance
Baudrate Max. Lange bei Kabeltyp Aderndurchmesser 2x1,12x0,6 mm
Baud rate Max. distance with cable type Wire gauge

dick / thick diinn / thin

* Das DeviceNet-Buskabel besteht aus den Daten-

125 kBit/s 500 m 100 m R

und den Spannungsversorgungsleitungen.
250 kBit/s 250 m 100 m The DeviceNet cable contains of the data line cables
500 kBit/s 100 m 100 m and the power supply cables.
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Diagnoseschnittstelle

Diagnostic Interface

Nicht auf PCMCIA-Karten und PMC-Modulen

Potentialgebundene RS-232C-Schnittstelle zum
Anschluss an die COM-Schnittstelle des PCs.

DSub-Stecker Pfostenverbinder

Not at PCMCIA cards and PMC modules

Non isolated RS-232C interface to connect with the

COM port at the PC.
Bedeutung

Meaning

Eingang/Ausgang

Input/Output

9-polig 10-polig 16-polig

DSub male square post connector

connector 9 pil 10 pin 16 pin
2 ] 7 RXD
3 5 9 TXD
4 7 11 DTR
5 ) 13 GND

(6)n.v./n.c. n.v./n.c. n.v./n.c. DSR
7 4 8 RTS
8 6 10 CTS

n.v. nicht verwendet / n.c. not connected

CIF

Empfangsdaten / Receive Data
Sendedaten / Send Data

Datenendeinrichtung betriebsbereit /

Data Terminal Ready
Betriebserde / Signal Ground
Betriebsbereitschaft /

Data Set Ready

Sendeteil einschalten /
Ready to Send
Sendebereitschaft /

Clear to Send

PC

Eingang / Input
Ausgang / Output
Ausgang / Output

Eingang / Input
Ausgang / Output

Eingang / Input

Schirm am Steckergehéduse

2
RXD —l

3
TXD —m

DTR —m >—‘
S
GND —m

[

nc. —il v
7

RTS —il
8

CTS —

9-polige DSub-Buchse
9 pin DSub female connector

|
Freee

9-polige DSub-Buchse
9 pin DSub female connector
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RXD
TXD
DTR
GND
DSR
RTS
CTsS

Shield at connector casing
2



Installation der Software

Installation of the Software

Schlieen Sie alle Programme!

Legen Sie die CD in das lokale CD-ROM-Laufwerk.
Das Installationsprogramm startet selbststandig
(Autostart eingeschaltet). Andernfalls wechseln Sie
in das Root-Verzeichnis der CD und starten Sie
Autorun.exe (Autostart ausgeschaltet).

HINWEIS Unter Windows NT/2000/XP benétigen Sie
Administratorrechte zur Installation!

Das Installationsprogramm fragt, welche Komponenten
installiert werden sollen. Beantworten Sie diese Fragen
mit Ja bzw. Nein.

Installiert werden

» Systemkonfigurator SyCon
« OPC-Server
« CIF Device Driver.

Wenn ein Lizenzcode im Lieferumfang mit enthalten ist,
finden Sie ihn flir den Systemkonfigurator als Label auf
dieser CD oder in einem Briefumschlag ein Lizenzcode-
anforderungsformular. Falls ein Lizenzcode vorhanden
ist, beantworten Sie die Frage nach einem vorhande-
nen Lizenzcode mit Ja, ansonsten wird eine Basisversi-
on des Systemkonfigurators installiert. Geben Sie lhren
Namen und den Firmennamen ein.

Installation
des SoftSPS-Treibers

Close all application programs on the system!

Insert the CD in the local CD ROM drive. The
installation program will start by itself (Autostart enab-
led). Otherwise change into the root directory on the CD
and start Autorun.exe (Autostart disabled).

NOTE Administrator privileges are required on
Windows NT/2000/XP systems for installation!

The installation program ask for the components you
want to install. Answer these questions with Yes or No.

It will install

+ System Configurator SyCon
» OPC Server
« CIF Device Driver.

If a license code is included in the scope of delivery you
will find it for the System Configurator on a label on this
CD orin an envelope a license code request form. In
case you have a license code, answer the question for
an existing license code with Yes, otherwiese a basic
version of the system configurator will be installed.
Enter your name and the company name.

Installation
of the SoftPLC Driver

Die Beschreibung der Installation ist auf der CD in
\DRIVER\SOFTPLC\ vorhanden. Zum Betrieb des
SoftSPS-Treibers ist eine Lizenz auf dem CIF notwen-
dig.

The description of the installation is on the CD in
\DRIVER\SOFTPLC\. To use the SoftPLC Driver a
license on the CIF is necessary.



Installation des
Systemkonfigurators SyCon

Installation of the
System Configurator SyCon

Bei der Installation miissen Sie lhren Namen und den
Firmennamen eingeben.

Wenn ein Lizenzcode im Lieferumfang mit enthalten ist,
finden Sie ihn flr den Systemkonfigurator als Label auf
dieser CD oder in einem Briefumschlag ein Lizenzcode-
anforderungsformular. Falls ein Lizenzcode vorhanden
ist, beantworten Sie die Frage nach einem vorhande-
nen Lizenzcode mit Ja, ansonsten wird eine Basisversi-
on des Systemkonfigurators installiert. lhnen stehen
dann alle Funktionen zur Verfiigung, jedoch ist die Kon-
figuration auf zwei Gerate am Netzwerk beschrankt,
was flir Slave-Teilnehmer ausreichend ist.

Unter dem Menupunkt Hilfe > Lizenzierung kénnen
Sie ein Bestellformular fiir Ihre Lizenz ausfiillen und an
lhren Distributor oder direkt an uns faxen.

Folgen Sie den Anweisungen des Installationsprogram-
mes, wahlen Sie die zu installierenden Feldbussysteme
aus und beantworten die Fragen mit JA oder WEITER.

During the installation the user and the company name
must be entered.

If a license code is included in the scope of delivery you
will find it for the System Configurator on a label on this
CD or in an envelope a license code request form. In
case you have a license code, answer the question for
an existing license code with Yes, otherwiese a basic
version of the system configurator will be installed. In
this case, all functions are available, but the
configuration is limited to two devices on the network,
which is sufficient for slave devices.

Alicense can be ordered by filling out the order form
under the menu item Help > Licensing and fax this
order form either to your distributor or directly to us.

Follow the instructions of the installation program by
selecting the fieldbus system to be installed and
answering all the questions with OK or NEXT.



Installation
des OPC-Servers

Installation
of the OPC Server

Installieren Sie bei Windows 95 und Windows 98 die
Betriebssystemerweiterung DCOM95 oder DCOM98.
(Zu beziehen uber
www.microsoft.com/com/resources/download.asp
bzw. im Internet Explorer ab Version 4.0 enthalten)

Bei Windows NT, Windows 2000 und Windows XP
sind diese Erweiterungen bereits vorhanden.

Installieren Sie den OPC-Server auf dem PC, in dem
das CIF installiert ist.

Wenn der OPC-Client auf einem anderen PC ausge-
fiihrt wird, dann installieren Sie zusatzlich auf diesem
PC den OPC-Server-Remote-PC.

Zum Betrieb des OPC-Servers ist eine Lizenz auf dem
CIF notwendig. Weitere Angaben zur Installation finden
Sie auf der CD in
\MANUAL\DEUTSCH\OPC\OPC_OID.PDF.
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For Windows 95 and Windows 98 install the operating
system extension DCOM95 or DCOM98. (Available on
www.microsoft.com/com/resources/download.asp
or components of the Internet Explorer from version
4.0)

In Windows NT, Windows 2000 and Windows XP
these extensions already exist.

Install the OPC Server on the PC that has the CIF
installed.

If the OPC Client is executed on another PC, then
install additionally OPC-Server remote station on that
PC.

To use the OPC Server a license on the CIF is
necessary.

More information about the installation are on the CD in
\MANUAL\ENGLISH\OPC\OPC_OIE.PDF.



Installation des
CIF Device Driver

Installation of the
CIF Device Driver

Wabhlen Sie CIF Device Driver aus dem Installations-
mentii oder starten Sie aus dem CD-Verzeichnis \Driver
das Programm Setup.exe.

Nach der Installation muss der CIF Device Driver ent-
sprechend des verwendeten CIFs konfiguriert werden.

Der Treiber akzeptiert maximal 4 Karten.

Konfiguration des
CIF Device Driver

Select CIF Device Driver in the installation menu or
start the program Setup.exe from the CD directory
\Driver.

After the installation the Device Driver has to be
configured according to the used CIF.

The driver accepts max. up to 4 cards.

Configuration of the
CIF Device Driver

Starten Sie das Setup Uber Start > Programme > CIF
Device Driver > CIF Device Driver Setup.

In den folgenden Abschnitten finden Sie eine Beschrei-
bung zur Konfiguration der von lhnen verwendeten CIF-
Karte unter dem von lhnen verwendeten
Betriebssystem.

ISA- und PC/104-Karten

Start the setup via Start > Programs > CIF Device Dri-
ver > CIF Device Driver Setup.

In the following sections you find a description of
configuring the CIF card which is used by you under the
used operating system.

ISA and PC/104 Cards

ISA- und PC/104-Karten unter Windows 2000/XP

1. Offnen Sie mit Systemsteuerung > System > Hard-
ware > Hardware-Assistent den Windows 2000 bzw.
XP Hardware-Assistenten.

2. Wahlen Sie Gerét hinzufiigen bzw. Problem behe-
ben.

3. Nach der automatischen Hardwareerkennung Suche
nach neuen Hardwarekomponenten wahlen Sie
Neues Gerit hinzufiigen.

ISA and PC/104 cards under Windows 2000/XP

1. Open the Windows 2000 or the XP Hardware Wizard
with Control Panel > System > Hardware > Hardware
Wizard.

2. Choose Add/Troubleshoot a device.

3. After the automatic New Hardware Detection
choose Add new device.



4. Wahlen Sie Nein, die Hardwarekomponenten
selbst aus einer Liste auswéhlen. Klicken Sie entwe-
der auf Andere Gerite oder falls vorhanden auf CIF
Communication Interface. Wahlen Sie dann Daten-
trager... und wechseln Sie zum CD-Verzeichnis
Driver\Win2000_XP\ISA oder, falls der Treiber bereits
installiert ist, in das Treiberinstallationsverzeichnis
...\Programme\CIF Device Driver\Win2000_XP\ISA.
Verfahren Sie bei CIF Communication Interface in glei-
cher Weise, wenn keine ISA-Karte zur Auswahl steht.

5. Wahlen Sie, in Abhangigkeit der verwendeten Karte,
CIF 10/30/40/104 (ISA-2KByte) oder
CIF 10/30/40/104 (ISA-8KByte)
aus. Sie werden dann aufgefordert den Speicherbereich
und gegebenenfalls den Interrupt des CIFs entspre-
chend der Hardwarevorgabe einzustellen.

6. Nach den Einstellungen miissen Sie lhren PC neu
starten.

HINWEIS: Standardmagig ist die Adresse CA000 und
kein Interrupt eingestellt (Basis-Konfiguration 0). Zum
Andern der Adresse wahlen Sie Basis-Konfiguration 1.
Interrupt und Adresse kénnen unter Basis-Konfiguration
2 geandert werden. Weitere Hinweise finden Sie auf der
CD in \FAQ\DEUTSCH\ISA\isa_d.pdf.

HINWEIS: Auf manchen PCs steht kein freier ISA-Spei-
cher im Bereich C0000—FFO000 und kein ISA-Interrupt
zur Verfligung. Der Grund kann am Windows 2000
ACPI (Advanced Configuration and Power Management
Interface) liegen. Uberpriifen Sie zuerst, ob Ihr PC
ACPI-konform ist und ob Sie das aktuellste BIOS des
Mainboardherstellers verwenden. Sollte es trotzdem
keine freien ISA-Ressourcen geben, so kénnen Sie
auch versuchen Windows 2000 im ,Standard PC*-
Modus (ACPI abgeschaltet) zu betreiben. Hierzu muss
die ACPI-HAL von Windows 2000 durch die
STANDARD-PC-HAL ersetzt oder Windows 2000 neu
installiert werden. Bitte kontaktieren Sie Microsoft zur
Vorgehensweise, da die Installation unbrauchbar werden
kann.
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4. Select No, | want to select the hardware from a
list. Now click on either Other devices or CIF Commu-
nication Interface if available. From Other devices
choose Have disk and change to the CD directory
Driver\Win2000_XP\ISA or the driver installation direc-
tory

...\Program Files\CIF Device Driver\Win2000_XP\ISA.
Proceed in the same manner if you can't find an entry
for a CIF ISA card under CIF Communication Interface.

5. Choose either

CIF 10/30/40/104 (ISA-2KByte) or

CIF 10/30/40/104 (ISA-8KByte)
depending on the hardware type. You will be asked to
set the memory area and if necessary to set an interrupt
both corresponding to the hardware settings of the CIF.

6. After an installation you have to reboot the PC.

NOTE: The default setting is address CA000 and no
interrupt (Basis Configuration 0). To change the address
select Basis Configuration 1. The interrupt and the
address can be changed under Basis Configuration 2.
You will find more information on the CD in
\FAQ\ENGLISH\ISA\isa_e.pdf.

NOTE: On some PCs it is not possible to find a free ISA
memory area between CO000—FF000 or a free ISA
interrupt in the Device Manager. This is Windows 2000
ACPI (Advanced Configuration and Power Management
Interface) depending. Please check at first if your PC is
ACPI compatible and you are using the latest BIOS ver-
sion for your mainboard. Are there still problems to find
available ISA resources, you can try to run Windows
2000 in "Standard PC" mode (ACPI disabled).
Therefore the ACPI-HAL of Windows 2000 must be
replaced with the STANDARD-PC-HAL or Windows
2000 must be installed new. Please contact Microsoft
how to change the Windows 2000-HAL, because this
can make your installation unusable.



ISA- und PC/104-Karten unter Windows
95/98/ME/NT

Geben Sie die konfigurierte Startadresse des CIFs in
Dual-Port Memory base address und die GroRRe des
Dual-Port Memory in Dual-Port Memory size ein.

Betreiben Sie das CIF im Interrupt-Modus, dann ist in
Interrupt number der konfigurierte Interrupt anzuge-
ben, ansonsten ist Polling einzustellen.

Weitere Hinweise finden Sie auf der CD im Verzeichnis
\FAQ\DEUTSCH\ISA\isa_d.pdf.

PCIl-Karten

ISA and PC/104 cards under Windows 95/98/ME/NT

Enter the configured start address of the CIF into Dual-
Port Memory base address and the size of the Dual-
Port Memory into Dual-Port Memory size.

If an interrupt on the card has been set by means of a
jumper, then enter the same Interrupt number, if not
enter Polling.

You find more information on the CD in the directory
\FAQ\ENGLISH\ISA\isa_e.pdf.

PCI Cards

PCl-Karten unter Windows 2000/XP

1. PCI-Karten werden von Windows 2000/XP automa-
tisch erkannt. Das System meldet sich mit Neue Hard-
ware gefunden. Falls nicht, starten Sie den Hardware-

ten unter S lerung > S >
Hardware > Hardware-Asswtent und wahlen Sie
Gerat hinzufiigen bzw. Problem beheben.

2. Windows 2000/XP sucht nun nach neuen Plug-and-
Play-Geraten. Die PCl-Karte wird als Anderes PCI-
Briickengerat angezeigt.

3. Wahlen Sie Nach einem passenden Treiber fiir
das Gerat suchen (empfohlen) und klicken Sie auf
Weiter.

4. Wahlen Sie das CD-Verzeichnis
Driver\Win2000_XP\PCI oder, wenn der CIF Device
Driver bereits installiert ist, das Verzeichnis
...\Programme\CIF Device Driver\Win2000_XP\PCI.

5. Zeigt der Gerate-Manager bereits ein Anderes
Briickengerat an und ist dieses mit einem Fragezei-
chen/Ausrufezeichen markiert, klicken Sie das Gerat
mit der rechten Maustaste an und wahlen Sie Deinstal-
lieren. Wiederholen Sie den Vorgang fiir all diese Gerate.

PCI cards under Windows 2000/XP

1. Windows 2000/XP will recognize PCI cards automati-
cally during system startup. The system will show New
hardware found. If not choose the Hardware Wizard
under Control Panel > System > Hardware > Hard-
ware Wizard and select Add/Troubleshoot a device.

2. Windows 2000/XP searches for new Plug and Play
devices. The PCI card will be shown as Other PCI
Bridge Device.

3. Select Search for a suitable driver for my device
(recommended) and click Next.

4. Select on the CD the directory
Driver\Win2000_XP\PCI or if the CIF Device Driver is
already installed, the directory ...\Programs\CIF Device
Driver\Win2000_XP\PCI.

5. If the Device Manager already shows Other Bridge
Device marked with a question/exclamation mark,
make a right mouse click on the device and choose
Uninstall. Proceed in the same way for all such cards.



6. Wahlen Sie dann Aktion > Nach geanderter Hard-
ware suchen aus dem Meni. Wenn das System Neue
Hardware gefunden meldet, verfahren Sie wie bereits
oben beschrieben.

7. Das CIF wird standardméfig im Polling-Modus instal-
liert. Uber das Programm CIF Device Driver Setup
kann der Interrupt-Modus ein- bzw. ausgeschaltet wer-
den.

8. Nach dem Umstellen des Modus muss der PC neu
gestartet werden.

PCl-Karten unter Windows 95/98/ME/NT

Die Unterstiitzung von PCl-Karten muss im CIF Device
Driver aktiviert werden. Das Aktivieren und Deaktivieren
erfolgt mithilfe des Programms CIF Device Driver
Setup. Die bendtigten Ressourcen werden vom PC
(BIOS) automatisch zugeteilt.

1. Starten Sie das Programm CIF Device Driver Setup
aus der Programmgruppe CIF Device Driver.

2. Im Menlpunkt PCI > Setup muss das Feld Activate
PCI support angehakt werden. Der Interruptbetrieb fur
PCl-Karten wird mit Enable interrupt for board 0...3

ein- bzw. ausgeschaltet (Grundeinstellung: ausgeschaltet).

3. Setzen Sie alle Einstellungen fir nicht installierte
ISA-Karten (Board 0 ... 3) auf 00000 bzw. NONE.

4. Starten Sie nach der Konfiguration Ihren PC neu.

5. Wahrend des Systemstarts werden die Konfigurati-
onsdaten vom CIF Device Driver ermittelt und vom Pro-
gramm CIF Device Driver Setup angezeigt. Der Treiber
verteilt die Board-Nummern der PCI-Karten automa-
tisch. Hierzu werden nur freie (unbenutzte) Board-Num-
mern verwendet, wobei diese aufsteigend von 0 bis 3
auf die PCI-Karten verteilt werden. Sind alle Board-
Nummern belegt, werden keine weiteren PCl-Karten
mehr vom Treiber akzeptiert.
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6. After uninstallation choose Action > Scan for hard-
ware changes from the menu. When the system sig-
nals New hardware found follow the description
above.

7. The CIF will be always installed in polling mode. Use
CIF Device Driver Setup Program to change the
operating mode of the PCI cards from polling to
interrupt.

8. After changing the mode, you have to restart your
PC.

PCI cards under Windows 95/98/ME/NT

The driver support for PCI cards must be activated in
the CIF Device Driver. The activating and deactivating
is done with the help of the CIF Device Driver Setup
Program. The required resources are assigned
automatically by the PC (BIOS).

1. Start the program CIF Device Driver Setup of the
program group CIF Device Driver.

2. Select the menu PCI > Setup and check the
Activate PCI support field. Interrupt support for the
cards will be enabled or disabled by Enable interrupt
for board 0...3 (default: disabled).

3. Set all entries for not installed ISA cards (Board
0 ... 3) to 00000 respectively NONE.

4. Restart your PC after configuration.

5. During system start, the configuration data will be
determined by the CIF Device Driver and will be shown
in the CIF Device Driver Setup program. Also the board
numbers for PCI cards will be assigned automatically by
the driver. Therefore, the driver uses only free (unused)
board numbers in rising order from 0 to 3. The driver
does not accept additional PCI boards if all board num-
bers are in use.



HINWEIS: Kontrollieren Sie, ob im PC-BIOS gentigend
Interrupte zur Nutzung fiir PCl-Karten freigegeben sind
und vermeiden Sie die Mehrfachnutzung mit anderen

PCI-Geraten (z. B. Netzwerkkarten, Soundkarten o. A.).

Bei Timeout-Fehlern (z. B. -17, -18, -20) zwischen
Anwendungsprogramm und CIF deaktivieren Sie den
PCl-Interrupt des CIFs.

Weitere Hinweise finden Sie auf der CD in
\FAQ\DEUTSCH\PCl\pci_d.pdf.

PCMCIA-Karten

NOTE: Check your PC-BIOS if there are enough inter-
rupts configured for the use by PCI devices and avoid

multiple use of interrupts by different PCI devices (e.g.
Network cards, sound cards etc.).

If you encounter timeout errors between your
application program and the CIF card (e.g. -17, -18, -
20) deactivate the PCI interrupt of the CIF card.

You find more information on the CD in
\FAQ\ENGLISH\PCl\pci_e.pdf.

PCMCIA Cards

PCMCIA-Karten unter Windows 2000/XP

1. PCMCIA-Karten werden von Windows 2000/XP auto-
matisch erkannt. Das System meldet sich mit Neue
Hardware gefunden. Falls nicht, starten Sie den Hard-
ware-Assistenten unter Systemsteuerung > System >
Hardware > Hardware-Assistent und wahlen Sie
Gerat hinzufiigen bzw. Problem beheben.

2. Windows 2000/XP sucht nun nach neuen Plug-and-
Play-Geraten. Die PCMCIA-Karte wird als
Hilscher_GmbH CIF60-... angezeigt.

3. Wahlen Sie Nach einem passenden Treiber fiir
das Gerat suchen (empfohlen) und klicken Sie auf
Weiter.

4. Wahlen Sie das CD-Verzeichnis
Driver\Win2000_XP\PCMCIA oder, wenn der CIF
Device Driver bereits installiert ist, das Verzeichnis
...\Programme\CIF Device Driver\Win2000_XP\
PCMCIA aus.
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PCMCIA cards under Windows 2000/XP

1. Windows 2000/XP will recognize PCMCIA cards
automatically during system startup. The system will
show New Hardware Found. If not choose the Hard-
ware Wizard under Control Panel > System > Hard-
ware > Hardware Wizard and select
Add/Troubleshoot a device.

2. Windows 2000/XP searches for new Plug and Play
devices. The CIF PCMCIA card will be shown as
Hilscher_GmbH CIF60-...

3. Select Search for a suitable driver for my device
(recommended) and click Next.

4. Select from the CD the directory
Driver\Win2000_XP\PCMCIA or if the CIF Device
Driver is already installed, the

...\Programs\CIF Device Driver\Win2000_XP\PCMCIA
directory.



HINWEIS: Sollte Ihr PC einen sog. PCMCIA-Socket-
Adapter verwenden, der ISA-Speicherbereiche bendtigt,
so ist es moglich, dass der Gerate-Manager keine frei-
en ISA-Bereiche findet. Das CIF wird dann mit
UNKNOWN HARDWARE MANUFACTURE angezeigt.
Der Grund kann am Windows 2000 ACPI (Advanced
Configuration and Power Management Interface) lie-
gen. Uberpriifen Sie zuerst, ob Ihr PC ACPI-konform ist
und ob Sie das aktuellste BIOS des Mainboardherstel-
lers verwenden. Sollte es trotzdem keine freien ISA-
Ressourcen geben, so kénnen Sie auch versuchen
Windows 2000 im ,Standard PC"-Modus (ACPI abge-
schaltet) zu betreiben. Hierzu muss die ACPI-HAL von
Windows 2000 durch die STANDARD-PC-HAL ersetzt
oder Windows 2000 neu installiert werden. Bitte kontak-
tieren Sie Microsoft zur Vorgehensweise, da die Instal-
lation unbrauchbar werden kann.

PCMCIA-Karten unter Windows 95/98/ME und NT

1. Windows 95/98/ME erkennen bei eingeschalteter
PCMCIA-Funktion die Karte automatisch. Bei jedem
Hinzufiigen und Entfernen des CIFs muss der PC neu
gestartet werden, damit auch der CIF Device Driver die
Karte erkennen kann.

2. Windows NT bendtigt zum Aktivieren von PCMCIA-
Karten eine spezielle Vorgehensweise. Die PCMCIA-
Dienste von Windows NT miissen gestartet sein. Wech-
seln Sie hierzu in die Systemsteuerung und 6ffnen Sie
Geréte. Das Gerat PCMCIA muss den Status Gestartet
und die Startart Neustart besitzen. Falls nicht andern
Sie die Startart auf Neustart.

3. Aktivieren Sie bei Windows NT die PCMCIA-Unter-
stlitzung des CIF Device Driver. Starten Sie das Pro-
gramm CIF Device Driver Setup aus der Programm-
gruppe CIF Device Driver. Im Menlipunkt PCMCIA >
Setup muss das Feld Activate PCMCIA support ange-
hakt werden.

ATTENTION: If you are using PCMCIA socket adapter
which mappes the PCMCIA card to the ISA memory, on
some PCs it is not possible for the Device Manager to
find free ISA memory resource. The device will than be
shown as UNKNOWN HARDWARE MANUFACTURE.
This is Windows 2000 ACPI (Advanced Configuraton
and Power Management Interface) depending. Please
check at first if your PC is ACPI compatible and you are
using the latest BIOS version for your mainboard. Are
there still problems to find available ISA resources, you
can try to run Windows 2000 in "Standard PC" mode
(ACPI disabled). Therefore the ACPI-HAL of Windows
2000 must be replaced with the STANDARD-PC-HAL or
Windows 2000 must be installed new. Please contact
Microsoft how to change the Windows 2000-HAL,
because this can make your installation unusable.

PCMCIA cards under Windows 95/98/ME and NT

1. Windows 95/98/ME recognize automatically the card
if the PCMCIA functionality is activated. The PC has to
be restarted for each insert and remove of the card for
the CIF Device Driver to recognize the card.

2. In Windows NT, PCMCIA boards needs a special
configuration. The PCMCIA services of Windows NT
have to be activated. Therefore change to the Control
Panel and open Devices. The device PCMCIA must
have the state Started and the startup must have the
state Boot. If not change the startup to Boot.

3. Activate in Windows NT the PCMCIA support of the
CIF Device Driver. Start the program CIF Device Driver
Setup of the program group CIF Device Driver. Select
the menu PCMCIA > Setup and check the Activate
PCMCIA support box.



Die voreingestellte Dual-Port-Memory-Adresse (D4000)
muss nur bei Geratekonflikten geandert werden.

4. Setzen Sie alle Einstellungen flr nicht installierte
ISA-Karten (Board 0 ... 3) auf 00000 bzw. NONE.

5. Starten Sie nach der Konfiguration Ihren PC neu. Bei
jedem Hinzufligen und Entfernen von CIF-Karten muss
der Rechner neu gestartet werden, damit der CIF
Device Driver dies erkennen kann.

6. Wahrend des Systemstarts werden die Konfigurati-
onsdaten vom CIF Device Driver ermittelt und vom Pro-
gramm CIF Device Driver Setup angezeigt. Der Trei-
ber verteilt die Board-Nummern der PCMCIA-Karten
automatisch. Hierzu werden nur freie (unbenutzte)
Board-Nummern verwendet, wobei diese aufsteigend
von 0 bis 3 auf die PCMCIA-Karten verteilt werden.
Sind alle Board-Nummern belegt, werden keine weite-
ren PCMCIA-Karten vom Treiber akzeptiert.

HINWEIS: Deinstallieren Sie vorhandene ,Card Wizard*

Programme.

Weitere Hinweise finden Sie auf der CD in
\FAQ\DEUTSCH\PCMCIA\pcmcia_d.pdf.
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The pre defined Dual-Port Memory address (D4000)
should only be changed if configuration conflicts occur.

4. Set all entries for not installed ISA cards
(Board 0 ... 3) to 00000 respectively NONE.

5. Restart your PC after configuration. The PC has to be
restarted for each insert and remove of the CIF cards
for the CIF Device Driver to recognize the card.

6. During the start of the system all configuration data
will be determined by the CIF Device Driver und will be
shown by the CIF Device Driver Setup program. Also
the board number for PCMCIA cards will be automati-
cally assigned by the driver. Therefore, the driver uses
only free (unused) board numbers in rising order from 0
to 3. If all board numbers are in use then the driver
does not accept additional any PCMCIA cards.

NOTE: Deinstall existing Card Wizard programs.

You find more information on the CD in
\FAQ\ENGLISH\PCMCIA\pcmcia_e.pdf.



Aufrufen des
CIF Device Driver

Using the
CIF Device Driver

Von eigenen Windows-Applikationen kénnen Sie den CIF
Device Driver benutzen, um auf das Prozessabbild bzw.

die Mailbox im Dual-Port Memory des CIFs zuzugreifen.

Das Manual DEVDRV.PDF beschreibt alle Funktionen
des CIF Device Driver und gilt fiir alle Feldbussysteme.
Die protokollspezifischen Befehle und Datenstrukturen
sind jeweils in einem eigenen Manual beschrieben,
siehe hierzu nachfolgende Tabelle.

Wenn Sie einen eigenen Treiber schreiben mochten,
unter MS/DOS oder einem anderen Betriebssystem
arbeiten, bieten wir das Toolkit CIF-TKIT mit C-Quell-
code, Beispielprogrammen und einer genauen
Definition des Dual-Port Memory an.

Feldbus/Protokoll / Fieldbus/Protocol

From own Windows application you can use the CIF
Device Driver to get access on the process image
respectively the mailbox in the Dual-Port Memory of the
CIF.

The manual DEVDRV.PDF describes all functions of the
CIF Device Driver and is valid for all fieldbus systems.
The protocol specific commands and data structures
are described presently in own manuals, please refer to
the following table.

If you wish to write your own driver or you are working
with MS/DOS or an other operating system, we offer the
tool kit CIF-TKIT with C-Source code, example program
and the exact definition of the Dual-Port Memory.

Manual

PROFIBUS-FMS Master FMS_PIE.PDF

PROFIBUS-DP Slave DPS_PIE.PDF

InterBus Slave IBS_PIE.PDF

CANopen Master COM_PIE.PDF

DeviceNet Master DNM_PIE.PDF

ControlNet Master (Scanner) CNM_PIE.PDF

ASCII, 3964R, RK512, Modbus RTU, Modbus Plus,
Modnet 1/N, Modnet 1/SFB

STD_PIE.PDF
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Konfiguration des
DeviceNet-Netzwerks

Configuration of the
DeviceNet Network

DeviceNet-Master:

Mit dem Systemkonfigurator legen Sie mit Datei > Neu
> DeviceNet das Bussystem fest und wahlen mit
Einfiigen > Master den verwendeten Master aus und
weisen Sie diesem eine MAC-ID zu.

Flgen Sie mit Einfligen > Gerat die am DeviceNet-
Netzwerk verwendeten Slaves in die Konfiguration ein
und vergeben die MAC-IDs.

Machen Sie einen Doppelklick auf die Slave-Icons und
konfigurieren Sie die einzelnen Gerate mit ihrer E/A-
Datenlange. Die Adressen im Prozessabbild werden bei
Autoadressierung vom SyCon vergeben, andernfalls
missen Sie diese manuell eingeben.

Stellen Sie die Baudrate in Einstellungen > Buspara-
meter ein. Stellen Sie mit Einstellungen > Geratezu-
ordnung ein, Uber welchen Treiber der Systemkonfigu-
rator mit dem CIF kommunizieren kann.

Speichern Sie die Konfiguration zunéachst auf dem PC
mit dem Menl Datei > Speichern und Ubertragen Sie
diese anschlieRend auf das Interface mit Online >
Download.

Uberpriifen Sie die Kommunikation mit Online >
Debugmodus starten. Alle Linien zu den Slave-Gera-
ten missen griin dargestellt werden. Wenn nicht,
machen Sie einen Doppelklick auf die Gerate mit roten
Linien und Uberpriifen Sie zunachst die Diagnosebits im
Diagnosefenster. Sie zeigen Fehler grundsatzlicher
Natur, wie zum Beispiel Keine Antwort. Zusatzlich lie-
fert das Diagnosefenster detaillierte Fehlerinformatio-
nen im Klartext, wenn das Gerat im Netzwerk gefunden
werden konnte, aber dennoch ein prinzipieller Fehler
vorliegt, der den Betrieb nicht zuldsst. Zum Beispiel,
wenn die konfigurierte E/A-Datenlange nicht mit der
reellen Datenléange Ubereinstimmt.
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DeviceNet Master:

In the System Configurator select the bus system with
File > New > DeviceNet. Select the used Master with
Insert > Master and assign its MAC-ID.

Insert the Slaves used at the DeviceNet network into
the configuration with Insert > Device and assign their
MAC-IDs.

Double click on the slaves icons and configure the
different devices with their I/0 data length.

The addresses in the process image are automatically
assigned by SyCon if Autoaddressing is on, otherwise
the addresses must be entered manually.

Set the baudrate in Settings > Busparameter.

Also assign in Settings > Device Assignment via
which driver the System Configurator will communicate
to the CIF.

Save the configuration at the PC with the menu item
File > Save and afterwards transfer it to the interface
with Online > Download.

Check the communication with Online > Start
Debugmode. All lines to the slave devices must be dis-
played in green color. If not, double click the red colored
ones and check the diagnostic bits in the diagnostic
window. These bits indicate basic communication
errors, like No response. Futhermore you will find
some detailed error information in the window, if the
slave could be found in the network, but principle errors
prohibit the process data exchange. For example if the
configured I/0 length does not match to the real I/O
length of the device.



Alternativ kann das DeviceNet-Netzwerk auch eingele-
sen werden. Dazu fligen Sie in eine leere Konfiguration
mit Einfligen > Master den verwendeten Master ein
und weisen diesem eine MAC-ID zu.

Stellen Sie mit Einstellungen > Gerétezuordnung ein,
Uiber welchen Treiber der Systemkonfigurator mit dem
CIF kommunizieren kann. Ubertragen sie die Konfigura-
tion auf das Interface mit Online > Download. Danach
kann die DeviceNet-Netzwerkstruktur mit Online >
Netzwerkstruktur einlesen eingelesen werden.

Die eingelesene Netzwerkstruktur in die Konfiguration
Uibernehmen und mit Datei > Speichern die Konfigura-
tion zunachst auf dem PC speichern. Ubertragen sie
diese anschlieRend auf das Interface mit Online >
Download.

DeviceNet-Slave:

Mit dem Systemkonfigurator legen Sie mit Datei > Neu
> DeviceNet das Bussystem fest und wahlen mit
Einfligen > Master irgendeinen Master aus.

Flgen Sie mit Einfligen > Gerat den verwendeten
Slave in die Konfiguration ein und weisen diesem eine
MAC-ID zu.

Machen Sie einen Doppelklick auf den Slave und konfi-
gurieren Sie die E/A-Datenlénge.

Stellen Sie mit Einstellungen > Gerétezuordnung ein,
Uiber welchen Treiber der Systemkonfigurator mit dem
CIF kommuniziert.

Speichern Sie die Konfiguration zunéachst auf dem PC
mit Datei > Speichern und Ubertragen sie diese
anschlieRend auf das Interface mit Online >
Download.
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Alternatively the DeviceNet network can also be scan-
ned. Therefore insert the used Master in an empty con-
figuration with Insert > Master and assign its MAC-ID.

With Settings > Device Assignment set via which
driver the System Configurator can communicate with
the CIF. Transfer the configuration to the interface with
Online > Download. After that the DeviceNet network
structure can be scanned with Online > Automatic
Network Scan.

Take over this network structure into the configuration
and with File > Save store it on the PC. Afterwards
transfer the configuration into the interface with Online
> Download.

DeviceNet Slave:

In the System Configurator select the bus system with
File > New > DeviceNet. Select any Master with Insert
> Master.

Insert the used Slave into the configuration with Insert
> Device and assign its MAC-ID.

Double click on the slave and configure the I/O data
length.

Assign with Settings > Device Assignment via which
driver the system configurator will communicate with the
CIF.

First save the configuration on the PC with File > Save
and afterwards transfer it into the interface via Online >
Download.



Fehlersuche

Troubleshooting

Dual-Port Memory

Prifen Sie, dass der von dem CIF benutzte Speicher-

bereich im BIOS auf Shadow RAM disable einge-

stellt ist.

Priifen Sie, ob die Adresseinstellung der ISA- und

PC/104-Karten mit der Einstellung im CIF Device

Driver Setup Ubereinstimmt.

Prifen Sie, dass die eingestellte Dual-Port-Memory-

GroRe im CIF Device Driver Setup der tatséchlichen

GroRe entspricht.

Prifen Sie, dass kein Adresskonflikt mit anderen PC-

Komponenten (z. B. SCSI-Controller) vorliegt.

— Weitere Hinweise finden Sie auf der CD in
\FAQ\DEUTSCH\ISA\ bzw. PCI bzw. PCMCIA.

Kabel

— Prifen Sie, dass die Pinbelegung des verwendeten
Kabels richtig ist.

— Prifen Sie, dass die Busterminierungswiderstéande
am Anfang und am Ende der Leitung vorhanden sind.
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Dual-port Memory

— Check if the memory area used by the CIF is set to
Shadow RAM disable in the BIOS.

Check if the address setting on an ISA- and PC/104
cards matchs with the setting in the CIF Device
Driver Setup.

Check that the Dual-Port Memory size in the CIF
Device Driver Setup is the same as the real size.
Check that there is no address conflict with another
PC component (e.g. SCSI controller).

More information are on the CD in
\FAQ\ENGLISH\ISA\ or PCI or PCMCIA.

Cable

— Check that the pin occupation of the used cable is
correct.

— Make sure that the bus termination resistors are
present at the beginning and the end of the cable.



Diagnose mit dem Systemkonfigurator beim
DeviceNet-Master

Priifen Sie mit Online > Live List, welche Statio-
nen/Gerate am Bus vorhanden sind.

Priifen Sie mit Online > Debugmode starten, zu
welchen Geraten ein Nutzdatenaustausch stattfindet
(griin dargestellte Linien zum Slave-Gerat).

Zeigen Sie mit Online > Geratediagnose die
Diagnoseinformation des Slaves-Gerates an.
Benutzen Sie das Men( Online > E/A-Monitor, um
die Ein- und Ausgangsbytes zu priifen.

Prifen Sie mit Online > Erweiterte Geratediagnose
> DNM_Task Common Variables, ob der Zahler fiir
Hard Transmission Aborts hochzahlt, was
grundsatzliche Verdrahtungsfehler oder eine falsch
eingestellte Baudrate anzeigt.

Priifen Sie mit Online > Erweiterte Geratediagnose
> DNM_Task Common Variables bei received und
sent messages, ob der Master Telegramme emp-
fangt und sendet.

Diagnose mit dem Systemkonfigurator beim
DeviceNet-Slave

— Prifen Sie mit Online > Erweiterte Geratediagnose
> DNS_Task Common Variables bei received und
sent messages, ob der Slave Telegramme empfangt
und sendet.

Prifen Sie mit Online > Erweiterte Geratediagnose
> DNS_Task Common Variables, ob der Zahler fir
Hard Transmission Aborts hochzahlt, was
grundsatzliche Verdrahtungsfehler oder eine falsch
eingestellte Baudrate anzeigt.

Benutzen Sie das Menii Online > E/A-Monitor um
die Ein- und Ausgangsbytes des Prozessabbildes zu
prifen.
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Diagnostic using the System Configurator at
DeviceNet Master

Check which stations are present on the bus using
Online > Live List.

Check to which devices a process data exchange is
executed (green colored lines to the icon) by using
Online > Start Debug Mode.

Display the diagnostic information of a Slave device
using Online > Device Diagnostic.

Use the menu Online > 10-Monitor to check the
input and output data.

Check with the menu Online > Extended Device
Diagnostic > DNM_Task Common Variables if the
counter for Hard Transmission Aborts counts up
which indicates basic wirering faults or wrong
configured baud rate.

Check with the menu Online > Extended Device
Diagnostic > DNM_Task Common Variables at
received and sent messages, if the Master receives
and sends telegrams.

Diagnostic using the System Configurator at
DeviceNet Slave

— Check with the menu Online > Extended Device
Diagnostic > DNS_Task Common Variables at
received and sent messages, if the Slave receives
and sends telegrams.

Check with the menu Online > Extended Device
Diagnostic > DNS_Task Common Variables if the
counter for Hard Transmission Aborts counts up
which indicates basic wirering faults or wrong
configured baud rate.

Use the menu Online > 10-Monitor to check the
input and output data of the process data image.



LED-Anzeigen Master

LED Displays Master

LED

RDY

gelb/
yellow

RUN
grin/
green

S ® O ® O 0e

MOD
griin /

green

S 00 ®

O

(*) 3-mal schnell mit 5 Hz, 8-mal zwischen 0,5 Hz und

1 Hz.

Zustand / State

Ein/On

Blinkt zyklisch mit 5 Hz /
Flashing cyclic at 5 Hz

Blinkt zyklisch mit 1 Hz /
Flashing cyclic at 1 Hz

Blinkt unregelmaRig (*) /
Flashing irregular (*)
Aus / Off

Ein/On

Blinkt zyklisch mit 5 Hz /
Flashing cyclic at 5 Hz

Blinkt unregelmaRig (*) /
Flashing irregular (*)

Aus / Off
Ein griin / On green

Blinkt griin /
Flashing green

Aus / Off

Bedeutung / Meaning

Gerat ist bereit / Device is ready

Firmware-Download wird durchgefiihrt /
Firmware download is in progress

Gerat ist in Bootstraploadermodus und wartet auf Firmware-Download /
Device is in bootloader mode and is waiting for firmware download

Hardware- oder schwerer Systemfehler erkannt /
Hardware or heavy runtime error detected

Versorgungsspannung fiir das Gerat fehlt oder Hardwaredefekt /
Device has no power supply or hardware defect

Kommunikation lauft, das Gerat hat mindestens eine Verbindung
aufgebaut / communication is running, the device has established at least
one configured |0 connection

Kein Fehler in der Konfiguration, Kommunikation gestoppt (NET-LED
aus bzw. MNS-LED griin an) oder bereit fiir Kommunikation, aber keine
Verbindung zu einem Slave (NET-LED bzw. MNS-LED rot blinkend) /

No error in configuration found, communication is stopped (NET-LED off
respectively MNS-LED green on) or ready for communication but no
connection to any Slave (NET-LED respectively MNS-LED red flashing)
Anlauf: Fehlende oder fehlerhafte Konfiguration, Inbetriebnahme nétig,
Laufzeit: Host-Watchdog-Zeitfehler / Power Up: Configuration missing or
faulty, device needs commissioning, Runtime: Host Watchdog timeout
Keine Kommunikation / No Communication

Gerat hat eine giiltige Konfiguration, Gerat arbeitet /
Device has found a valid configuration, device is operating

Gerat erwartet Inbetriebnahme aufgrund fehlender oder fehlerhafter
Konfiguration / The device expects commissioning due to missing,
incomplete or incorrect configuration

Versorgungsspannung fiir das Gerat fehlt / Device has no power supply

(*) 3times fast at 5 Hz, 8 times between 0.5 Hz and
1 Hz.
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MNS @ |Ein griin / On green Geréat ist online und hat eine oder mehrere Verbindungen aufgebaut /
griin/ Device is online and has one or more connections in established state
green @) |Blinkt griin / Gerat ist online und hat keine Verbindung aufgebaut /
Flashing green Device is online and has no connection in the established state
rot / red ‘ Ein rot / On red Kritischer Verbindungsfehler; Gerat hat einen Netzwerkfehler erkannt
(doppelte MAC-ID oder Bus off) / Critical link failure; Device has detected
a network error (duplicate MAC-ID or bus off)
@) |Blinkt rot / Flashing red Verbindungsiiberwachungszeit abgelaufen /
Connection timeout
@) |Blinkt rot und griin / Kommunikation fehlgeschlagen /
Flashing red and green Communicaton faulted
O |Aus / Off Nach Start des Geréates und wahrend der Priifung auf doppelte MAC-ID /
after start of the device and during duplicate MAC-ID check
Hinweis: Die MNS-LED ist eine Kombination aus der Note: The MNS LED is a combination of the MOD LED
MOD-LED und der NET-LED. Die MNS-LED ist bei dem and the NET LED. The MNS LED exists on the CIF 60
CIF 60 und CIF 80 vorhanden. and CIF 80.
Die HS-LED ist ausschlieRlich auf dem CIF 80 vorhan- The HS LED exists exclusively on the CIF 80.

den.
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LED-Anzeigen Slave

LED Displays Slave

LED

RDY

gelb/
yellow

RUN
grin/

green

MOD
grin/

green

NET
grun/

green

8 80 S 60 ® 0 @ O ® O 0o

rot / red .

(*) 3-mal schnell mit 5 Hz, 8-mal zwischen 0,5 Hz und

1Hz.

()
O

Zustand / State

Ein/On

Blinkt zyklisch mit 5 Hz /
Flashing cyclic at 5 Hz

Blinkt zyklisch mit 1 Hz /
Flashing cyclic at 1 Hz

Blinkt unregelmagig (*) /
Flashing irregular (*)

Aus / Off
Ein/On

Blinkt zyklisch mit 5 Hz /
Flashing cyclic at 5 Hz

Blinkt unregelmaRig (*) /
Flashing irregular (*)
Aus / Off

Ein/ On

Blinkt / Flashing
Aus / Off
Ein griin / On green

Blinkt griin /
Flashing green

Ein rot/ On red

Blinkt rot / Flashing red
Aus / Off

Bedeutung / Meaning

Gerét ist bereit / Device is ready

Firmware-Download wird durchgefiihrt /

Firmware download is in progress

Gerat ist in Bootstraploadermodus und wartet auf Firmware-Download/
Device is in bootloader mode and is waiting for firmware download
Hardware- oder schwerer Systemfehler erkannt /

Hardware or heavy runtime error detected

Versorgungsspannung flir das Gerat fehlt oder Hardwaredefekt /
Device has no power supply or hardware defect

Kommunikation lauft, das Gerat hat eine Verbindung aufgebaut /
Communication is running, the device has established one connection
Kein Fehler in der Konfiguration, bereit flir Kommunikation, aber keine
Verbindung aufgebaut / No error in configuration found, ready for
communication but no established connection

Fehlende oder fehlerhafte Konfiguration, Inbetriebnahme nétig /
Configuration missing or faulty, device needs commissioning

Keine Kommunikation / No Communication

Gerat hat eine giiltige Konfiguration, Gerat arbeitet /

Device has found a valid configuration, device is operating

Gerat erwartet Inbetriebnahme aufgrund fehlender oder fehlerhafter
Konfiguration / The device needs commissioning due to configuration
missing, incomplete or incorrect

Versorgungsspannung fiir das Gerat fehlt / Device has no power supply

Gerat (Slave) ist online und hat eine Verbindung aufgebaut /
Device is online and has a connection in established state
Gerat (Slave) ist online und hat keine Verbindung aufgebaut, Gerat wartet
auf den Master fiir einen Verbindungsaufbau /
Device is online and has no connection in the established state, Device
waits for the master to built up a connection
Kritischer Verbindungsfehler; Gerat hat einen Netzwerkfehler erkannt
(doppelte MAC-ID oder Bus off) / Critical link failure; Device has detected
a network error (duplicate MAC-ID or bus off)
Verbindungstiberwachungszeit abgelaufen / Connection timeout
Nach dem Geréatestart und wahrend der Priifung auf doppelte MAC-ID /
After start of the device and during duplicate MAC-ID check
(*) 3times fast at 5 Hz, 8 times between 0.5 Hz and

1 Hz.
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MNS @
grin/

Ein griin / On green

Gerat (Slave) ist online und hat eine Verbindung aufgebaut /
Device is online and has a connection in established state

green @) | Blinkt griin / Gerat (Slave) ist online und hat keine Verbindung aufgebaut, Geréat wartet
Flashing green auf den Master fiir einen Verbindungsaufbau / Device is online and has no
connection in the established state
rot/ red @ | Ein rot/ On red Kritischer Verbindungsfehler. Gerat hat einen Netzwerkfehler erkannt
(doppelte MAC-ID oder Bus off) / Critical link failure; Device has detected
a network error (duplicate MAC-ID or bus off)
Critical link failure, critical fault
@) | Blinkt rot / Flashing red Verbindungsiiberwachungszeit abgelaufen / Connection timeout
@) | Blinkt rot und griin / Kommunikation fehlgeschlagen /
Flashing red and green Communication faulted
O |Aus 1 off Nach Start des Geréates und wahrend der Priifung auf doppelte MAC-ID /
After start of the device and during duplicate MAC-ID check
Hinweis: Die MNS-LED ist eine Kombination aus der Note: The MNS LED is a combination of the MOD LED
MOD-LED und der NET-LED. Die MNS-LED ist bei and the NET LED. The MNS LED exists on the CIF 60
dem CIF 60 und CIF 80 vorhanden. and CIF 80.
Die HS-LED ist ausschlieflich auf dem CIF 80 The HS LED exists exclusively on the CIF 80.

vorhanden.
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Technische Daten Technical Data
CIF 30 /50 (*) / 60/ 104: CIF 30/50(*)/60/

DeviceNet-Master

DeviceNet-Slave

Prozessor / Processor
Speicher

ASIC

DeviceNet-Schnittstelle
DeviceNet Interface
Diagnoseschnittstelle

Diagnostic Interface
Betriebsspannung / Power Supply

Betriebstemp. / Operating Temp.
MaRe (L x B x H)
Dimensions (L x W x H)

Hinweis (*): Die hier angegebenen technischen Daten Note (*): The technical data of the CIF 50-DNM and
des CIF 50-DNM bzw. CIF 50-DNS beziehen sich auf respectively CIF 50-DNS indicated here refer to revision
Revision 1 der Gerate. Angaben zum CIF 50-DNM bzw. 1 of this devices. Data about the CIF 50-DNM and

CIF 50-DNS ab Revision 2 finden Sie auf der nachsten respectively CIF 50-DNS starting from revision 2 are
Seite beschrieben. described on the next page.




Technische Daten

CIF 50 (**) / 80/ 104P /| PMC:

DeviceNet-Master

DeviceNet-Slave

Process Image
Prozessor / Processor
Speicher / Memo,

DeviceNet-Schnittstelle
DeviceNet Interface
Diagnoseschnittstelle
Diagnostic Interface
Betriebsspannung
Power Supply

Betriebstemp. / Operating Temp.
MaRe (L x B x H)
Dimensions (L x W x H)

Hinweis (**): Die hier angegebenen technischen Daten
des CIF 50-DNM bzw. CIF 50-DNS beziehen sich auf
Geréate ab Revision 2. Angaben zum CIF 50-DNM bzw.
CIF 50-DNS mit Revision 1 finden Sie auf der
vorhergehenden Seite beschrieben.

Tech
CIF 50 (**) / 80/ 104P / PMC:

al Data

Note (**): The technical data of the CIF 50-DNM and
respectively CIF 50-DNS indicated here refer to revision
2 of this devices. Data about the CIF 50-DNM and

CIF 50-DNS revision 1, can be found on the preceding
page.




Reserviert Reserved
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Haftungsausschluss

Der Inhalt dieses Manuals wurde auf Ubereinstimmung
mit der beschriebenen Hard- und Software gepriift.
Dennoch kénnen Abweichungen nicht ausgeschlossen
werden, sodass wir fiir die vollstandige Ubereinstim-
mung keine Gewahr ibernehmen. Die Angaben in die-
sem Manual werden jedoch regelmaRig tiberpriift. Not-
wendige Korrekturen sind in den nachfolgenden
Auflagen enthalten. Fir Verbesserungsvorschlage sind
wir dankbar.

42

Exemption from Liability

The contents of this manual were checked for agreement
with the described hardware and software. However,
deviations may occur so that no guarantee can be made
for complete agreement with the documentation.
However, the information in this manual is controlled
regularly. Necessary corrections are contained in the
following editions. We are grateful for improvement sug-
gestions.



Headquarters

Subsidiaries

Germany

Hilscher Gesellschaft fiir
Systemautomation mbH
Rheinstrasse 15

65795 Hattersheim

Phone: +49 (0) 6190 9907-0
Fax: +49 (0) 6190 9907-50
E-Mail: info@hilscher.com
Web:  www.hilscher.com

World-wide: Distributors
Please visit our homepage on
www.hilscher.com
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France

Hilscher France S.a.r.l.
12, rue du 35 iéme Régiment d’Aviation
Miniparc du Chéne

69500 Bron

Phone: +33 (0) 4 72 37 98 40
Fax: +33 (0) 4 78 26 83 27
E-Mail: info@hilscher.fr
Web:  www.hilscher.com
Italy

Hilscher Italia srl
Via Grandi, 25
20090 Vimodrone (MI)

Phone:
Fax:

+39 02 25007068
+39 02 25029973

E-Mail: info@hilscher.it
Web:  www.hilscher.com
Switzerland

Hilscher Swiss GmbH
Hubelmattstrasse 29
4500 Solothurn

Phone:

+41 (0) 32 623 6633

Fax: +41 (0) 32 623 6632
E-Mail: info@hilscher.ch
Web:  www.hilscher.com
USA

Hilscher North America, Inc.
Suite 100

2443 Warrenville Road
Lisle, IL 60532

Phone: +1 630-505-5301
Fax: +1 630-505-7532
E-Mail: info@hilscher.us
Web:  www.hilscher.com



DeviceNet

Bei weiteren Fragen wenden Sie sich
bitte an eine unserer Geschéaftsstellen,
lhren lokalen Distributor

oder an unseren technischen Support:

If you have any question
please contact our subsidiaries,

your local distributor

or our technical support:

~

y 4
hll@@[ﬁ]@ﬂ? Phone: +49 (0) 6190 9907-99

COMPETENCE IN . . )
CONMMUNICATION E-Mail: hotline@hilscher.com
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