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Kurzbeschreibung
Diese CD beinhaltet

• die ladbare Firmware*
• den Systemkonfigurator SyCon**
• den OPC-Server**
• den CIF Device Driver
• die Treiber für SoftSPS-Einheiten**
• die EDS-Dateien
• die Dokumentation

für unsere Communication InterFaces CIF.

Das Communication Interface führt den gesamten
Datenaustausch zwischen den angeschlossenen
Feldbusteilnehmern und dem PC durch. Dabei werden
die Daten als Prozessabbild im Dual-Port-Memory des
CIFs zur Verfügung gestellt. 
Bei nachrichtenorientiertem Datenaustausch erfolgt 
dieser über eine Mailbox im Dual-Port-Memory.
Die PC-Applikation greift über den CIF Device Driver
oder einen speziellen SoftSPS-Treiber auf das Prozess-
abbild oder auf die Mailbox zu.
Die Konfiguration und Inbetriebnahme erfolgt durch den
Systemkonfigurator SyCon. Dieser kommuniziert mit dem
CIF über den CIF Device Driver oder über TCP/IP zu einem
Remote-PC oder über eine serielle Verbindung zwischen
dem COM-Port des PCs und der Diagnoseschnittstelle
des CIFs. Die Konfiguration wird auf dem CIF gespeichert,
sodass das CIF beim Starten sofort betriebsbereit ist.
* Falls es eine neue Firmware-Version gibt, können Sie
diese von unserer Homepage herunterladen.

** Zum Betrieb des Systemkonfigurators, des OPC-Ser-
vers oder des SoftSPS-Treibers benötigen Sie einen
Lizenzcode. Wenn dieser im Lieferumfang mit enthal-
ten ist, finden Sie ihn für den Systemkonfigurator als
Label auf dieser CD oder in einem Briefumschlag ein
Lizenzcode-Anforderungsformular. Für den OPC-Ser-
ver oder den SoftSPS-Treiber finden Sie den Lizenz-
code auf der Karte. Andernfalls wenden Sie sich bitte
an Ihren Distributor oder direkt an uns.

Short Description
This CD contains

• loadable Firmware*
• System Configurator SyCon**
• OPC Server**
• CIF Device Driver
• Driver for SoftPLC units**
• EDS files
• Documentation

for our Communication InterFaces CIF.

The Communication Interface handles the complete
data exchange between the connected fieldbus devices
and the PC. The data are available as process image in
the dual-port memory of the CIF. The message oriented
data exchange is handled via a mailbox in the dual-port
memory.

The PC application has access to the process image or
the mailbox via the CIF Device Driver or via a special
SoftPLC driver.
The configuration and set up is proceeded by the
System Configurator SyCon. It communicates with the
CIF via the CIF Device Driver or via TCP/IP to a remote
PC or via a serial connection between the COM port of
the PC and the diagnostic interface of the CIF. The con-
figuration is stored on the CIF, therefore the CIF is
immediately ready after the start.
* If there is a new firmware version available you can
download it from our homepage.

** A license code is required to use the System Con-
figurator, the OPC Server or the SoftPLC driver. If this
is included in the scope of delivery you will find it for
the System Configurator on a label on this CD or in
an envelope a license code request form. For the OPC
Server or the SoftPLC driver you will find the license
code on the card. Otherwise please contact your dis-
tributor or us directly.
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Verzeichnisstruktur der CD
Sie erhalten auf dieser CD alle Dokumentationen im
Adobe®-Acrobat®-Reader-Format (PDF). Im Verzeich-
nis ACROREAD ist eine Runtime-Version enthalten.

Directory Structure of the CD
All manuals on this CD are delivered in the Adobe®

Acrobat® Reader format (PDF). A runtime version of
this reader can be found in the ACROREAD directory.

Installation des Acrobat Reader, 
in Deutsch und Englisch für verschiedene 
Windows-Versionen

Installation of Acrobat Reader, 
in German or English language for different
Windows versions

Installation des CIF Device Driver
Installation of the CIF Device Driver

Manuals, Headers, Sample 
zur Treiberprogrammierung
for the driver programming

Häufig gestellte Fragen
Frequently asked questions

Dokumentation zum SyCon und
den Protokollen im Acrobat-Reader-Format
Documentation of SyCon and the protocols in
Acrobat Reader format

Installation des SyCon
Installation of SyCon
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Systemvoraussetzungen
• PC mit 486-, Pentium-Prozessor oder höher
• Windows® 98/Windows® ME, 
Windows® NT 4.0/Windows® 2000/Windows® XP
• Freier Festplattenspeicher: 30–80 MByte
• CD-ROM-Laufwerk
• RAM: mind. 16 MByte
• Grafikauflösung: mind. 800 x 600 Bildpunkte
• Windows® NT: Service Pack 6 oder höher
• COM/DCOM für den OPC-Server
• Tastatur und Maus

Installation des CIFs
Stellen Sie sicher, dass die konfigurierten Speicherbereiche
und Interrupte nicht von anderen Geräten belegt sind. 

Um solche Fehler zu erkennen und zu verhindern,
wählen Sie unter:

System Requirements
• PC with 486-, Pentium processor or higher
• Windows® 98/Windows® ME, 
Windows® NT 4.0/Windows® 2000/Windows® X
• Free disk space: 30–80 MByte
• CD ROM Drive
• RAM: min. 16 MByte
• Graphic resolution: min. 800 x 600 pixel
• Windows® NT: Service Pack 6 or higher
• COM/DCOM only for OPC Server
• Keyboard and Mouse

Installation of the CIF
Make sure that the configured memory areas and inter-
rupts are not used by another PC component. 

In order to identify and prevent such errors, select in:

Windows® Pfad / Path

2000/XP Start > Einstellungen > Systemsteuerung, Verwaltung > Computerverwaltung, System > 

Gerätemanager

Start > Settings > Control Panel, Administrative Tools > Computer Management, System >

Device Manager

NT Start > Programme > Verwaltung > Windows-NT-Diagnose > Ressourcen

Start > Programs > Administrative Tools > Windows NT Diagnostics > Resources

98/ME Start > Einstellungen > Systemsteuerung, System > Gerätemanager

Start > Settings > Control Panel, System > Device Manager
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Gerät einbauen:

Stromschlaggefahr
• Betriebsspannung des PCs und aller
angeschlossenen Geräte ausschalten.

• Erst danach das PC-Gehäuse öffnen.

ACHTUNG! Beschädigung durch 
elektrostatische Entladung
• Um eine Beschädigung 

des PCs und des CIFs 
zu vermeiden, entladen Sie sich.

ISA- und PC/104-Karten

1. Konfigurieren Sie die Startadresse des CIFs gemäß
den nachstehenden Abbildungen. Beachten Sie, dass
das CIF einen freien Speicherbereich von 2 bzw.
8 KByte zwischen 0xA0000 und 0xFFFFF benötigt.

2. Falls Sie im Interruptbetrieb arbeiten, stellen Sie
einen freien Interrupt auf dem CIF ein.

3. Schalten Sie zuerst die Betriebsspannung Ihres PCs
und aller angeschlossenen Geräte aus.

4. Öffnen Sie das Gehäuse des PCs und stecken Sie
das CIF auf einen freien ISA-Steckplatz. Der CIF 
Device Driver unterstützt bis zu vier CIFs pro PC. 
Befestigen Sie das CIF an der vorgesehenen Bohrung.

5. Schließen Sie das PC-Gehäuse wieder und schalten
Sie die Betriebsspannung des PCs ein.

Installing Device:

Electrocution
• Switch off the power of the PC and of all
connected devices.

• Only after it open the PC cabinet.

NOTICE! Damage from 
electrostatic discharge
• To prevent damage

to the PC and the CIF,
discharge yourself.

ISA and PC/104 cards

1. Configure the start address of the CIF according the
following description. Please note that a free memory
area of 2 KByte respectively 8 KByte between 0xA0000
and 0xFFFFF is necessary.

2. If you are using the interrupt mode you have to set up
a free interrupt on the CIF.

3. First switch off the power of the PC and all connected
devices.

4. Open the cabinet of the PC and plug in the CIF on a
free ISA slot. Up to four CIFs per PC are supported by
the CIF Device Driver. Fix the CIF using the hole 
intended.

5. Close the PC and switch on the power of the PC.

GEFAHR! DANGER!
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PCI-Karten

1. Schalten Sie zuerst die Betriebsspannung Ihres PCs
und aller angeschlossenen Geräte aus.

2. Öffnen Sie das Gehäuse des PCs und stecken Sie
das CIF auf einen freien PCI-Steckplatz. Der CIF 
Device Driver unterstützt bis zu vier CIFs pro PC. 
Befestigen Sie das CIF an der vorgesehenen Bohrung.

3. Schließen Sie das PC-Gehäuse wieder und schalten
Sie die Betriebsspannung des PCs ein.

4a. Windows® 2000*/Windows® XP erkennen das CIF
automatisch und öffnen das Fenster Neue Hardware
gefunden. Das CIF wird als Anderes PCI-Brücken-
gerät erkannt. Der Installationsassistent erwartet eine
Diskette/CD des Hardware-Herstellers. Wechseln Sie
hierzu in das Verzeichnis Driver\Win2000_XP\PCI auf
der CD oder bei bereits installiertem CIF Device Driver
in das Verzeichnis der Treiberhilfsprogramme 
(...\Programme\CIF Device Driver\Win2000_XP\PCI)

4b. Unter Windows® NT* werden PCI-Karten nicht 
automatisch erkannt, sondern müssen manuell über
den CIF Device Driver aktiviert werden. Die Aktivierung
erfolgt mithilfe des Programms CIF Device Driver
Setup im Menü PCI > Setup > Activate PCI support.

4c. Windows® 98*/Windows® ME* erkennen das CIF
automatisch und öffnen das Fenster Neue Hardware-
komponente gefunden. Der Installationsassistent
erwartet eine Diskette/CD des Hardware-Herstellers.
Wechseln Sie hierzu in das Verzeichnis Driver\Win9x\
PCI auf der CD oder bei bereits installiertem CIF Device
Driver in das Verzeichnis der Treiberhilfsprogramme 
(...\Programme\CIF Device Driver\Win9x\PCI).

5. Nach erfolgreicher Installation ist der PC neu zu 
starten.

* Treiber für die Karte CIF 52-COM sind nur für 
Windows® XP erhältlich.

PCI cards

1. First switch off the power of the PC and of all 
connected devices.

2. Open the cabinet of the PC and plug in the CIF on a
free PCI slot. Up to four CIFs per PC are supported by
the CIF Device Driver. Fix the CIF using the hole 
intended.

3. Close the cabinet of the PC and switch on the power
of the PC.

4a. Windows® 2000*/Windows® XP detect the CIF
automatically and will open the window New Hardware
Found. The CIF is detected as an Other Bridge 
Device. The installation assistant asks for a disk/CD
from the hardware manufacturer. For this purpose,
change to the directory Driver\Win2000_XP\PCI on the
CD or if the CIF Device Driver is already installed into
the directory of the driver utilities (...Program Files\CIF
Device Driver\ Win2000_XP\PCI).

4b. Under Windows® NT* the PCI cards are not 
detected automatically, they have to be activated manu-
ally via the CIF Device Driver. The activation is done
with help of the CIF Device Driver Setup program in
the menu PCI > Setup > Activate PCI support.

4c. Windows® 98*/Windows® ME* will detect the CIF
automatically and will open the window New Hardware
Found. The installation assistent asks for a disk/CD
from the hardware manufacturer. For this purpose,
change to the directory Driver\Win9x\PCI on the CD or
if the CIF Device Driver is already installed into the
directory of the driver utilities 
(...\Programs\CIF Device Driver\Win9x\PCI).

5. After a successful installation the PC has to be
rebooted.

* Drivers for the CIF 52-COM card are only available
for  Windows® XP.
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PCMCIA-Karten

1. PCMCIA-Karten können bei einigen Betriebssyste-
men im laufenden PC hinzugefügt oder entfernt wer-
den. Halten Sie die Karte so, dass das Hilscher-Logo
nach oben und der 68-polige Stecker zum Steckplatz
zeigt. Stecken Sie die Karte bis zum Einrasten in den
PCMCIA-Karten-Steckplatz.

2a. Windows® 2000/Windows® XP erkennt das CIF
automatisch und öffnet das Fenster Neue Hardware
gefunden. Das CIF wird als Hilscher_GmbH CIF60_...
erkannt. Der Installationsassistent erwartet eine 
Diskette/CD des Hardware-Herstellers. Wechseln Sie
hierzu in das Verzeichnis Driver\Win2000_XP\PCMCIA
auf der CD oder bei bereits installiertem CIF Device 
Driver in das Verzeichnis der Treiberhilfsprogramme
(...\Programme\CIF Device river\Win2000_XP\
PCMICIA).

2b. Windows® NT ist kein Plug-and-Play-Betriebs-
system. Die PCMCIA-Karte nur bei ausgeschaltetem
PC hinzufügen oder entfernen.

2c. Windows® 98/Windows® ME erkennen das CIF
automatisch und öffnen das Fenster Neue Hard-
warekomponente gefunden. Der Installationsassistent
erwartet eine Diskette/CD des Hardware-Herstellers.
Wechseln Sie hierzu in das Verzeichnis
Driver\Win9x\PCMCIA auf der CD oder bei bereits
installiertem CIF Device Driver in das Verzeichnis der
Treiberhilfsprogramme 
(...\Programme\CIF Device Driver\Win9x\PCMICIA). 

3. Nach erfolgreicher Installation ist der PC neu zu 
starten.

PCMCIA cards

1. Some operating systems support that PCMCIA cards
can be plugged in and removed while the system is
powered on. Hold the card with the Hilscher logo facing
upward and the 68-pin card connector to the card slot.
Insert the card into the PCMCIA card slot and push it in
until it is firmly seated. 

2a. Windows® 2000/Windows® XP detects the CIF
automatically and opens the Windows® New Hardware
found. The CIF will be detected as Hilscher_GmbH
CIF60_... The installation assistant asks for a disk/CD
from the hardware manufacturer. For this purpose,
change to the directory Driver\Win2000_XP\PCMCIA
on the CD or if the CIF Device Driver is already installed
into the directory of the driver utilities 
(...\Program Files\CIF Device Driver\Win2000_XP\
PCMCIA).

2b. Windows® NT is no plug & play operating system.
The PCMCIA card can only be added or removed if the
PC is switched off.

2c. Windows® 98/Windows® ME will detect the CIF
automatically and will open the window New Hardware
Found. The installation assistent asks for a disk from
the hardware manufacturer. For this purpose, change to
the directory Driver\Win9x\PCMCIA on the CD or if the
CIF Device Driver is already installed into the directory
of the driver utilities 
(...\Program Files\CIF Device Driver \Win9x\
PCMCIA).

3. After a successful installation the PC has to be
rebooted.
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X = Steckbrücke gesteckt / Jumper closed Grundeinstellung / Default configuration

Adresse /Address A13 A14 A15 A16 A17 A18 A19

CA000 X X X
CC000 X X X

CE000 X X

D0000 X X X X

D2000 X X X

D4000 X X X

D6000 X X

Typ / Type Karte / Card Dual-Port Memory Funktion / Function
CIF 30-COS ISA 8 KByte CANopen Slave

CIF 30-COM ISA 8 KByte CANopen Master

Gerätezeichnungen Device Drawings

Weitere Beispiele für Jumpereinstellungen finden Sie auf der CD im Verzeichnis CD:/Faq/jumper.pdf.
Further examples for jumper settings are on the CD in the directory CD:/Faq/jumper.pdf.

Interrupt I15 I14 I12 I11 ... I9

Kein / no
15 X

14 X

12 X

11 X

...

9 X
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Typ / Type Karte / Card Dual-Port Memory Funktion / Function
CIF 50-COS PCI 8 KByte CANopen Slave

CIF 50-COM PCI 8 KByte CANopen Master

Die Adresseinstellung erfolgt automatisch durch den
CIF Device Driver und kann mit dem Programm 
CIF Device Driver Setup überprüft werden.

Für die Betriebssysteme Windows® 98/Windows® ME
und Windows® NT ist der CIF Device Driver ab 
Version 3.010 oder höher zu verwenden.

Für die Betriebssysteme Windows® 2000 und
Windows® XP ist der CIF Device Driver Version 3.110
oder höher zu verwenden.

The address setting takes place automatically by the
CIF Device Driver and can be checked with the 
program CIF Device Driver Setup.

For the operating systems Windows® 98/Windows® ME
and Windows® NT you have to use the CIF Device 
Driver version 3.010 or higher.

For the operating systems Windows® 2000 and 
Windows® XP you have to use the CIF Device Driver
version 3.110 or higher.
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Die Adresseinstellung erfolgt automatisch durch den
CIF Device Driver und kann mit dem Programm 
CIF Device Driver Setup überprüft werden.

Für die Betriebssysteme Windows® 98/Windows® ME,
Windows® NT und Windows® 2000 ist kein Treiber vor-
handen.

Für das Betriebssystem Windows® XP ist der CIF 
Device Driver Version 3.120 oder höher zu verwenden.

Das CIF 52-COM belegt im CIF Device Driver zwei
Boards.

The address setting takes place automatically by the
CIF Device Driver and can be checked with the 
program CIF Device Driver Setup.

For the operating systems Windows® 98/
Windows® ME,  Windows® NT and Windows® 2000 no
driver is available.

For the operating system Windows® XP you have to
use the CIF Device Driver version 3.120 or higher.

The CIF 52-COM occupies two boards in the 
CIF Device Driver.

Typ / Type Karte / Card Dual-Port Memory Funktion / Function
CIF 52-COM PCI 8 KByte CANopen Master 

(Rev. 3) (Zwei-Kanal / Two Channel)
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Typ / Type Karte / Card Dual-Port Memory Funktion / Function
CIF 60-COS PCMCIA 8 KByte CANopen Slave

CIF 60-COM PCMCIA 8 KByte CANopen Master

Die Adresseinstellung erfolgt automatisch durch den
CIF Device Driver und kann mit dem Programm 
CIF Device Driver Setup überprüft werden.

The address setting takes place automatically by the
CIF Device Driver and can be checked with the 
program CIF Device Driver Setup.



14

Typ/Type Karte/Card Dual-port memory Funktion/Function
CIF 80-COS Compact PCI 8 KByte CANopen Slave

CIF 80-COM Compact PCI 8 KByte CANopen Master

Typ / Type Karte / Card Dual-Port Memory Funktion / Function
CIF 80-COS Compact PCI 8 KByte CANopen Slave

CIF 80-COM Compact PCI 8 KByte CANopen Master

Die Adresseinstellung erfolgt automatisch durch den
CIF Device Driver und kann mit dem Programm 
CIF Device Driver Setup überprüft werden.

Für die Betriebssysteme Windows® 98/Windows® ME
und Windows® NT ist der CIF Device Driver ab Version
3.010 oder höher zu verwenden.

Für die Betriebssysteme Windows® 2000 und
Windows® XP ist der CIF Device Driver Version 3.110
oder höher zu verwenden.

The address setting takes place automatically by the
CIF Device Driver and can be checked with the 
program CIF Device Driver Setup.

For the operating systems Windows® 98/Windows® ME
and Windows® NT you have to use the CIF Device 
Driver version 3.010 or higher.

For the operating systems Windows® 2000 and 
Windows® XP you have to use the CIF Device Driver
version 3.110 or higher.
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X = Steckbrücke gesteckt / Jumper closed Grundeinstellung / Default configuration

Typ / Type Karte / Card Dual-Port Memory Funktion / Function
CIF 104-COS PC/104 8 KByte CANopen Slave

CIF 104-COS-R PC/104 8 KByte CANopen Slave*

CIF 104-COM PC/104 8 KByte CANopen Master

CIF 104-COM-R PC/104 8 KByte CANopen Master*

* Karten mit Stecker an der rechten Seite nicht abgebildet. / Boards with connector on the right side are not shown.

Adresse /Address A13 A14 A15 A16 A17 A18 A19

CA000 X X X
CC000 X X X

CE000 X X

D0000 X X X X

D2000 X X X

D4000 X X X

Interrupt I15 I14 I12 ... I3

Kein / no
15 X

14 X

12 X

...

3 X

Weitere Beispiele für Jumpereinstellungen finden Sie auf der CD im Verzeichnis CD:/Faq/jumper.pdf.
Further examples for jumper settings are on the CD in the directory CD:/Faq/jumper.pdf.

\P 10-polig gewinkelt

10 pin angled

\S 10-polig gerade

10 pin straight

\H 16-polig gewinkelt

16 pin angled

\V 16-polig gerade

16 pin straight

Option
Pfostenverbinder
anstelle von
DSub-Stecker

Option
Square post
connector instead
of a DSub connector
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Typ / Type Karte / Card Dual-Port Memory Funktion / Function
CIF 104P-COS PC/104+ 8 KByte CANopen Slave

CIF 104P-COM PC/104+ 8 KByte CANopen Master

Der Schalter dient zur Einstellung der physikalischen
Steckplatznummer. Es können max. 4 Module aufeinan-
der gesteckt werden und jede Schaltereinstellung darf
nur einmal verwendet werden. Das Modul, das direkt
am Host-Controller aufgesteckt ist, erhält die CLK 0, die
folgenden Module erhalten die nächsthöhere CLK-Num-
mer.

Die Adresseinstellung erfolgt automatisch durch den
CIF Device Driver und kann mit dem Programm 
CIF Device Driver Setup überprüft werden. Für die
Betriebssysteme Windows® 98/Windows® ME und 
Windows® NT ist der CIF Device Driver ab Version
3.010 oder höher zu verwenden. Für die Betriebs-
systeme Windows® 2000 und Windows® XP ist der CIF
Device Driver Version 3.110 oder höher zu verwenden.

The switch is used for setting the physical slot number.
Max. 4 modules can be plugged on each other. Each
slot setting can be used only one time. The module next
to the host controller gets the CLK 0, the following
modules get the next higher CLK number.

The address setting is proceeded automatically by the
CIF Device Driver and can be checked with the 
program CIF Device Driver Setup. For the operating
systems Windows® 98/ME and NT you have to use the
CIF Device Driver version 3.010 or higher. For the 
operating systems Windows® 2000 and XP you have to
use the CIF Device Driver version 3.110 or higher.

Switch Module No. CLK ID Select INT

Position Slot

0, 4, 8 1 CLK 0 IDSEL 0 INTA

1, 5, 9 2 CLK 1 IDSEL 1 INTB

2, 6 3 CLK 2 IDSEL 2 INTC

3, 7 4 CLK 3 IDSEL 3 INTD

16

\P 10-polig gewinkelt

10 pin angled

\S 10-polig gerade

10 pin straight

\H 16-polig gewinkelt

16 pin angled

\V 16-polig gerade

16 pin straight

Option
Pfostenverbinder
anstelle von
DSub-Stecker

Option
Square post
connector instead
of a DSub connector
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Typ / Type Karte / Card Dual-Port Memory Funktion / Function
PMC-COS PMC 8 KByte CANopen Slave

PMC-COM PMC 8 KByte CANopen Master

Die Adresseinstellung erfolgt automatisch durch den
CIF Device Driver und kann mit dem Programm 
CIF Device Driver Setup überprüft werden.

Für die Betriebssysteme Windows® 98/Windows® ME
und Windows® NT ist der CIF Device Driver ab Version
3.010 oder höher zu verwenden.

Für die Betriebssysteme Windows® 2000 und
Windows® XP ist der CIF Device Driver Version 3.110
oder höher zu verwenden.

The address setting takes place automatically by the
CIF Device Driver and can be checked with the 
program CIF Device Driver Setup.

For the operating systems Windows® 98/Windows® ME
and Windows® NT you have to use the CIF Device 
Driver version 3.010 or higher.

For the operating systems Windows® 2000 and 
Windows® XP you have to use the CIF Device Driver
version 3.110 or higher.
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Anschluss mit / Connection with Signal / Bedeutung /

DSub-Stecker / Pfostenverbinder / Signal Meaning

DSub male connector Square post connector

2 3 CAN_L CAN_L-Busleitung / CAN_L Bus Line

3 5 CAN_GND CAN-Bezugspotential / CAN Ground

7 4 CAN_H CAN_H-Busleitung - / CAN_H Bus Line

CANopen-Schnittstelle
ISO-11898-Schnittstelle, Steckerbelegung gemäß 
CiA DS 102.

CANopen Interface
ISO 11898 interface, connector pinning per CiA DS 102.

Bitte verwenden Sie nur spezielles für CAN zugelasse-
nes Kabel mit folgenden Eigenschaften:

Parameter / Parameter Wert / Value

Wellenwiderstand / Impendance 108…132 Ohm

Kapazitätsbelag / Capacity < 50 pF/m

Please use only special improved CAN cable with the
following characteristics:
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An den Netzwerkenden müssen Abschlusswiderstände
von 120 Ohm angebracht werden. Auf dem CIF 
60-COS / -COM kann über einen Schalter der Busab-
schlusswiderstand aktiviert werden. In diesem Fall
kann der Abschlusswiderstand im Kabel entfallen.

Es ist zulässig Repeater einzusetzen, um die Anzahl
der angeschlossenen Knoten oder die maximale
Kabellänge zu erhöhen.

At the ends of the network there must be two resistors
of 120 Ohm to terminate the cable. The CIF 60-COS / 
-COM have a bus termination resistor on board, which
can be activated with a built-in switch. In that case the
termination resistor of the cable can be eliminated.

It is allowed to use repeaters to increase the number of
nodes, which may be connected, or to increase the
maximum cable length.

Baudrate in kbits/s / Max. Länge in Meter / Schleifenwiderstand / Adernquerschnitt /
Baud rate in kbits/s Max. distance Loop resistance Wire gauge

10 1.000 26 Ohm/km 0,75...0,80 mm2

20 1.000 26 Ohm/km 0,75...0,80 mm2

50 1.000 26 Ohm/km 0,75...0,80 mm2

125 500 40 Ohm/km 0,50...0,60 mm2

250 250 40 Ohm/km 0,50...0,60 mm2

500 100 60 Ohm/km 0,34...0,60 mm2

800 50 60 Ohm/km 0,34...0,60 mm2

1.000 40 70 Ohm/km 0,25...0,34 mm2
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Diagnoseschnittstelle
Nicht auf PCMCIA-Karten und PMC-Modulen

Potentialgebundene RS-232C-Schnittstelle zum An-
schluss an die COM-Schnittstelle des PCs. Die 
Hilscher-Bestellbezeichnung für das Diagnosekabel ist
CAB-SRV.

Diagnostic Interface
Not at PCMCIA cards and PMC modules

Non isolated RS-232C interface to connect with the 
COM port at the PC. The Hilscher part number for the
diagnostic cable is CAB-SRV.

DSub-Stecker Pfostenverbinder Signal / Bedeutung / Eingang/Ausgang
9-polig / 10-polig / 16-polig /
DSub male Square post connector Signal Meaning Input/Output
connector 9 pin 10 pin 16 pin

2 3 7 RXD Empfangsdaten / Receive Data Eingang / Input
3 5 9 TXD Sendedaten / Send Data Ausgang / Output
4 7 11 DTR Datenendeinrichtung betriebsbereit / Ausgang / Output

Data Terminal Ready
5 9 13 GND Betriebserde / Signal Ground -

(6) n.v. / n.c. n.v. / n.c. n.v. / n.c. DSR Betriebsbereitschaft / Eingang / Input
Data Set Ready

7 4 8 RTS Sendeteil einschalten / Ausgang / Output
Ready to Send 

8 6 10 CTS Sendebereitschaft / Clear to Send Eingang / Input
n.v. nicht verbunden / n.c. not connected
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Diagnose CIF52-COM

Potentialgebundene RS-232C-Schnittstelle zum
Anschluss an die COM-Schnittstelle des PCs. Die 
Hilscher-Bestellbezeichnung für das Diagnosekabel ist
CAB-SRV-MD8.

Diagnostic CIF52-COM

Non isolated RS-232C interface to connect with the 
COM port at the PC. The Hilscher part number for the
diagnostic cable is CAB-SRV-MD8.

Anschluss mit Signal / Bedeutung /

Mini-DIN-Buchse 8-polig /

Connection with Mini DIN Signal Meaning

8 pin female connector

1 RXD Empfangsdaten / Receive Data

2 TXD Sendedaten / Send Data

3 GND Betriebserde / Signal Ground

4 DTR Datenendeinrichtung betriebsbereit / Data Terminal Ready

5 RTS Sendeteil einschalten / Ready to Send

8 CTS Sendebereitschaft / Clear to Send
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Installation of the Software
Close all application programs on the system!

Insert the CD in the local CD ROM drive. The installa-
tion program will start by itself (Autostart enabled).
Otherwise change into the root directory on the CD and
start Autorun.exe (Autostart disabled).

NOTE Administrator privileges are required on
Windows® NT/Windows® 2000/Windows® X
systems for installation!

Choose System Installation from the start screen. The
installation program asks for the components to be
installed. Answer these questions with Yes or No.

It will install:

• System Configurator SyCon,
• OPC Server,
• CIF Device Driver.

If a license code is included in the scope of delivery you
will find it for the System Configurator on a label on this
CD or in an envelope a license code request form. In
case you have a license code, answer the question for
an existing license code with Yes, otherwiese a basic
version of the system configurator will be installed.
Enter your name and the company name. 

Installation 
of the SoftPLC Driver
The description of the installation is on the CD in 
\DRIVER\SOFTPLC\. To use the SoftPLC driver a 
license on the CIF is necessary.

Installation der Software
Schließen Sie alle Programme!

Legen Sie die CD in das lokale CD-ROM-Laufwerk. 
Das Installationsprogramm startet selbstständig
(Autostart eingeschaltet). Andernfalls wechseln Sie 
in das Root-Verzeichnis der CD und starten Sie
Autorun.exe (Autostart ausgeschaltet).

HINWEIS Unter Windows® NT/Windows® 2000/
Windows® XP benötigen Sie Administrator-
rechte zur Installation!

Wählen Sie aus dem Startbildschirm System 
Installation. Das Installationsprogramm fragt, welche
Komponenten installiert werden sollen. Beantworten Sie
diese Fragen mit Ja bzw. Nein.

Installiert werden:

• Systemkonfigurator SyCon,
• OPC-Server,
• CIF Device Driver.

Wenn ein Lizenzcode im Lieferumfang mit enthalten ist,
finden Sie ihn für den Systemkonfigurator als Label auf
dieser CD oder in einem Briefumschlag ein Lizenzcode-
Anforderungsformular. Falls ein Lizenzcode vorhanden
ist, beantworten Sie die Frage nach einem vorhande-
nen Lizenzcode mit Ja, ansonsten wird eine Basis-
version des Systemkonfigurators installiert. Geben Sie
Ihren Namen und den Firmennamen ein. 

Installation 
des SoftSPS-Treibers
Die Beschreibung der Installation ist auf der CD in 
\DRIVER\SOFTPLC\ vorhanden. Zum Betrieb des
SoftSPS-Treibers ist eine Lizenz auf dem CIF 
notwendig.
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Installation des
Systemkonfigurators SyCon
Bei der Installation müssen Sie Ihren Namen und den
Firmennamen eingeben. 

Wenn ein Lizenzcode im Lieferumfang mit enthalten ist,
finden Sie ihn für den Systemkonfigurator als Label auf
dieser CD oder in einem Briefumschlag ein Lizenz-
code-Anforderungsformular. Falls ein Lizenzcode vor-
handen ist, beantworten Sie die Frage nach einem vor-
handenen Lizenzcode mit Ja, ansonsten wird eine
Basisversion des Systemkonfigurators installiert. Ihnen
stehen dann alle Funktionen zur Verfügung, jedoch ist
die Konfiguration auf zwei Geräte im Netzwerk
beschränkt, was für Slave-Teilnehmer ausreichend ist.

Unter dem Menüpunkt Hilfe > Lizenzierung können
Sie ein Bestellformular für Ihre Lizenz ausfüllen und an
Ihren Distributor oder direkt an uns faxen.

Folgen Sie den Anweisungen des Installationsprogram-
mes, wählen Sie die zu installierenden Feldbussysteme
aus und beantworten die Fragen mit JA oder WEITER.

Installation of the
System Configurator SyCon
During the installation the user and the company name
must be entered.

If a license code is included in the scope of delivery you
will find it for the System Configurator on a label on this
CD or in an envelope a license code request form. In
case you have a license code, answer the question for
an existing license code with Yes, otherwise a basic
version of the system configurator will be installed. In
this case, all functions are available, but the configu-
ration is limited to two devices on the network, which is
sufficient for slave devices.

A license can be ordered by filling out the order form
under the menu item Help > Licensing and fax this
order form either to your distributor or directly to us.

Follow the instructions of the installation program by
selecting the fieldbus system to be installed and
answer all questions by OK or NEXT.



24

Installation 
des OPC-Servers
Installieren Sie bei Windows® 98 die Betriebssystem-
erweiterung DCOM98. (Zu beziehen über 
www.microsoft.com/com/resources/download.asp
bzw. im Internet Explorer ab Version 4.0 enthalten)

Bei Windows® NT, Windows® 2000 und 
Windows® XP sind diese Erweiterungen bereits 
vorhanden. 

Installieren Sie den OPC-Server auf dem PC, in dem
das CIF installiert ist. 

Wenn der OPC-Client auf einem anderen PC ausge-
führt wird, dann installieren Sie zusätzlich auf diesem
PC den OPC-Server-Remote-PC.

Zum Betrieb des OPC-Servers ist eine Lizenz auf dem
CIF notwendig. Weitere Angaben zur Installation finden
Sie auf der CD in
\MANUAL\DEUTSCH\OPC\OPC_OID.PDF.

Installation 
of the OPC Server
For Windows® 98 install the operating system extensi-
on DCOM98. (Available on
www.microsoft.com/com/resources/download.asp
or components of the Internet Explorer from 
version 4.0)

In Windows® NT, Windows® 2000 and 
Windows® XP these extensions already exist. 

Install the OPC Server on the PC that has the CIF
installed. 

If the OPC Client is executed on another PC, then
install additionally OPC Server remote station on that
PC. 

To use the OPC Server a license on the CIF is 
necessary.
More information about the installation are on the CD in
\MANUAL\ENGLISH\OPC\OPC_OIE.PDF.
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Installation des
CIF Device Driver
Wählen Sie CIF Device Driver aus dem Installations-
menü oder starten Sie aus dem CD-Verzeichnis \Driver
das Programm Setup.exe.

Nach der Installation muss der CIF Device Driver
entsprechend des verwendeten CIFs konfiguriert 
werden.

Der Treiber akzeptiert maximal 4 Karten.

Konfiguration des 
CIF Device Driver
Starten Sie das Setup über Start > Programme > 
CIF Device Driver > CIF Device Driver Setup.

In den folgenden Abschnitten finden Sie eine Beschrei-
bung zur Konfiguration der von Ihnen verwendeten 
CIF-Karte unter dem von Ihnen verwendeten 
Betriebssystem.

ISA- und PC/104-Karten

ISA- und PC/104-Karten unter Windows® 2000/
Windows® XP

1. Öffnen Sie mit Systemsteuerung > System > 
Hardware > Hardware-Assistent den Windows® 2000
bzw. Windows® XP Hardware-Assistenten.

2. Wählen Sie Gerät hinzufügen bzw. Problem 
beheben.

3. Nach der automatischen Hardware-Erkennung
Suche nach neuen Hardwarekomponenten wählen
Sie Neues Gerät hinzufügen.

Installation of the
CIF Device Driver
Select CIF Device Driver in the installation menu or
start the program Setup.exe from the CD directory 
\Driver.

After the installation the CIF Device Driver has to be
configured according to the used CIF.

The driver accepts max. up to 4 cards. 

Configuration of the 
CIF Device Driver
Start the setup via Start > Programs > CIF Device 
Driver > CIF Device Driver Setup.

In the following sections you find a description of 
configuring the CIF card which is used by you under the
used operating system.

ISA and PC/104 Cards

ISA and PC/104 cards under Windows® 2000/
Windows® XP

1. Open the Windows® 2000 or the Windows® XP
Hardware Wizard with Control Panel > System >
Hardware > Hardware Wizard.

2. Choose Add/Troubleshoot a device.

3. After the automatic New Hardware Detection
choose Add new device.
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4. Wählen Sie Nein, die Hardwarekomponenten
selbst aus einer Liste auswählen. Klicken Sie entwe-
der auf Andere Geräte oder, falls vorhanden, auf 
CIF Communication Interface. Wählen Sie dann
Datenträger... und wechseln Sie zum CD-Verzeichnis
Driver\Win2000_XP\ISA oder, falls der Treiber bereits
installiert ist, in das Treiberinstallationsverzeichnis
...\Programme\CIF Device Driver\Win2000_XP\ISA.
Verfahren Sie bei CIF Communication Interface in glei-
cher Weise, wenn keine ISA-Karte zur Auswahl steht.

5. Wählen Sie, in Abhängigkeit der verwendeten Karte, 
CIF 10/30/40/104 (ISA-2KByte) oder 
CIF 10/30/40/104 (ISA-8KByte)

aus. Sie werden dann aufgefordert den Speicherbe-
reich und gegebenfalls den Interrupt des CIFs 
entsprechend der Hardwarevorgabe einzustellen. 

6. Nach den Einstellungen müssen Sie Ihren PC neu
starten.

HINWEIS: Standardmäßig ist die Adresse CA000 und
kein Interrupt eingestellt (Basis-Konfiguration 0). Zum
Ändern der Adresse wählen Sie Basis-Konfiguration 1.
Interrupt und Adresse können unter Basis-Konfigu-
ration 2 geändert werden. Weitere Hinweise finden Sie
auf der CD in \FAQ\DEUTSCH\ISA\isa_d.pdf. 

HINWEIS: Auf manchen PCs steht kein freier ISA-Spei-
cher im Bereich C0000-FF000 und kein ISA-Interrupt
zur Verfügung. Dies kann mit Windows® 2000 ACPI
(Advanced Configuration and Power Management
Interface) zusammenhängen. Überprüfen Sie zuerst,
ob Ihr PC ACPI-konform ist und ob Sie das aktuellste
BIOS des Mainboard-Herstellers verwenden. Sollte es
trotzdem keine freien ISA-Ressourcen geben, so kön-
nen Sie auch versuchen Windows® 2000 im „Standard
PC“-Modus (ACPI abgeschaltet) zu betreiben. Hierzu
muss die ACPI-HAL von Windows® 2000 durch die
STANDARD-PC-HAL ersetzt oder Windows® 2000 neu
installiert werden. Bitte kontaktieren Sie Microsoft zum
Vorgehen, da die Installation unbrauchbar werden kann.

4. Select No, I want to select the hardware from a
list. Now click on either Other devices or 
CIF Communication Interface if available. From Other
devices choose Have disk and change to the CD direc-
tory Driver\Win2000_XP\ISA or, if the driver is already
installed, to the driver installation directory 
...\Program Files\CIF Device Driver\Win2000_XP\ISA.
Proceed in the same manner if you can not find an
entry for a CIF ISA card under CIF Communication
Interface. 

5. Choose either
CIF 10/30/40/104 (ISA-2KByte) or 
CIF 10/30/40/104 (ISA-8KByte) 

depending on the hardware type. You will be asked to
set the memory area and if necessary to set an interrupt
both corresponding to the hardware settings of the CIF. 

6. After the settings you have to reboot the PC.

NOTE: The default setting is address CA000 and no
interrupt (Basis Configuration 0). To change the address
select Basis Configuration 1. The interrupt and the
address can be changed under Basis Configuration 2.
You will find more information on the CD in
\FAQ\ENGLISH\ISA\isa_e.pdf. 

NOTE: On some PCs it is not possible to find a free ISA
memory area between C0000-FF000 or a free ISA inter-
rupt in the device manager. This is Windows® 2000
ACPI (Advanced Configuration and Power Management
Interface) depending. Please check at first if your PC is
ACPI compatible and you are using the latest BIOS ver-
sion for your mainboard. Are there still problems to find
available ISA resources, you can try to run Windows®

2000 in “Standard PC” mode (ACPI disabled). There-
fore the ACPI-HAL of Windows® 2000 must be replaced
by the STANDARD-PC-HAL or Windows® 2000 must
be installed new. Please contact Microsoft how to 
change the Windows® 2000 HAL, because this can
make your installation unusable. 
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ISA- und PC/104-Karten unter Windows® 98/
Windows® ME/Windows® NT

Geben Sie die konfigurierte Startadresse des CIFs in
Dual-Port Memory base address und die Größe des
Dual-Port-Memory in Dual-Port Memory size ein. 

Betreiben Sie das CIF im Interrupt-Modus, dann ist in
Interrupt number der konfigurierte Interrupt anzuge-
ben, ansonsten ist Polling einzustellen.
Weitere Hinweise finden Sie auf der CD im Verzeichnis
\FAQ\DEUTSCH\ISA\isa_d.pdf.

PCI-Karten

PCI-Karten unter Windows® 2000/Windows® XP

1. PCI-Karten werden von Windows® 2000/
Windows® XP automatisch erkannt. Das System 
meldet sich mit Neue Hardware gefunden. Falls nicht,
starten Sie den Hardware-Assistenten unter
Systemsteuerung > System > Hardware > Hard-
ware-Assistent und wählen Sie Gerät hinzufügen
bzw. Problem beheben.

2. Windows® 2000/Windows® XP sucht nun nach
neuen Plug-and-Play-Geräten. Die PCI-Karte wird als
Anderes PCI-Brückengerät angezeigt.

3. Wählen Sie Nach einem passenden Treiber für
das Gerät suchen (empfohlen) und klicken Sie auf
Weiter.

4. Wählen Sie das CD-Verzeichnis
Driver\Win2000_XP\PCI oder, wenn der CIF Device
Driver bereits installiert ist, das Verzeichnis 
...\Programme\CIF Device Driver\Win2000_XP\PCI.

ISA and PC/104 cards under Windows® 98/
Windows® ME/Windows® NT

Enter the configured start address of the CIF into Dual-
Port Memory base address and the size of the Dual-
Port Memory into Dual-Port Memory size.

If an interrupt on the card has been set by means of a
jumper, then enter the same Interrupt number, if not
enter Polling.
You find more information on the CD in the directory
\FAQ\ENGLISH\ISA\isa_e.pdf. 

PCI Cards

PCI cards under Windows® 2000/Windows® XP

1. Windows® 2000/Windows® XP will recognize PCI
cards automatically during system startup. The system
will show New hardware found. If not choose the
Hardware Wizard under Control Panel > System >
Hardware > Hardware Wizard and select
Add/Troubleshoot a device.

2. Windows® 2000/Windows® XP searches for new
Plug and Play devices. The PCI card will be shown as
Other PCI Bridge Device.

3. Select Search for a suitable driver for my device
(recommended) and click Next.

4. Select on the CD the directory
Driver\Win2000_XP\PCI or if the CIF Device Driver is
already installed, the directory 
...\Programs\CIF Device Driver\Win2000_XP\PCI.
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5. Zeigt der Geräte-Manager bereits ein Anderes
Brückengerät an und ist dieses mit einem Fragezei-
chen/Ausrufezeichen markiert, klicken Sie das Gerät
mit der rechten Maustaste an und wählen Sie Deinstal-
lieren. Wiederholen Sie den Vorgang für all diese Geräte.

6. Wählen Sie dann Aktion > Nach geänderter Hard-
ware suchen aus dem Menü. Wenn das System Neue
Hardware gefunden meldet, verfahren Sie wie bereits
oben beschrieben. 

7. Das CIF wird standardmäßig im Polling-Modus 
installiert. Über das Programm CIF Device Driver
Setup kann der Interrupt-Modus ein- bzw. ausge-
schaltet werden. 

8. Nach dem Umstellen des Modus muss der PC neu
gestartet werden.

PCI-Karten unter Windows® 98/Windows® ME/
Windows® NT

Die Unterstützung von PCI-Karten muss im CIF Device
Driver aktiviert werden. Das Aktivieren und Deaktivieren
erfolgt mithilfe des Programms CIF Device Driver
Setup. Die benötigten Ressourcen werden vom PC
(BIOS) automatisch zugeteilt.

1. Starten Sie das Programm CIF Device Driver Setup
aus der Programmgruppe CIF Device Driver.

2. Im Menüpunkt PCI > Setup muss das Feld Activate
PCI support angehakt werden. Der Interruptbetrieb für
PCI-Karten wird mit Enable interrupt for board 0…3
ein- bzw. ausgeschaltet (Grundeinstellung: ausgeschaltet).

3. Setzen Sie alle Einstellungen für nicht installierte
ISA-Karten (Board 0 ... 3) auf 00000 bzw. NONE.

4. Starten Sie nach der Konfiguration Ihren PC neu.

5. If the device manager already shows Other Bridge
Device marked with a question/exclamation mark,
make a right mouse click on the device and choose
Uninstall. Proceed in the same way for all such cards.

6. After uninstallation choose Action > Scan for hard-
ware changes from the menu. When the system 
signals New hardware found follow the description
above. 

7. The CIF will be always installed in polling mode.
Using the CIF Device Driver Setup program the
interrupt mode can be enabled or disabled.

8. After changing the mode, you have to restart your
PC.

PCI cards under Windows® 98/Windows® ME/
Windows® NT

The driver support for PCI cards must be activated in
the CIF Device Driver. The activating and deactivating
is done with the help of the CIF Device Driver Setup
program. The required resources are assigned automa-
tically by the PC (BIOS). 

1. Start the program CIF Device Driver Setup of the
program group CIF Device Driver.

2. Select the menu PCI > Setup and check the
Activate PCI support field. Interrupt support for the
cards will be enabled or disabled by Enable interrupt
for board 0…3 (default: disabled).

3. Set all entries for not installed ISA cards 
(Board 0 ... 3) to 00000 respectively NONE.

4. Restart your PC after configuration.
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5. Während des Systemstarts werden die Konfigu-
rationsdaten vom CIF Device Driver ermittelt und vom
Programm CIF Device Driver Setup angezeigt. Der
Treiber verteilt die Board-Nummern der PCI-Karten
automatisch. Hierzu werden nur freie (unbenutzte)
Board-Nummern verwendet, wobei diese aufsteigend
von 0 bis 3 auf die PCI-Karten verteilt werden. Sind alle
Board-Nummern belegt, werden keine weiteren PCI-
Karten mehr vom Treiber akzeptiert.

HINWEIS: Kontrollieren Sie, ob im PC-BIOS genügend
Interrupte zur Nutzung für PCI-Karten freigegeben sind
und vermeiden Sie die Mehrfachnutzung mit anderen
PCI-Geräten (z. B. Netzwerkkarten, Soundkarten o. Ä.).

Bei Timeout-Fehlern (z. B. -17, -18, -20) zwischen
Anwendungsprogramm und CIF deaktivieren Sie den
PCI-Interrupt des CIFs.

Weitere Hinweise finden Sie auf der CD in
\FAQ\DEUTSCH\PCI\pci_d.pdf.

PCMCIA-Karten

PCMCIA-Karten unter Windows® 2000/Windows®XP

1. PCMCIA-Karten werden von Windows® 2000/
Windows® XP automatisch erkannt. Das System mel-
det sich mit Neue Hardware gefunden. Falls nicht,
starten Sie den Hardware-Assistenten unter System-
steuerung > System > Hardware > Hardware-Assis-
tent und wählen Sie Gerät hinzufügen bzw. Problem
beheben.

2. Windows® 2000/Windows® XP sucht nun nach
neuen Plug-and-Play-Geräten. Die PCMCIA-Karte wird
als Hilscher_GmbH CIF60-... angezeigt. 

3. Wählen Sie Nach einem passenden Treiber für
das Gerät suchen (empfohlen) und klicken Sie auf
Weiter.

5. During system start, the configuration data will be
determined by the CIF Device Driver and will be
shown in the CIF Device Driver Setup program. Also
the board numbers for PCI cards will be assigned auto-
matically by the driver. Therefore, the driver uses only
free (unused) board numbers in rising order from 0 to 3.
The driver does not accept additional PCI boards if all
board numbers are in use.

NOTE: Check your PC-BIOS if there are enough inter-
rupts configured for the use by PCI devices and avoid
multiple use of interrupts by different PCI devices 
(e. g. network cards, sound cards etc.).

If you encounter timeout errors between your applica-
tion program and the CIF card (e. g. -17, -18, -20) 
deactivate the PCI interrupt of the CIF card.

You find more information on the CD in
\FAQ\ENGLISH\PCI\pci_e.pdf.

PCMCIA Cards

PCMCIA cards under Windows® 2000/Windows® XP

1. Windows® 2000/Windows® XP will recognize 
PCMCIA cards automatically during system startup.
The system will show New Hardware Found. If not
choose the Hardware Wizard under Control Panel >
System > Hardware > Hardware Wizard and select
Add/Troubleshoot a device.

2. Windows® 2000/Windows® XP searches for new
Plug and Play devices. The CIF PCMCIA card will be
shown as Hilscher_GmbH CIF60-...

3. Select Search for a suitable driver for my device
(recommended) and click Next.
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4. Wählen Sie das CD-Verzeichnis
Driver\Win2000_XP\PCMCIA oder, wenn der CIF 
Device Driver bereits installiert ist, das Verzeichnis
...\Programme\CIF Device Driver\Win2000_XP\
PCMCIA aus.

HINWEIS: Sollte Ihr PC einen sog. PCMCIA-Socket-
Adapter verwenden, der ISA-Speicherbereiche benötigt,
so ist es möglich, dass der Geräte-Manager keine 
freien ISA-Bereiche findet. Das CIF wird dann mit 
UNKNOWN HARDWARE MANUFACTURE angezeigt.
Dies kann mit Windows® 2000 ACPI (Advanced Confi-
guration and Power Management Interface) 
zusammenhängen. Überprüfen Sie zuerst, ob Ihr PC
ACPI-konform ist und ob Sie das aktuellste BIOS des
Mainboard-Herstellers verwenden. Sollte es trotzdem
keine freien ISA-Ressourcen geben, so können Sie
auch versuchen Windows® 2000 im „Standard PC“-
Modus (ACPI abgeschaltet) zu betreiben. Hierzu muss
die ACPI-HAL von Windows® 2000 durch die STAN-
DARD-PC-HAL ersetzt oder Windows® 2000 neu instal-
liert werden. Bitte kontaktieren Sie Microsoft zur Vorge-
hensweise, da die Installation unbrauchbar werden
kann.

PCMCIA-Karten unter Windows® 98/Windows® ME
und Windows® NT

1. Windows® 98/Windows® ME erkennen bei einge-
schalteter PCMCIA-Funktion die Karte automatisch. Bei
jedem Hinzufügen und Entfernen des CIFs muss der
PC neu gestartet werden, damit auch der CIF Device
Driver die Karte erkennen kann.

2. Windows® NT benötigt zum Aktivieren von PCMCIA-
Karten eine spezielle Vorgehensweise. Die PCMCIA-
Dienste von Windows® NT müssen gestartet sein.
Wechseln Sie hierzu in die Systemsteuerung und 
öffnen Sie Geräte. Das Gerät PCMCIA muss den 
Status Gestartet und die Startart Neustart besitzen.
Falls nicht, ändern Sie die Startart auf Neustart.

4. Select from the CD the directory
Driver\Win2000_XP\PCMCIA or if the CIF Device 
Driver is already installed, the 
...\Programs\CIF Device Driver\Win2000_XP\PCMCIA
directory.

ATTENTION: If you are using PCMCIA socket adapter
which mappes the PCMCIA card to the ISA memory, on
some PCs it is not possible for the device manager to
find free ISA memory resource. The device will than be
shown as UNKNOWN HARDWARE MANUFACTURE.
This is Windows® 2000 ACPI (Advanced Configuraton
and Power Management Interface) depending. Please
check at first if your PC is ACPI compatible and you are
using the latest BIOS version for your mainboard. Are
there still problems to find available ISA resources, you
can try to run Windows® 2000 in “Standard PC” mode
(ACPI disabled). Therefore the ACPI-HAL of Windows®

2000 must be replaced with the STANDARD-PC-HAL or
Windows® 2000 must be installed new. Please contact
Microsoft how to change the Windows® 2000 HAL,
because this can make your installation unusable.

PCMCIA cards under Windows® 98/Windows® ME
and Windows® NT

1. Windows® 98/Windows® ME recognize automatically
the card if the PCMCIA functionality is activated. The
PC has to be restarted for each insert and remove of
the card for the CIF Device Driver to recognize the card.

2. In Windows® NT, PCMCIA boards needs a special
configuration. The PCMCIA services of Windows® NT
have to be activated. Therefore change to the control
panel and open Devices. The device PCMCIA must
have the state Started and the startup must have the
state Boot. If not change the startup to Boot.
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3. Aktivieren Sie bei Windows® NT die PCMCIA-Unter-
stützung des CIF Device Driver. Starten Sie das 
Programm CIF Device Driver Setup aus der Pro-
grammgruppe CIF Device Driver. Im Menüpunkt 
PCMCIA > Setup muss das Feld Activate PCMCIA
support angehakt werden. 

Die voreingestellte Dual-Port-Memory-Adresse (D4000)
muss nur bei Gerätekonflikten geändert werden. 

4. Setzen Sie alle Einstellungen für nicht installierte
ISA-Karten (Board 0 ... 3) auf 00000 bzw. NONE.

5. Starten Sie nach der Konfiguration Ihren PC neu. Bei
jedem Hinzufügen und Entfernen von CIF-Karten muss
der Rechner neu gestartet werden, damit der CIF 
Device Driver dies erkennen kann.

6. Während des Systemstarts werden die Konfigurati-
onsdaten vom CIF Device Driver ermittelt und vom Pro-
gramm CIF Device Driver Setup angezeigt. Der 
Treiber verteilt die Board-Nummern der PCMCIA-
Karten automatisch. Hierzu werden nur freie (unbenutz-
te) Board-Nummern verwendet, wobei diese aufstei-
gend von 0 bis 3 auf die PCMCIA-Karten verteilt 
werden. Sind alle Board-Nummern belegt, werden
keine weiteren PCMCIA-Karten vom Treiber akzeptiert.

HINWEIS: Deinstallieren Sie vorhandene „Card Wizard“
Programme 

Weitere Hinweise finden Sie auf der CD in
\FAQ\DEUTSCH\PCMCIA\pcmcia_d.pdf.

3. Activate in Windows® NT the PCMCIA support of the
CIF Device Driver. Start the program CIF Device Driver
Setup of the program group CIF Device Driver. Select
the menu PCMCIA > Setup and check the Activate
PCMCIA support box.

The pre defined dual-port memory address (D4000)
should only be changed if configuration conflicts occur.

4. Set all entries for not installed ISA cards 
(Board 0 ... 3) to 00000 respectively NONE.

5. Restart your PC after configuration. The computer
must be restarted at every adding and remove of CIF
cards so that the CIF Device Driver can recognize this.

6. During the start of the system all configuration data
will be determined by the CIF Device Driver und will be
shown by the CIF Device Driver Setup program. Also
the board number for PCMCIA cards will be automati-
cally assigned by the driver. Therefore, the driver uses
only free (unused) board numbers in rising order from 0
to 3. If all board numbers are in use then the driver
does not accept any additional PCMCIA cards.

NOTE: Deinstall existing Card Wizard programs. 

You find more information on the CD in
\FAQ\ENGLISH\PCMCIA\pcmcia_e.pdf.
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Aufrufen des 
CIF Device Driver
Von eigenen Windows®-Applikationen können Sie den
CIF Device Driver benutzen, um auf das Prozessabbild
bzw. die Mailbox im Dual-Port-Memory des CIFs zuzu-
greifen.

Das Manual DEVDRV.PDF beschreibt alle Funktionen
des CIF Device Driver und gilt für alle Feldbussysteme.
Die protokollspezifischen Befehle und Datenstrukturen
sind jeweils in einem eigenen Manual beschrieben,
siehe hierzu nachfolgende Tabelle.

Wenn Sie einen eigenen Treiber schreiben möchten,
unter MS/DOS oder einem anderen Betriebssystem
arbeiten, bieten wir das Toolkit CIF-TKIT mit C-Quell-
code, Beispielprogrammen und einer genauen
Definition des Dual-Port-Memory an.

Using the 
CIF Device Driver
From own Windows® application you can use the 
CIF Device Driver to get access on the process image
respectively the mailbox in the dual-port memory of the
CIF.

The manual DEVDRV.PDF describes all functions of the
CIF Device Driver and is valid for all fieldbus systems.
The protocol specific commands and data structures
are described presently in own manuals, please refer to
the following table.

If you wish to write your own driver or you are working
with MS/DOS or an other operating system, we offer the
tool kit CIF-TKIT with C-Source code, example program
and the exact definition of the dual-port memory.

Feldbus/Protokoll / Fieldbus/Protocol Manual
Programmieranleitung zum CIF Device Driver / DEVDRV.PDF 
How to use the CIF Device Driver and the demo files
PROFIBUS-FMS Master FMS_PIE.PDF
PROFIBUS-DP Master DPM_PIE.PDF
PROFIBUS-DP Slave DPS_PIE.PDF
InterBus Master IBM_PIE.PDF
InterBus Slave IBS_PIE.PDF
AS-Interface Master ASIM_PIE.PDF
CANopen Master COM_PIE.PDF
CANopen Slave COS_PIE.PDF
DeviceNet Master DNM_PIE.PDF
DeviceNet Slave DNS_PIE.PDF
ControlNet Master (Scanner) CNM_PIE.PDF
ControlNet Slave (Adapter) CNS_PIE.PDF
ASCII, 3964R, RK512, Modbus RTU, Modbus Plus, STD_PIE.PDF
Modnet 1/N, Modnet 1/SFB
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Konfiguration des 
CANopen-Netzwerks
CANopen-Master:

Mit dem Systemkonfigurator legen Sie mit Datei > Neu
> CANopen das Bussystem fest und wählen mit 
Einfügen > Master den verwendeten Master aus und
weisen diesem eine Knotenadresse zu.

Fügen Sie mit Einfügen > Knoten die am CANopen-
Netzwerk verwendeten Slaves in die Konfiguration ein
und vergeben die Knotenadressen.
Machen Sie einen Doppelklick auf die Knoten und konfi-
gurieren Sie die PDOs aller Geräte. Die Adressen im
Prozessabbild werden bei Autoadressierung ein vom
SyCon vergeben, andernfalls müssen Sie diese 
manuell eingeben.

Stellen Sie die Baudrate in Einstellungen > Buspara-
meter ein.

Stellen Sie mit Einstellungen > Gerätezuordnung ein,
über welchen Treiber der Systemkonfigurator mit dem
CIF kommunizieren kann.

Speichern Sie die Konfiguration zunächst auf dem PC
mit dem Menü Datei > Speichern und übertragen Sie
diese anschließend auf das Interface mit Online >
Download.

Überprüfen Sie die Kommunikation mit Online >
Debugmodus starten. Alle Buslinien der Knoten müs-
sen grün dargestellt werden. Wenn nicht, machen Sie
einen Doppelklick auf die Geräte mit roten Linien und
überprüfen Sie die Diagnosebits im Diagnosefenster. 
Sie zeigen Fehler grundsätzlicher Natur, wie zum 
Beispiel Keine Antwort oder Parametrierungsfehler.

Configuration of the
CANopen Network
CANopen Master:

In the System Configurator select the bus system with
File > New > CANopen. Select the used master with
Insert > Master and assign the node ID.

Insert the nodes used at the CANopen network into the
configuration with Insert > Node and assign the node
ID addresses.
Double click on the nodes and configure the PDOs of all
devices. The addresses of the process image are defin-
ed by SyCon if Auto addressing is on, otherwise the
addresses must be entered manually.

Set the baudrate in Settings > Busparameter.

Also assign in Settings > Device Assignment via
which driver SyCon will communicate to the CIF. 

Save the configuration at the PC with the menu item
File > Save and afterwards transfer it to the interface
with Online > Download.

Check the communication with Online > Start Debug-
mode. All lines to the nodes must be displayed green
color. If not, double click the red icons and check the
diagnostic bits in the diagnostic window. 
These bits indicate basic communication errors, like no
response or Parameterization fault.
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Zusätzlich liefert das Diagnosefenster detaillierte 
Fehlerinformationen im Klartext, wenn der Knoten im
Netzwerk gefunden werden konnte, aber dennoch ein
prinzipieller Fehler vorliegt, der den Betrieb nicht 
zulässt. Dieser könnte zum Beispiel ein Falsch konfi-
guriertes Object 1000H = Device-Typ sein.

CANopen-Slave (Knoten):

Mit dem Systemkonfigurator legen Sie mit Datei > Neu
> CANopen das Bussystem fest und wählen mit 
Einfügen > Master irgendeinen Master aus.

Fügen Sie mit Einfügen > Knoten den verwendeten
Knoten in die Konfiguration ein und weisen diesem eine
Knotenadresse zu.

Wählen Sie den Master mit einem linken Mausklick aus
und stellen Sie die Baudrate in Einstellungen >
Busparameter ein.

Stellen Sie mit Einstellungen > Gerätezuordnung ein,
über welchen Treiber der Systemkonfigurator mit dem
CIF kommuniziert.

Speichern Sie die Konfiguration zunächst auf dem PC
mit Datei > Speichern und übertragen sie diese an-
schließend auf das Interface mit Online > Download.

Hinweis: Die PDOs des Knotens werden im verwende-
ten CANopen-Master konfiguriert und über das 
CANopen-Netzwerk in den Knoten übertragen.

Futhermore you will find some detailed error information
in the window, if the node could be found in the net-
work, but principle errors prohibit the process data
exchange. Such an error for example could be a Wrong
configured Object 1000H = Devicetype.

CANopen Slave (Node):

In the System Configurator select the bus system with
File > New > CANopen. Select any master with Insert
> Master.

Insert the used node into the configuration with Insert >
Node and assign the node ID address.

Select the master with a left mouse click and then set
the baudrate in Settings > Busparameter.

Assign with Settings > Device Assignment via which
driver the System Configurator will communicate with
the CIF.

First save the configuration on the PC with File > Save
and afterwards transfer it into the interface via Online >
Download.

Note: The configuration of the PDOs of the Node are
configured in the used CANopen master and transfered
via the CANopen network into the node.
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Fehlersuche
Dual-Port Memory 
– Prüfen Sie, dass der von dem CIF benutzte Spei-
cherbereich im BIOS auf Shadow RAM disable ein-
gestellt ist.

– Prüfen Sie, ob die Adresseinstellung der ISA- und
PC/104-Karten mit der Einstellung im CIF Device
Driver Setup übereinstimmt.

– Prüfen Sie, dass die eingestellte Größe des Dual-
Port-Memory im CIF Device Driver Setup der
tatsächlichen Größe entspricht. 

– Prüfen Sie, dass kein Adresskonflikt mit anderen 
PC-Komponenten (z. B. SCSI-Controller) vorliegt.

– Weitere Hinweise finden Sie auf der CD in
\FAQ\DEUTSCH\ISA\ bzw. PCI bzw. PCMCIA.

Kabel 
– Prüfen Sie, dass die Pin-Belegung des verwendeten
Kabels richtig ist.

– Prüfen Sie, dass die Busterminierungswiderstände
am Anfang und am Ende der Leitung eingeschaltet
und bei allen anderen Steckern des Bussegmentes
ausgeschaltet sind.

Troubleshooting
Dual-Port Memory 
– Check if the memory area used by the CIF is set to

Shadow RAM disable in the BIOS. 
– Check if the address setting on the ISA- and PC/104
cards matchs with the setting in the CIF Device 
Driver Setup.

– Check that the dual-port memory size in the 
CIF Device Driver Setup is the same as the real
size.

– Check that there is no address conflict with another
PC component (e. g. SCSI controller). 

– More information are on the CD in
\FAQ\ENGLISH\ISA\ or PCI or PCMCIA.

Cable 
– Check that the pin occupation of the used cable is
correct.

– Check that the bus termination resistors are switched
on at the beginning and the end of the cable and are
switched off at all other connectors in the bus seg-
ment.
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Diagnose mit dem Systemkonfigurator beim
CANopen-Master
– Prüfen Sie mit Online > Live List, welche Knoten am
Bus vorhanden sind.

– Prüfen Sie mit Online > Debugmode starten, zu
welchen Knoten ein Nutzdatenaustausch (PDO-Kom-
munikation) stattfindet (grün dargestellte Linie zum
Symbol des Knoten).

– Zeigen Sie mit Online > Gerätediagnose die 
Diagnoseinformation des Knoten an.

– Benutzen Sie das Menü Online > EA-Monitor um
die Dateninhalte der PDOs zu prüfen.

– Prüfen Sie mit Online > Erweiterte Gerätediagnose
> CAN_Task CMS Domain Services, ob der Zähler
für Hard Transmission Aborts hochzählt, was
grundsätzliche Verdrahtungsfehler oder eine falsch
eingestellte Baudrate anzeigt.

– Prüfen Sie mit Online > Erweiterte Gerätediagnose
> CAN_Task Common Variables nach received
und sent messages, ob der Master Telegramme
empfängt und sendet.

Diagnose mit dem Systemkonfigurator beim
CANopen-Slave
– Prüfen Sie mit Online > Erweiterte Gerätediagnose

> COS_Task Common Variables, ob der Zähler für
Hard Transmission Aborts hochzählt, was
grundsätzliche Verdrahtungsfehler oder eine falsch
eingestellte Baudrate anzeigt.

– Prüfen Sie mit Online > Erweiterte Gerätediagnose
> COS_Task Common Variables nach received
und sent messages, ob der Knoten Telegramme
empfängt und sendet.

– Prüfen Sie mit Online > Erweiterte Gerätediagnose
> COS_Task PDO Transfer die PDO-Kommuni-
kation.

– Benutzen Sie das Menü Online > EA-Monitor um
die Dateninhalte der PDOs zu prüfen.

Diagnostic using the System Configurator at
CANopen Master
– Check which nodes are present on the bus using

Online > Live List.
– Check to which nodes a process data exchange
(PDO communication) is executed (green colored
line to the icon of the node) by using Online > Start
Debug Mode.

– Display the diagnostic information of a node using
Online > Device Diagnostic.

– Use the menu Online > IO-Monitor to check the
data contents of the PDOs.

– Check with the menu Online > Extended Device
Diagnostic > CAN_Task CMS Domain Services if
the counter for Hard Transmission Aborts counts
up which indicates basic wiring faults or wrong confi-
gured baud rate.

– Check with the menu Online > Extended Device
Diagnostic > CAN_Task Common Variables for
received and sent messages, if the master receives
and sends telegrams.

Diagnostic using the System Configurator at
CANopen Slave
– Check with the menu Online > Extended Device

Diagnostic > COS_Task Common Variables if the
counter for Hard Transmission Aborts counts up
which indicates basic wiring faults or wrong 
configured baud rate.

– Check with the menu Online > Extended Device
Diagnostic > COS_Task Common Variables for
received and sent messages, if the Node receives
and sends telegrams.

– Check with the menu Online > Extended Device
Diagnostic > COS_Task PDO Transfer the PDO
communication.

– Use the menu Online > IO-Monitor to check the
data contents of the PDOs.
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LED Zustand / State Bedeutung / Meaning

RDY Ein / On Gerät ist bereit / Device is ready

gelb / Blinkt zyklisch mit 5 Hz / Firmware-Download wird durchgeführt / 
yellow Flashing cyclic at 5 Hz Firmware download is in progress

Blinkt zyklisch mit 1 Hz / Gerät ist in Bootstraploadermodus und wartet auf Firmware-Download / 
Flashing cyclic at 1 Hz Device is in boot loader mode and is waiting for firmware download

Blinkt unregelmäßig (*) / Hardware- oder schwerer Systemfehler erkannt / 
Flashing irregular (*) Hardware or heavy runtime error detected

Aus / Off Versorgungsspannung für das Gerät fehlt oder Hardwaredefekt /
Device has no power supply or hardware defect

RUN Ein / On Kommunikation läuft, das Gerät hat mindestens eine Verbindung zu einem
grün / konfigurierten Teilnehmer aufgebaut / communication is running, 
green the device has established at least one configured fieldbus connection

Blinkt zyklisch mit 5 Hz / Kein Fehler in der Konfiguration, Kommunikation gestoppt (ERR-LED rot
Flashing cyclic at 5 Hz aus) oder bereit für Kommunikation, aber keine Verbindung zu einem

Knoten (ERR-LED rot an) / No error in configuration found, 
communication is stopped (ERR-LED red off) or ready for communication 
but no connection to any Node (ERR-LED red on)

Blinkt unregelmäßig (*) / Anlauf: Fehlende oder fehlerhafte Konfiguration, Inbetriebnahme nötig,
Flashing irregular (*) Laufzeit: Host-Watchdog-Zeitfehler / Power-up: Configuration missing or 

faulty, device needs commissioning, Runtime: Host watchdog timeout

Aus / Off Keine Kommunikation / No Communication

ERR Ein / On Gerät hat ein Kommunikationsproblem zu mindestens einem CANopen-
rot / red Knoten erkannt / Device has found a communication problem to at least 

one CANopen Node

Aus / Off Kein Fehler / No error

STA Ein / On Gerät sendet ein Telegramm / Device sends a telegram

gelb / Aus / Off Gerät ist empfangsbereit oder empfängt Telegramme /
yellow Device is ready to receive or is receiving telegrams

HS Ein / On Beim Einstecken und Entfernen des Geräts, während der Initialisierung / 
blau / blue During pluging in and removing the device, during initialization 

Aus / Off Initialisierung abgeschlossen / Initialization completed

(*) 3-mal schnell mit 5 Hz, 8-mal zwischen 0,5 Hz und 
1 Hz.

Hinweis: Die HS-LED ist ausschließlich auf der CIF 80
vorhanden.

(*) 3 times fast at 5 Hz, 8 times between 0.5 Hz and 
1 Hz.

Note: The HS-LED exists exclusively on the CIF 80.

LED-Anzeigen Master
CIF 30 / 50 / 60 / 80 / 104P / PMC:

LED Displays Master
CIF 30 / 50 / 60 / 80 / 104P / PMC:
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LED Zustand / State Bedeutung / Meaning 

SYS
Blinkt zyklisch mit 5 Hz / Firmware-Download wird durchgeführt / 
Flashing cyclic at 5 Hz Firmware download is in progress

Blinkt zyklisch mit 1 Hz / Gerät ist in Bootloadermodus und wartet auf Firmware-Download / 
Flashing cyclic at 1 Hz Device is in boot loader mode and is waiting for firmware download

Blinkt unregelmäßig (*) / Hardware- oder schwerer Systemfehler erkannt / 
Flashing irregular (*) Hardware or heavy runtime error detected

Ein / On Kommunikation läuft, das Gerät hat mindestens eine Verbindung zu einem
konfigurierten Teilnehmer aufgebaut / Communication is running, 
the device has established at least one configured fieldbus connection

Blinkt zyklisch mit 5 Hz / ERR-LED rot aus: Kein Fehler in der Konfiguration, 
Flashing cyclic at 5 Hz Kommunikation gestoppt, ERR-LED rot ein: Bereit für Kommunikation, 

aber keine Verbindung zu einem Slave / ERR-LED red off: No error 
in configuration found, communication is stopped, ERR-LED red on:
Ready for communication but no connection to any Slave

Blinkt unregelmäßig (*) / Anlauf: Fehlende oder fehlerhafte Konfiguration, Inbetriebnahme nötig, 
Flashing irregular (*) Laufzeit: Host-Watchdog-Timeout / Power-up: Configuration missing or 

faulty, device needs commissioning, Runtime: Host Watchdog timeout

Aus / Off Versorgungsspannung für das Gerät fehlt oder Hardwaredefekt /
Device has no power supply or hardware defect

COM
Ein / On Gerät sendet ein Telegramm / 

Device sends a telegram

Ein / On Gerät hat ein Kommunikationsproblem zu mindestens einem CANopen-
Knoten erkannt / Device has detected a communication problem to at 
least one CANopen node

Aus / Off Gerät ist empfangsbereit oder empfängt Telegramme /
Device is ready to receive or receiving telegrams

grün /
green

grün /
green

grün /
green

rot /
red

grün /
green

gelb /
yellow

gelb /
yellow

gelb /
yellow

(*) 3-mal schnell mit 5 Hz, 8-mal zwischen 0,5 Hz und 
1 Hz.

(*) 3 times fast at 5 Hz, 8 times between 0.5 Hz and 
1 Hz.

CIF 52-COM: CIF 52-COM:
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LED-Anzeigen Slave LED Displays Slave
LED Zustand / State Bedeutung / Meaning

RDY Ein / On Gerät ist bereit / Device is ready

gelb / Blinkt zyklisch mit 5 Hz / Firmware-Download wird durchgeführt / 
yellow Flashing cyclic at 5 Hz Firmware download is in progress

Blinkt zyklisch mit 1 Hz / Gerät ist in Bootstraploadermodus und wartet auf Firmware-Download / 
Flashing cyclic at 1 Hz Device is in boot loader mode and is waiting for firmware download

Blinkt unregelmäßig (*) / Hardware- oder schwerer Systemfehler erkannt / 
Flashing irregular (*) Hardware or heavy runtime error detected

Aus / Off Versorgungsspannung für das Gerät fehlt oder Hardwaredefekt /
Device has no power supply or hardware defect

RUN Ein / On Kommunikation läuft, Knoten ist im Zustand Operational / 
grün / Communication is running, Node is in state operational
green Blinkt zyklisch mit 5 Hz / Knoten ist im Zustand Preoperational (bzw. Prepared) /

Flashing cyclic at 5 Hz Node is in state preoperational (or prepared)

Blinkt unregelmäßig (*) / Anlauf: Fehlende oder fehlerhafte Konfiguration, Inbetriebnahme nötig,
Flashing irregular (*) Laufzeit: Host-Watchdog-Zeitfehler / Power-up: Configuration missing or 

faulty, device needs commissioning, Runtime: Host watchdog timeout

Aus / Off Keine Kommunikation / No Communication

ERR Ein / On Knoten hat den Zustand Operational verlassen /
rot / red Node has left the state operational

Aus / Off Kein Fehler / No error

STA Ein / On Gerät sendet ein Telegramm / Device sends a telegram

gelb / Aus / Off Gerät ist empfangsbereit oder empfängt Telegramme /
yellow Device is ready to receive or is receiving telegrams

HS Ein / On Beim Einstecken und Entfernen des Gerätes, während der Initialisierung / 
blau / blue During pluging in and removing the device, during initialization

Aus / Off Initialisierung abgeschlossen / Initialization completed

(*) 3-mal schnell mit 5 Hz, 8-mal zwischen 0,5 Hz und 
1 Hz.

Hinweis: Die HS-LED ist ausschließlich auf der CIF 80
vorhanden.

(*) 3 times fast at 5 Hz, 8 times between 0.5 Hz and 
1 Hz.

Note: The HS-LED exists exclusively on the CIF 80.
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Technische Daten
CIF 30 / 50 (*) / 104:

Technical Data
CIF 30 / 50 (*) / 104:

CANopen Master Knoten / Nodes max. 127
unterstützt / supported Min. Boot up, Emergency Message, 

Node-/Life Guarding, Heartbeat,
COB-ID Distribution, Event Trigger

PDO Modes async, cyclic, acyclic, remote requested

CANopen Slave Unterstützt / Supported: Min. Boot up, Emergency Message, 
Node-/Life Guarding, Heartbeat,
max. 32 Rx-/32 Tx-PDOs, Event Trigger

PDO Modes async, remote requested

Prozessabbild / Process Image Knoten / Node max. 510 Byte
Master max. 7168 Byte

Prozessor / Processor 16 Bit mit / with Interrupt- und / and DMA-Controller

Speicher / Memory CIF 30 / 50 (*) / 60 / 104-COS 8 KB DPM
CIF 30 / 50 (*) / 60 / 104-COM 8 KB DPM

ASIC SJA 1000

CANopen-Schnittstelle / Gemäß ISO 11898, max. 1 MBit/s, potentialfrei /
CANopen Interface According ISO 11898, max. 1 MBit/s, potential free

Diagnoseschnittstelle / RS-232C, potentialgebunden, DSub-Stecker 9-polig / 
Diagnostic Interface RS-232C, non isolated, DSub male connector 9 pin

Betriebsspannung / CIF 30-COS /-COM +5 V ± 5 % / 650 mA, ±12 V ±5% / 50 mA
Power Supply CIF 50-COS /-COM (*) +5 V ± 5 % / 650 mA, ±12 V ±5% / 50 mA

CIF 104-COS /-COM +5 V ± 5 % / 650 mA

Betriebstemp. / Operating Temp. 0 … 55 °C

Maße (L x B x H) / CIF 30-COS /-COM 134 x 107 x 20 mm ISA
Dimensions (L x W x H) CIF 50-COS /-COM 134 x 107 x 20 mm PCI

CIF 104-COS /-COM 90 x 96 x 23 mm PC/104

CE-Zeichen / CE-Zeichen EN 61000-6-4 für Emission / for emission
CE Indication EN 61000-6-2 für Störfestigkeit / for noise immunity

Hinweis (*): Die hier angegebenen technischen Daten
der CIF 50-COM bzw. CIF 50-COS beziehen sich auf
Revision 1 der Geräte. Angaben CIF 50-COM bzw. 
CIF 50-COS ab Revision 2 finden Sie auf der nächsten
Seite beschrieben.

Note (*): The technical data of the CIF 50-COM and
respectively CIF 50-COS indicated here refer to 
revision 1 of this devices. Data about the CIF 50-COM
and respectively CIF 50-COS starting from revision 2
are described on the next page.
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CANopen Master Knoten / Nodes max. 127, CIF 52-COM: 2 x max. 127
Unterstützt / Supported Min. Boot up, Emergency Message, 

Node-/Life Guarding, Heartbeat,
COB-ID Distribution, Event Trigger

PDO Modes async, cyclic, acyclic, remote requested

CANopen Slave Unterstützt / Supported Min. Boot up, Emergency Message, 
Node-/Life Guarding, Heartbeat,
max. 32 Rx- / 32 Tx-PDOs, Event Trigger

PDO Modes async, remote requested

Prozessabbild / Process Image Knoten / Node max. 510 Byte
Master max. 7168 Byte, CIF 52-COM: 2xmax. 7168 Byte

Prozessor / Processor EC1
Speicher / Memory 8 KByte DPM, CIF 52-COM: 2 x 8 KByte DPM
CANopen Schnittstelle / Gemäß ISO 11898, max 1 MBit/s, potentialfrei
CANopen Interface According ISO 11898, max 1 MBits/s, potential free
Diagnoseschnittstelle / RS-232C, potentialgebunden, DSub-Stecker 9-polig (nicht auf CIF 60,
Diagnostic Interface PMC-COM/-COS) / RS-232C, non isolated, DSub male connector 9 pin 

(not on CIF 60, PMC-COM/-COS)
Betriebsspannung / Power Supply CIF 50-COM /-COS (**) 3,3 V ± 5 % / 530 mA, 5 V ±5 % / 380 mA

CIF 52-COM 3,3 V ± 5 % / 1,1 A, 5 V ±5 % / 630 mA
CIF 60-COS /-COM +5 V ± 5 % / 650 mA
CIF 80-COS /-COM 3,3 V ± 5 % / 500 mA, 5 V ±5 % / 300 mA
CIF 104P-COS /-COM 3,3 V ± 5 % / 400 mA, 5 V ±5 % / 300 mA
PMC-COS /-COM 3,3 V ± 5 % / 400 mA, 5 V ±5 % / 300 mA

Betriebstemp. / Operating Temp. 0 ... 55 °C
Maße (L x B x H) / CIF 50-COS /-COM, CIF 52-COM 134 x 107 x 20 mm PCI
Dimensions (L x W x H) CIF 60-COS /-COM PCMCIA, Typ II PCMCIA

CIF 80-COS /-COM 160 x 100 x 20 mm Compact PCI
CIF 104P-COS /-COM 90 x 96 x 23 mm PC/104+
PMC-COS /-COM 153 x 74 x 13 mm PMC

CE-Zeichen / CE Indication CE-Zeichen EN 61000-6-4 für Emission / for emission
EN 61000-6-2 für Störfestigkeit / for noise immunity

Technische Daten
CIF 50 (**) / 52 / 60 / 80 / 104P / PMC:

Technical Data
CIF 50 (**) / 52 / 60 / 80 / 104P / PMC:

Hinweis (**): Die hier angegebenen technischen Daten
des CIF 50-COM bzw. CIF 50-COS beziehen sich auf
Geräte ab Revision 2. Angaben zum CIF 50-COM bzw.
CIF 50-COS mit Revision 1 finden Sie auf der vorherge-
henden Seite beschrieben.

Note (**): The technical data of the CIF 50-COM and
respectively CIF 50-COS indicated here refer to 
revision 2 of this devices. Data about the CIF 50-COM
and CIF 50-COS revision 1 can be found on the 
preceding page.
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Reserviert Reserved
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Exemption from Liability
The contents of this manual were checked for agreement
with the described hardware and software. However,
deviations may occur so that no guarantee can be made
for complete agreement with the documentation. 
However, the information in this manual is controlled
regularly. Necessary corrections are contained in the
following editions. We are grateful for improvement sug-
gestions.

Haftungsausschluss
Der Inhalt dieses Manuals wurde auf Übereinstimmung
mit der beschriebenen Hard- und Software geprüft.
Dennoch können Abweichungen nicht ausgeschlossen
werden, sodass wir für die vollständige Übereinstim-
mung keine Gewähr übernehmen. Die Angaben in die-
sem Manual werden jedoch regelmäßig überprüft. Not-
wendige Korrekturen sind in den nachfolgenden
Auflagen enthalten. Für Verbesserungsvorschläge sind
wir dankbar.
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Headquarters

Germany
Hilscher Gesellschaft für 
Systemautomation mbH
Rheinstrasse 15
65795 Hattersheim
Phone:  +49 (0) 6190 9907-0
Fax:    +49 (0) 6190 9907-50
E-Mail: info@hilscher.com
Web:    www.hilscher.com

World-wide: Distributors
Please visit our homepage on
www.hilscher.com 

Subsidiaries

France
Hilscher France S.a.r.l.
12, rue du 35 ième Régiment d`Aviation
Miniparc du Chêne 
69500 Bron
Phone:  +33 (0) 4 72 37 98 40
Fax:      +33 (0) 4 78 26 83 27
E-Mail:  info@hilscher.fr
Web:     www.hilscher.com

Italy
Hilscher Italia srl
Via Grandi, 25
20090 Vimodrone (MI)
Phone:  +39  02 25007068
Fax:      +39  02 25029973
E-Mail:  info@hilscher.it
Web:     www.hilscher.com

Japan
Hilscher Japan KK
YKB Shinjuku-Gyoen Bldg. 3F
1-3-8 Shinjuku, Shinjuku-ku 
Tokyo, 160-0022
Phone:  +81 (0) 3-5362-0521
Fax:      +81 (0) 3-5362-0522
E-Mail:  info@hilscher.jp
Web:     www.hilscher.com

Switzerland
Hilscher Swiss GmbH
Hubelmattstrasse 29
4500 Solothurn
Phone:  +41 (0) 32 623 6633
Fax:      +41 (0) 32 623 6632
E-Mail:  info@hilscher.ch
Web:     www.hilscher.com

USA
Hilscher North America, Inc.
Suite 100
2443 Warrenville Road
Lisle, IL 60532
Phone: +1  630-505-5301
Fax:      +1  630-505-7532
E-Mail:  info@hilscher.us
Web:     www.hilscher.com



CANopen

Bei weiteren Fragen wenden Sie sich

bitte an eine unserer Geschäftsstellen, 

Ihren lokalen Distributor

oder an unseren technischen Support:

If you have any question 

please contact our subsidiaries, 

your local distributor 

or our technical support:  

Phone: +49 (0) 6190 9907-99

E-Mail: hotline@hilscher.com
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